Closed Bug 1476200 Opened 2 years ago Closed 2 years ago

Deprecate DER_Lengths and remove usage

Categories

(NSS :: Libraries, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: franziskus, Assigned: franziskus)

References

Details

(Keywords: sec-want)

Attachments

(1 file)

Remove usage of DER_Lengths within NSS and deprecate the API.
Telemetry showed that DER_Lengths is hardly used and keeler removed it from PSM.
We can remove it from NSS as well.
Deprecating util functions is a little tricky so I didn't do that yet (they're always used in the wrapper, which breaks the build).
Keywords: sec-want
Comment on attachment 8992563 [details]
Bug 1476200 - remove usage of DER_Lengths, r=mt

Martin Thomson [:mt:] has approved the revision.

https://phabricator.services.mozilla.com/D2183
Attachment #8992563 - Flags: review+
https://hg.mozilla.org/projects/nss/rev/d80deec801102e7c5eb9e8fecdce72411be23b47
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Group: crypto-core-security → core-security-release
Group: core-security-release
You need to log in before you can comment on or make changes to this bug.