Closed Bug 1476271 Opened 3 years ago Closed 3 years ago

Perma Could not find com.google.android.gms:play-services-analytics:15.0.1.

Categories

(Firefox Build System :: Toolchains, defect, P5)

defect

Tracking

(firefox63 fixed)

RESOLVED FIXED
Tracking Status
firefox63 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: petru)

References

Details

(Keywords: intermittent-failure, Whiteboard: --do_not_change--[priority:high])

Attachments

(1 file)

Filed by: ebalazs [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=188547329&repo=try

https://queue.taskcluster.net/v1/task/SW9jXgTwTUmhUhJaFwiluQ/runs/0/artifacts/public/logs/live_backing.log

Could not find com.google.android.gms:play-services-analytics:15.0.1.
[task 2018-07-17T11:48:02.349Z]  0:51.76   Searched in the following locations:
[task 2018-07-17T11:48:02.349Z]  0:51.76       file:/builds/worker/workspace/build/src/android-sdk-linux/extras/m2repository/com/google/android/gms/play-services-analytics/15.0.1/play-services-analytics-15.0.1.pom
[task 2018-07-17T11:48:02.350Z]  0:51.76       file:/builds/worker/workspace/build/src/android-sdk-linux/extras/m2repository/com/google/android/gms/play-services-analytics/15.0.1/play-services-analytics-15.0.1.jar
[task 2018-07-17T11:48:02.350Z]  0:51.76       file:/builds/worker/workspace/build/src/android-sdk-linux/extras/google/m2repository/com/google/android/gms/play-services-analytics/15.0.1/play-services-analytics-15.0.1.pom
[task 2018-07-17T11:48:02.350Z]  0:51.76       file:/builds/worker/workspace/build/src/android-sdk-linux/extras/google/m2repository/com/google/android/gms/play-services-analytics/15.0.1/play-services-analytics-15.0.1.jar
[task 2018-07-17T11:48:02.350Z]  0:51.76       file:/builds/worker/workspace/build/src/android-sdk-linux/extras/android/m2repository/com/google/android/gms/play-services-analytics/15.0.1/play-services-analytics-15.0.1.pom
[task 2018-07-17T11:48:02.350Z]  0:51.76       file:/builds/worker/workspace/build/src/android-sdk-linux/extras/android/m2repository/com/google/android/gms/play-services-analytics/15.0.1/play-services-analytics-15.0.1.jar
[task 2018-07-17T11:48:02.350Z]  0:51.76       http://localhost:8081/nexus/content/repositories/jcenter/com/google/android/gms/play-services-analytics/15.0.1/play-services-analytics-15.0.1.pom
[task 2018-07-17T11:48:02.350Z]  0:51.76       http://localhost:8081/nexus/content/repositories/jcenter/com/google/android/gms/play-services-analytics/15.0.1/play-services-analytics-15.0.1.jar
[task 2018-07-17T11:48:02.350Z]  0:51.76       http://localhost:8081/nexus/content/repositories/google/com/google/android/gms/play-services-analytics/15.0.1/play-services-analytics-15.0.1.pom
[task 2018-07-17T11:48:02.351Z]  0:51.76       http://localhost:8081/nexus/content/repositories/google/com/google/android/gms/play-services-analytics/15.0.1/play-services-analytics-15.0.1.jar
[task 2018-07-17T11:48:02.351Z]  0:51.76   Required by:
[task 2018-07-17T11:48:02.351Z]  0:51.76       project :app
[task 2018-07-17T11:48:02.351Z]  0:51.76 * Try:
[task 2018-07-17T11:48:02.351Z]  0:51.76 Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
[task 2018-07-17T11:48:02.351Z]  0:51.76 ==============================================================================
[task 2018-07-17T11:48:02.351Z]  0:51.76 2: Task failed with an exception.
[task 2018-07-17T11:48:02.351Z]  0:51.76 -----------
[task 2018-07-17T11:48:02.351Z]  0:51.76 * What went wrong:
[task 2018-07-17T11:48:02.351Z]  0:51.77 Could not resolve all files for configuration ':app:officialWithoutGeckoBinariesNoMinApiPhotonDebugAndroidTestRuntimeClasspath'.
[task 2018-07-17T11:48:02.351Z]  0:51.77 > Could not find com.google.android.gms:play-services-analytics:15.0.1.
Summary: Intermittent Could not find com.google.android.gms:play-services-analytics:15.0.1. → Perma Could not find com.google.android.gms:play-services-analytics:15.0.1.
(In reply to Sebastian Hengst [:aryx] (needinfo on intermittent or backout) from comment #3)
> Hi Mihai, do you know what's wrong here? This permafails in beta simulatons,
> e.g.
> https://treeherder.mozilla.org/#/
> jobs?repo=try&revision=6c2769d59345c3ca122d7ac1c4a2ebc11220d179&filter-
> resultStatus=testfailed&filter-resultStatus=busted&filter-
> resultStatus=exception&filter-resultStatus=retry&filter-
> resultStatus=usercancel&filter-resultStatus=runnable&selectedJob=191134121

Hm, dug a bit but I have no ideas. Am slowly ramping up in Android and mobile world but I don't have expertise in this topic. Do you need someone specifically from RelEng? If so, I can try to poke other people with better knowledge than me to help.
Flags: needinfo?(mtabara)
Bug 1463376 increased the google play services version from 8.4.0 to 15.0.1:

https://hg.mozilla.org/mozilla-central/rev/267ff4f4ca9b#l1.12

Petru, do you have any idea why that change broke the gradle-dependencies job in the beta simulations? There are and have been some changes to beta simulations in place because they don't have access to the Adjust tokens, see https://hg.mozilla.org/try/rev/c71b2f6d020250736ae72f3b124b592f495a3708#l2.1
Blocks: 1463376
Flags: needinfo?(petru.lingurar)
Assignee: nobody → petru.lingurar
Status: NEW → ASSIGNED
Flags: needinfo?(petru.lingurar)
Whiteboard: --do_not_change--[priority:high]
(In reply to Sebastian Hengst [:aryx] (needinfo on intermittent or backout) from comment #5)
> Bug 1463376 increased the google play services version from 8.4.0 to 15.0.1:
> 
> https://hg.mozilla.org/mozilla-central/rev/267ff4f4ca9b#l1.12
> 
> Petru, do you have any idea why that change broke the gradle-dependencies
> job in the beta simulations? There are and have been some changes to beta
> simulations in place because they don't have access to the Adjust tokens,
> see
> https://hg.mozilla.org/try/rev/c71b2f6d020250736ae72f3b124b592f495a3708#l2.1

The issue I think stems from having builds with the MOZ_INSTALL_TRACKING flag.
That tries to add the 'play-services-analytics' dependency but there's no v. 15.0.1 of that.
Depends on: 1474859
Attachment #8996737 - Flags: review?(sdaswani) → review?(nchen)
Comment on attachment 8996737 [details]
Bug 1476271 - Perma Could not find com.google.android.gms:play-services-analytics:15.0.1;

https://reviewboard.mozilla.org/r/260788/#review267896
Attachment #8996737 - Flags: review?(nchen) → review+
Comment on attachment 8996737 [details]
Bug 1476271 - Perma Could not find com.google.android.gms:play-services-analytics:15.0.1;

https://reviewboard.mozilla.org/r/260788/#review268130

::: mobile/android/app/build.gradle:240
(Diff revision 1)
>          implementation "com.google.android.gms:play-services-base:$google_play_services_version"
>          implementation "com.google.android.gms:play-services-cast:$google_play_services_version"
>      }
>  
>      if (mozconfig.substs.MOZ_INSTALL_TRACKING) {
> -        implementation "com.google.android.gms:play-services-analytics:$google_play_services_version"
> +        implementation "com.google.android.gms:play-services-analytics:$google_play_services_analytics_version"

This should just be the advertising ID library, I think.  Report back from the other ticket!
After the fix from bug 1474859 I don't think the issue is reproducing anymore.
Aryx, can you confirm?
Flags: needinfo?(aryx.bugmail)
Yes, bug 1474859 turned it green, see e.g. https://treeherder.mozilla.org/#/jobs?repo=try&revision=06ec6e047de48334634241f89c918dded6e1a67f
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Flags: needinfo?(aryx.bugmail)
Resolution: --- → FIXED
Blocks: 1505514
No longer blocks: 1505514
See Also: → 1505514
You need to log in before you can comment on or make changes to this bug.