Closed Bug 1476471 Opened 2 years ago Closed 2 years ago

Intermittent w3c-css/received/css-writing-modes/text-indent-vrl-010.xht == w3c-css/received/css-writing-modes/text-indent-vrl-010-ref.xht | image comparison, max difference: 255, number of differing pixels: 5600

Categories

(Core :: Layout, defect, P5)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1392106

People

(Reporter: intermittent-bug-filer, Unassigned)

Details

(Keywords: intermittent-failure)

Filed by: aciure [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=188621506&repo=autoland

https://queue.taskcluster.net/v1/task/b34XuCdaQhWzwsYw8HH_Cg/runs/0/artifacts/public/logs/live_backing.log

https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://queue.taskcluster.net/v1/task/b34XuCdaQhWzwsYw8HH_Cg/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1

19:23:07     INFO -  REFTEST TEST-START | file:///Z:/task_1531851891/build/tests/reftest/tests/layout/reftests/w3c-css/received/css-writing-modes/text-indent-vrl-010.xht == file:///Z:/task_1531851891/build/tests/reftest/tests/layout/reftests/w3c-css/received/css-writing-modes/text-indent-vrl-010-ref.xht
19:23:07     INFO -  REFTEST TEST-LOAD | file:///Z:/task_1531851891/build/tests/reftest/tests/layout/reftests/w3c-css/received/css-writing-modes/text-indent-vrl-010.xht | 1115 / 1195 (93%)
19:23:07     INFO -  ++DOMWINDOW == 188 (0F018000) [pid = 3996] [serial = 2627] [outer = 00AC17A0]
19:23:07     INFO -  Could not create glyph run analysis.
19:23:07     INFO -  z:/build/build/src/gfx/skia/skia/src/ports/SkScalerContext_win_dw.cpp(498) : error 0x80070005: Access is denied.
19:23:07     INFO -  Requested bounding box could not be determined.
19:23:07     INFO -  z:/build/build/src/gfx/skia/skia/src/ports/SkScalerContext_win_dw.cpp(581) : error 0x80070005: Access is denied.
19:23:07     INFO -  REFTEST TEST-LOAD | file:///Z:/task_1531851891/build/tests/reftest/tests/layout/reftests/w3c-css/received/css-writing-modes/text-indent-vrl-010-ref.xht | 1115 / 1195 (93%)
19:23:07     INFO -  ++DOMWINDOW == 189 (0F018C00) [pid = 3996] [serial = 2628] [outer = 00AC17A0]
19:23:07     INFO -  REFTEST INFO | REFTEST fuzzy test (0, 0) <= (255, 5600) <= (255, 480)
19:23:07    ERROR -  REFTEST TEST-UNEXPECTED-FAIL | file:///Z:/task_1531851891/build/tests/reftest/tests/layout/reftests/w3c-css/received/css-writing-modes/text-indent-vrl-010.xht == file:///Z:/task_1531851891/build/tests/reftest/tests/layout/reftests/w3c-css/received/css-writing-modes/text-indent-vrl-010-ref.xht | image comparison, max difference: 255, number of differing pixels: 5600
19:23:07     INFO -  REFTEST TEST-END | file:///Z:/task_1531851891/build/tests/reftest/tests/layout/reftests/w3c-css/received/css-writing-modes/text-indent-vrl-010.xht == file:///Z:/task_1531851891/build/tests/reftest/tests/layout/reftests/w3c-css/received/css-writing-modes/text-indent-vrl-010-ref.xht
19:23:07     INFO -  ++DOMWINDOW == 190 (0E028800) [pid = 3996] [serial = 2629] [outer = 00AC17A0]
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: missing-letter-win7
Joel, can you explain to use why this is bug 1392106 and how to detect that?
Flags: needinfo?(jmaher)
I look at the reftest image:
https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://queue.taskcluster.net/v1/task/b34XuCdaQhWzwsYw8HH_Cg/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1

and then the test case, and saw that we load the FAIL background, but overwrite it with a 80px font size div:
https://searchfox.org/mozilla-central/source/layout/reftests/w3c-css/received/css-writing-modes/text-indent-vrl-010.xht#28

then we use that div and write a letter in this ahem/css font:
https://searchfox.org/mozilla-central/source/layout/reftests/w3c-css/received/css-writing-modes/text-indent-vrl-010.xht#49

in this case, it is just a letter missing.  Of course, maybe I understand this wrong, so please let me know if I am incorrect or not clear.
Flags: needinfo?(jmaher)
The other instances of bug 1392106 which I know of are not showing one or more letters of a text but the area which they would use isn't collapsed and the area has the correct size to fit the missing letter(s) - like just the print of the character is missing.

Here the missing character has more consequences than that the character is missing in the screenshot. Not sure if this is the same bug.
it could be a different bug, lets ask :jfkthame as he would be the expert.
Flags: needinfo?(jfkthame)
This does look a bit different, as the Ahem character (an 80px square) that should be hiding the "fail" background isn't completely absent, but seems to be partially drawn, or perhaps misplaced and clipped.

However, as it's a debug build, we can confirm from the log messages:

19:23:07     INFO -  Could not create glyph run analysis.
19:23:07     INFO -  z:/build/build/src/gfx/skia/skia/src/ports/SkScalerContext_win_dw.cpp(498) : error 0x80070005: Access is denied.
19:23:07     INFO -  Requested bounding box could not be determined.
19:23:07     INFO -  z:/build/build/src/gfx/skia/skia/src/ports/SkScalerContext_win_dw.cpp(581) : error 0x80070005: Access is denied.

that this really is still a symptom of the same kind of internal failure (possibly resource exhaustion?) inside DirectWrite. So I'm comfortable calling it a dupe of 1392106.
Flags: needinfo?(jfkthame)
You need to log in before you can comment on or make changes to this bug.