Closed Bug 1476520 Opened 3 years ago Closed 3 years ago

Address book import has many graphic anomalies

Categories

(Thunderbird :: Address Book, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 63.0

People

(Reporter: jorgk-bmo, Assigned: Paenglab)

Details

Attachments

(3 files)

Attached image addressbook import.png
I wanted to transfer an address book from one profile to the other using a CSV file. So I exported it and imported it.

The CSV import for the column matching is graphically completely broken, see attachment. Also, the import panel has the buttons cut off.

Tested with 63.0a1 (2018-07-17) (64-bit). Alice, can you please find the regression for us.
Flags: needinfo?(richard.marti)
Flags: needinfo?(alice0775)
Attached patch Bug1476520.patchSplinter Review
This fixes both, the too tall listbox which I made too tall in bug 1475817 and the transparent dialog.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Flags: needinfo?(richard.marti)
Attachment #8992902 - Flags: review?(jorgk)
Comment on attachment 8992902 [details] [diff] [review]
Bug1476520.patch

Looks good by visual inspection.
Attachment #8992902 - Flags: review?(jorgk) → review+
Keywords: checkin-needed
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/eaad7c4f5df4
Fix address book import glitches caused by bug 1475817 and bug 1469642. r=jorgk DONTBUILD
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 63.0
Comment on attachment 8992902 [details] [diff] [review]
Bug1476520.patch

This needs a partial backport.
Attachment #8992902 - Flags: approval-comm-beta+
Partial patch for beta with CustomHeaders.xul included where the same problem was.
Attachment #8992912 - Flags: approval-comm-beta?
Attachment #8992912 - Flags: approval-comm-beta? → approval-comm-beta+
Attachment #8992912 - Flags: approval-comm-beta+
Attachment #8992902 - Flags: approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.