Closed Bug 1476556 Opened Last year Closed Last year

quotation mark coming from <q> element should be language-specific

Categories

(Core :: Layout: Text and Fonts, defect)

61 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1421938

People

(Reporter: gunnar, Unassigned)

Details

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:61.0) Gecko/20100101 Firefox/61.0
Build ID: 20180704003137

Steps to reproduce:

<q> elements used in different languages, see https://codepen.io/gunnarbittersmann/pen/XBKwde


Actual results:

Firefox renders English quotation marks “” for all languages


Expected results:

Language-specific quotation marks should be rendered: e.g. „“ for German, „” for Polish, «» for Russian – like in Edge, IE, Safari, and Chrome.
screenshot with Chrome
screenshot with Chrome
Attachment #8992914 - Attachment is obsolete: true
Status: UNCONFIRMED → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1421938
You need to log in before you can comment on or make changes to this bug.