Homepage pref list options don't update when selected

VERIFIED FIXED in Firefox 63

Status

()

defect
P1
normal
VERIFIED FIXED
11 months ago
9 months ago

People

(Reporter: andreio, Assigned: ahillier)

Tracking

unspecified
Firefox 63
Points:
---

Firefox Tracking Flags

(firefox63 verified)

Details

Attachments

(1 attachment)

Reporter

Description

11 months ago
In about:preferences#home make sure you have the first option selected for the Homepage pref.
Switch to Blank page (#3rd option) and try switching back to first. Notice how switching to the first option requires you to select it a second time around for it to update.
It's not a dupe
Iteration: --- → 63.4 - Aug 20
Assignee

Comment 3

11 months ago
This seems to be a UI thing - for me if I click the first option once (so that it doesn't visually update and still shows the third option selected) but then open about:home or a new window, I get ActivityStream as expected. When focus is restored to about:preferences, the drop-down correctly shows the first option.
Comment hidden (mozreview-request)
Assignee

Updated

11 months ago
Assignee: nobody → ahillier

Comment 5

11 months ago
mozreview-review
Comment on attachment 8995656 [details]
Bug 1476594 - Fix default homepage selection in about:preferences

https://reviewboard.mozilla.org/r/260034/#review267098

Works for me and passes all the local in-content preferences tests, thanks Adam!
Attachment #8995656 - Flags: review?(usarracini) → review+

Comment 6

11 months ago
Pushed by usarracini@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c3309f635b90
Fix default homepage selection in about:preferences r=ursula

Comment 7

11 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/c3309f635b90
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63

Updated

11 months ago
Iteration: 63.4 - Aug 20 → 63.3 - Aug 6
Priority: -- → P1
Managed to reproduce issue on 63.0a1(19-07-2018).
Verified and confirmed fix with 63.0b12, 64.0a1 (2018-10-07) on Win10x64, macOS 10.11, Ubuntu 16.04.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.