Closed Bug 1476750 Opened 2 years ago Closed 2 years ago

Rename the preference media.webrtc.rsdparsa_enabled

Categories

(Core :: WebRTC: Signaling, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
mozilla63
Tracking Status
firefox63 --- fixed

People

(Reporter: johannes.willbold, Assigned: johannes.willbold)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Rename the preference "media.webrtc.rsdparsa_enabled" to "media.peerconnection.rsdparsa.enabled".
media.peerconnection.rsdpara.comapre
Status: UNCONFIRMED → NEW
Rank: 15
Ever confirmed: true
Priority: -- → P2
Lets actually use "media.peerconnection.sdp.rust.enabeld" and "media.peerconnection.sdp.rust.compare"
Comment on attachment 8995744 [details]
Bug 1476750: Updated preferences controlling Rust SDP Parse behavior,

https://reviewboard.mozilla.org/r/260112/#review267246

lgtm

::: commit-message-0e816:1
(Diff revision 1)
> +Bug 1476750: Renamed the preference media.webrtc.rsdparsa_enabled, r=dminor

The summary here should be something like "Updated preferences controlling Rust SDP Parse behavior" since you've changed more than one preference in this bug.

::: commit-message-0e816:4
(Diff revision 1)
> +Bug 1476750: Renamed the preference media.webrtc.rsdparsa_enabled, r=dminor
> +
> +Renamed the pref media.webrtc.rsdparsa_enabled to media.webrtc.rsdparsa_enabled
> +Added the pref media.peerconnection.rsdparsa.enabled

This should be: media.peerconnection.sdp.rust.compare

Please also mention that you're using it to control whether or not we compare rust and sdparsa results.
Attachment #8995744 - Flags: review?(dminor) → review+
Comment on attachment 8995744 [details]
Bug 1476750: Updated preferences controlling Rust SDP Parse behavior,

https://reviewboard.mozilla.org/r/260112/#review267370

Two more small fixes please.

::: media/webrtc/signaling/src/jsep/JsepSessionImpl.cpp:71
(Diff revision 2)
>    NS_ENSURE_SUCCESS(rv, rv);
>  
>    SetupDefaultCodecs();
>    SetupDefaultRtpExtensions();
>  
> -  mRunRustParser = Preferences::GetBool("media.webrtc.rsdparsa_enabled", false);
> +  mRunRustParser = Preferences::GetBool("media.peerconnection.rsdparsa.enabled",

I meant to use "sdp.rust" consistently for all prefs instead of "rsdparsa".

::: modules/libpref/init/all.js:424
(Diff revision 2)
>  pref("media.navigator.video.use_tmmbr", false);
>  pref("media.navigator.audio.use_fec", true);
>  pref("media.navigator.video.red_ulpfec_enabled", false);
>  
>  pref("media.peerconnection.dtmf.enabled", true);
> +pref("media.peerconnection.rsdparsa.enabled", false);

Replace "rsdparsa" with "sdp.rust" here as well.
Attachment #8995744 - Flags: review+
Pushed by drno@ohlmeier.org:
https://hg.mozilla.org/integration/autoland/rev/b57c92c69d8b
Updated preferences controlling Rust SDP Parse behavior, r=dminor,drno
https://hg.mozilla.org/mozilla-central/rev/b57c92c69d8b
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
Assignee: nobody → johannes.willbold
You need to log in before you can comment on or make changes to this bug.