Crash in java.lang.IllegalArgumentException: null notification at android.os.Parcel.readException(Parcel.java)

RESOLVED FIXED

Status

()

defect
P1
critical
RESOLVED FIXED
Last year
Last year

People

(Reporter: marcia, Assigned: vlad.baicu)

Tracking

({crash, regression})

Trunk
Unspecified
Android
Points:
---

Firefox Tracking Flags

(firefox61 unaffected, firefox62 unaffected, firefox63+ fixed)

Details

(Whiteboard: --do_not_change--[priority:high], crash signature)

This bug was filed from the Socorro interface and is
report bp-9d253b89-dada-4a55-958e-8fa630180718.
=============================================================

Seen while looking at nightly crash stats - crashes started using 20180717100050: https://bit.ly/2NqZHv7

6 crashes/3 installs so far. No comments. 

Java stack trace:

java.lang.IllegalArgumentException: null notification
	at android.os.Parcel.readException(Parcel.java:2009)
	at android.os.Parcel.readException(Parcel.java:1951)
	at android.app.IActivityManager$Stub$Proxy.setServiceForeground(IActivityManager.java:5752)
	at android.app.Service.startForeground(Service.java:699)
	at org.mozilla.gecko.media.MediaControlService.onStartCommand(MediaControlService.java:16)
	at android.app.ActivityThread.handleServiceArgs(ActivityThread.java:3474)
	at android.app.ActivityThread.-wrap20(Unknown Source:0)
	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1692)
	at android.os.Handler.dispatchMessage(Handler.java:106)
	at android.os.Looper.loop(Looper.java:164)
	at android.app.ActivityThread.main(ActivityThread.java:6494)
	at java.lang.reflect.Method.invoke(Native Method)
	at com.android.internal.os.RuntimeInit$MethodAndArgsCaller.run(RuntimeInit.java:438)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:807)
=============================================================
Not sure if this is related to the API upgrade but it did start happening around then.
Whiteboard: --do_not_change--[priority:high]
Assignee: nobody → vlad.baicu
Status: NEW → ASSIGNED
Re-triaging per https://bugzilla.mozilla.org/show_bug.cgi?id=1473195

Needinfo :susheel if you think this bug should be re-triaged.
Priority: -- → P5
Currently this is the #3 top browser crash on nightly, and flagged as a potential startup crash. 75 crashes/56 installs in the last seven days.

One comment: Nightly crashed upon me clearing a notification for audio that was playing. The audio was the clicking sound Facebook plays while choosing a reaction to a post.
(In reply to Firefox Product Integrity Bug Husbandry Bot (contact :emceeaich) from comment #2)
> Re-triaging per https://bugzilla.mozilla.org/show_bug.cgi?id=1473195
> 
> Needinfo :susheel if you think this bug should be re-triaged.

Given comment 3, not sure this should be P5.
Flags: needinfo?(sdaswani)
Flags: needinfo?(sdaswani)
Priority: P5 → P1
This signature hasn't had any crashes since 20180730100330. Recommend keeping open for another week to see if anything crops up again.
I agree with Marcia, the patch we've rolled out on https://bugzilla.mozilla.org/show_bug.cgi?id=1477041 should have also impacted/fixed this crash.
Closing this one out as resolved fixed. As noted in Comment 6, it appears the fix in that bug took care of it. The last crash I see in crash-stats is from 20180730221940.
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.