Closed Bug 1476790 Opened Last year Closed Last year

[RTL] Mirrored expander icons for folders in Bookmarks & History sidebars

Categories

(Toolkit :: Themes, defect, P2)

Unspecified
Windows
defect

Tracking

()

VERIFIED FIXED
mozilla63
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox61 --- unaffected
firefox62 + verified
firefox63 + verified

People

(Reporter: itiel_yn8, Assigned: Paenglab)

References

Details

(Keywords: regression, regressionwindow-wanted, rtl, Whiteboard: [fxsearch])

Attachments

(3 files, 1 obsolete file)

Attached image Screenshot
See attached. The arrow icon should point left in RTL locales.

Regression range is 2018-06-23 to 2018-06-24. Mozregression's output isn't really helpful:
2018-07-19T00:31:05: DEBUG : Starting merge handling...
2018-07-19T00:31:05: DEBUG : Using url: https://hg.mozilla.org/integration/mozilla-inbound/json-pushes?changeset=15c95df467be553beb39f2e8102c206639e05fde&full=1
2018-07-19T00:31:05: DEBUG : Found commit message:
 bug 1470306, DOMEventTargetHelper object should be kept alive while calling DisconnectFromOwner, r=bkelly

2018-07-19T00:31:05: INFO : The bisection is done.
2018-07-19T00:31:05: INFO : Stopped
Priority: -- → P3
Whiteboard: [fxsearch]
Taking the regression range as 2018-06-23 to 2018-06-24 gives https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=368ae05266bd2fefd96e6a1bd7b7e478749fcec3&tochange=15c95df467be553beb39f2e8102c206639e05fde

I'd hazard a guess that this is a regression from bug 1466826

Not sure if this should be tracked or not, so flagging anyway.
Blocks: 1466826
Flags: needinfo?(richard.marti)
Priority: P3 → --
Component: Bookmarks & History → Theme
OS: Unspecified → Windows
Component: Theme → Themes
Priority: -- → P2
Product: Firefox → Toolkit
Attached patch Bug1476790.patch (obsolete) — Splinter Review
Dumb typo where the letter d not arrived in the file. Sorry.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Flags: needinfo?(richard.marti)
Attachment #8994583 - Flags: review?(dao+bmo)
Attached patch Bug1476790.patchSplinter Review
Linux is also affected.
Attachment #8994583 - Attachment is obsolete: true
Attachment #8994583 - Flags: review?(dao+bmo)
Attachment #8994585 - Flags: review?(dao+bmo)
Attachment #8994585 - Flags: review?(dao+bmo) → review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/aef8309a42d0
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
Approval Request Comment
[Feature/Bug causing the regression]: bug 1466826
[User impact if declined]: twisties look the wrong direction for RTL users.
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: not yet
[Needs manual test from QE? If yes, steps to reproduce]: with to RTL set FX check that the closed twisty shows into the correct direction 
[Is the change risky?]: no
[Why is the change risky/not risky?]: one letter change
[String changes made/needed]: none

This patch is now Windows only because the Linux part landed in FX 63 (bug 1400266).
Attachment #8994853 - Flags: review+
Attachment #8994853 - Flags: approval-mozilla-beta?
Comment on attachment 8994853 [details] [diff] [review]
Bug1476790-beta.patch

Recent regression in 62, low risk, Beta62+
Attachment #8994853 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Looking good on latest Nightly.
I couldn't reproduce the bug. I used a Nightly version from 2018-07-18 on Windows 10 x64, Windows 7 x32, Windows 8.1 x32, Ubuntu 16.04 x64 and macOS 10.12. I used RTL builds just as ar, he and ja, but I still couldn't reproduce the issue.

Am I missing something? Or can you please verify if the bug is still reproducing on beta 62.0b12? 
Thank you.
Flags: needinfo?(itiel_yn8)
(In reply to Oana Botisan from comment #10)
> I couldn't reproduce the bug. I used a Nightly version from 2018-07-18 on
> Windows 10 x64, Windows 7 x32, Windows 8.1 x32, Ubuntu 16.04 x64 and macOS
> 10.12. I used RTL builds just as ar, he and ja, but I still couldn't
> reproduce the issue.
> 
> Am I missing something? Or can you please verify if the bug is still
> reproducing on beta 62.0b12? 
> Thank you.

You can reproduce this on 62.0b11
On an RTL build, simply open the Bookmarks/History sidebar and verify that the tree twisties are turning left instead of right.
It doesn't look like 62.0b12 is officialy out yet, but I have verified that the issue if fixed on latest Nightly.
Flags: needinfo?(itiel_yn8)
Thank you for the quick answer. 
I tried with beta 62.0b11 but I still couldn't reproduce.
Maybe when beta 62.0b12 is out, you could check the fix.
(In reply to Oana Botisan from comment #12)
> Thank you for the quick answer. 
> I tried with beta 62.0b11 but I still couldn't reproduce.
> Maybe when beta 62.0b12 is out, you could check the fix.

This looks okay also on 62.0b12.
Status: RESOLVED → VERIFIED
According to comment 13 and comment 9 I will take out the qe+ flag.
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.