Closed Bug 1476834 Opened 2 years ago Closed 2 years ago

Intermittent svg/text-gradient-04.svg == svg/text-gradient-04-ref.svg | image comparison, max difference: 255, number of differing pixels: 320

Categories

(Core :: SVG, defect, P5)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1392106

People

(Reporter: intermittent-bug-filer, Unassigned)

Details

(Keywords: intermittent-failure)

Filed by: cbrindusan [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=188859929&repo=mozilla-inbound

https://queue.taskcluster.net/v1/task/Q-AtWsBsSo-qiPJL4FZxaQ/runs/0/artifacts/public/logs/live_backing.log

https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://queue.taskcluster.net/v1/task/Q-AtWsBsSo-qiPJL4FZxaQ/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1

01:14:16     INFO -  REFTEST TEST-START | file:///Z:/task_1531959796/build/tests/reftest/tests/layout/reftests/svg/text-gradient-04.svg == file:///Z:/task_1531959796/build/tests/reftest/tests/layout/reftests/svg/text-gradient-04-ref.svg
01:14:16     INFO -  REFTEST TEST-LOAD | file:///Z:/task_1531959796/build/tests/reftest/tests/layout/reftests/svg/text-gradient-04.svg | 352 / 444 (79%)
01:14:16     INFO -  ++DOMWINDOW == 36 (0AF7EC00) [pid = 1168] [serial = 853] [outer = 010A37A0]
01:14:16     INFO -  REFTEST TEST-LOAD | file:///Z:/task_1531959796/build/tests/reftest/tests/layout/reftests/svg/text-gradient-04-ref.svg | 352 / 444 (79%)
01:14:16     INFO -  ++DOMWINDOW == 37 (0C6AD400) [pid = 1168] [serial = 854] [outer = 010A37A0]
01:14:16    ERROR -  REFTEST TEST-UNEXPECTED-FAIL | file:///Z:/task_1531959796/build/tests/reftest/tests/layout/reftests/svg/text-gradient-04.svg == file:///Z:/task_1531959796/build/tests/reftest/tests/layout/reftests/svg/text-gradient-04-ref.svg | image comparison, max difference: 255, number of differing pixels: 320
Dear Reader,

We are a joint research team from the University of Zurich, Switzerland* and Mozilla** and are building a tool to automatically recognize the type of an intermittent-failure, such as the one here.

By automatically recognizing the type of failure, the tool should provide a starting point for the bug fixing process. To evaluate and improve the tool, we kindly ask your feedback.
    
Tool Result - this intermittent-failure is most likely affected by a:
Assertion Failure (test vs. reference value): This includes test failures in which a (pre-) defined value was not met or the value that the test produced lies outside of the range of acceptable values. This often occurs when running reference tests (e.g. comparing images, audio, etc.). Also, this includes wrong assertion statements only leading to intermittent- and not permanent-failures.

Feedback: 
1. Did the tool correctly recognize the type of intermittent-failure? (please also explain why or why not)
2. Did the information from the tool help your analysis, the bug fixing process, or anything in the process? (please also let us know how the tool was useful and/or what would improve the tool's usefulness for you)

Thank you very much for your help! 
*Moritz, Fabio and Alberto (http://www.ifi.uzh.ch/en/zest/team.html)
**Marco Castellucio (https://marco-c.github.io/)
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: missing-letter-win7
You need to log in before you can comment on or make changes to this bug.