Closed Bug 1476927 Opened Last year Closed Last year

Perma /css/css-logical/animation-001.html | Logical longhands win over physical shorthands - Animation to or from an underlying value is not yet supported when Gecko 63 merges to Beta on 2018-08-27

Categories

(Core :: DOM: Animation, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla63
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox61 --- unaffected
firefox62 --- unaffected
firefox63 + fixed

People

(Reporter: RaulGurzau, Assigned: emilio)

References

Details

(Keywords: regression)

Attachments

(1 file)

[Tracking Requested - why for this release]:

Central as Beta sim:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=20a04997cec50341d5f8fc16b9d1a9e981c0c94f&filter-resultStatus=testfailed&filter-resultStatus=busted&filter-resultStatus=exception&filter-classifiedState=unclassified&selectedJob=188930687

Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=188930687&repo=try&lineNumber=3116

Log snippet:

[task 2018-07-19T11:31:51.556Z] 11:31:51     INFO - TEST-START | /css/css-logical/animation-001.html
[task 2018-07-19T11:31:51.573Z] 11:31:51     INFO - Setting pref dom.animations-api.core.enabled (true)
[task 2018-07-19T11:31:51.621Z] 11:31:51     INFO - PID 5246 | 1531999911616	Marionette	DEBUG	[2147483653] Frame script loaded
[task 2018-07-19T11:31:51.623Z] 11:31:51     INFO - PID 5246 | 1531999911619	Marionette	DEBUG	[2147483653] Frame script registered
[task 2018-07-19T11:31:51.765Z] 11:31:51     INFO - PID 5246 | 1531999911762	Marionette	DEBUG	[2147483656] Frame script loaded
[task 2018-07-19T11:31:51.798Z] 11:31:51     INFO - 
[task 2018-07-19T11:31:51.798Z] 11:31:51     INFO - TEST-PASS | /css/css-logical/animation-001.html | Logical properties can be animated using object notation 
[task 2018-07-19T11:31:51.799Z] 11:31:51     INFO - TEST-PASS | /css/css-logical/animation-001.html | Logical properties can be animated using array notation 
[task 2018-07-19T11:31:51.799Z] 11:31:51     INFO - TEST-PASS | /css/css-logical/animation-001.html | Logical properties are NOT stored as physical properties 
[task 2018-07-19T11:31:51.800Z] 11:31:51     INFO - TEST-PASS | /css/css-logical/animation-001.html | Logical properties in animations respect the writing-mode 
[task 2018-07-19T11:31:51.800Z] 11:31:51     INFO - TEST-PASS | /css/css-logical/animation-001.html | Logical properties in animations respect the direction 
[task 2018-07-19T11:31:51.800Z] 11:31:51     INFO - TEST-PASS | /css/css-logical/animation-001.html | Physical properties win over logical properties in object notation 
[task 2018-07-19T11:31:51.800Z] 11:31:51     INFO - TEST-PASS | /css/css-logical/animation-001.html | Physical properties win over logical properties in array notation 
[task 2018-07-19T11:31:51.800Z] 11:31:51     INFO - TEST-PASS | /css/css-logical/animation-001.html | Physical properties with variables win over logical properties 
[task 2018-07-19T11:31:51.800Z] 11:31:51     INFO - TEST-FAIL | /css/css-logical/animation-001.html | Logical shorthands follow the usual prioritization based on number of component longhands - Animation to or from an underlying value is not yet supported.
[task 2018-07-19T11:31:51.800Z] 11:31:51     INFO - @http://web-platform.test:8000/css/css-logical/animation-001.html:106:16
[task 2018-07-19T11:31:51.800Z] 11:31:51     INFO - Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:1538:20
[task 2018-07-19T11:31:51.801Z] 11:31:51     INFO - test@http://web-platform.test:8000/resources/testharness.js:545:9
[task 2018-07-19T11:31:51.801Z] 11:31:51     INFO - @http://web-platform.test:8000/css/css-logical/animation-001.html:104:1
[task 2018-07-19T11:31:51.801Z] 11:31:51     INFO - TEST-FAIL | /css/css-logical/animation-001.html | Physical longhands win over logical shorthands - Animation to or from an underlying value is not yet supported.
[task 2018-07-19T11:31:51.801Z] 11:31:51     INFO - @http://web-platform.test:8000/css/css-logical/animation-001.html:123:16
[task 2018-07-19T11:31:51.801Z] 11:31:51     INFO - Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:1538:20
[task 2018-07-19T11:31:51.802Z] 11:31:51     INFO - test@http://web-platform.test:8000/resources/testharness.js:545:9
[task 2018-07-19T11:31:51.802Z] 11:31:51     INFO - @http://web-platform.test:8000/css/css-logical/animation-001.html:121:1
[task 2018-07-19T11:31:51.804Z] 11:31:51     INFO - TEST-UNEXPECTED-FAIL | /css/css-logical/animation-001.html | Logical longhands win over physical shorthands - Animation to or from an underlying value is not yet supported.


This is a regression from Bug 1309752.
Flags: needinfo?(emilio)
I suspect this is related to the parts of WebAnimations we're intending to ship vs. not, likely just needs a pref flip.
Assignee: nobody → emilio
Flags: needinfo?(emilio)
Comment on attachment 8993427 [details] [diff] [review]
Enable dom.animations-api.implicit-keyframes.enabled for this test.

Review of attachment 8993427 [details] [diff] [review]:
-----------------------------------------------------------------

Yeah, I added those prefs after writing this patch (but before it landed) so there was a bit of unlucky timing.

We should probably set this pref in __dir__.ini but this is fine for now.
Attachment #8993427 - Flags: review?(bbirtles) → review+
Pushed by emilio@crisal.io:
https://hg.mozilla.org/integration/mozilla-inbound/rev/05b49818ba6a
Enable the pref for implicit keyframes in animation-001.html.ini. r=birtles
https://hg.mozilla.org/mozilla-central/rev/05b49818ba6a
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
:emilio the failure no longer appears on beta-sim on this specific file animation-001.html, but still occurs on a different one animation-003.tenative.html since yesterday's simulations, can you take a look?

Treeherder link: https://treeherder.mozilla.org/#/jobs?repo=try&revision=568e142efb2341632a696a3431b45e9dfd30cb12&filter-resultStatus=testfailed&filter-resultStatus=busted&filter-resultStatus=exception&filter-resultStatus=retry&filter-resultStatus=usercancel&filter-resultStatus=runnable&selectedJob=189326775 

Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=189405054&repo=try&lineNumber=3102

[task 2018-07-22T12:00:37.224Z] 12:00:37     INFO - TEST-OK | /css/css-logical/animation-002.html | took 506ms
[task 2018-07-22T12:00:37.228Z] 12:00:37     INFO - TEST-START | /css/css-logical/animation-003.tenative.html
[task 2018-07-22T12:00:37.284Z] 12:00:37     INFO - PID 5255 | 1532260837282	Marionette	DEBUG	[2147483662] Frame script loaded
[task 2018-07-22T12:00:37.288Z] 12:00:37     INFO - PID 5255 | 1532260837285	Marionette	DEBUG	[2147483662] Frame script registered
[task 2018-07-22T12:00:37.370Z] 12:00:37     INFO - 
[task 2018-07-22T12:00:37.371Z] 12:00:37     INFO - TEST-UNEXPECTED-FAIL | /css/css-logical/animation-003.tenative.html | Logical properties are represented as physical properties in keyframes - div.getAnimations is not a function
[task 2018-07-22T12:00:37.371Z] 12:00:37     INFO - @http://web-platform.test:8000/css/css-logical/animation-003.tenative.html:28:16
[task 2018-07-22T12:00:37.372Z] 12:00:37     INFO - Test.prototype.step@http://web-platform.test:8000/resources/testharness.js:1538:20
[task 2018-07-22T12:00:37.372Z] 12:00:37     INFO - test@http://web-platform.test:8000/resources/testharness.js:545:9
[task 2018-07-22T12:00:37.372Z] 12:00:37     INFO - @http://web-platform.test:8000/css/css-logical/animation-003.tenative.html:23:1
[task 2018-07-22T12:00:37.372Z] 12:00:37     INFO - TEST-OK | /css/css-logical/animation-003.tenative.html | took 145ms
[task 2018-07-22T12:00:37.389Z] 12:00:37     INFO - PID 5255 | 1532260837382	Marionette	INFO	Stopped listening on port 2828
[task 2018-07-22T12:00:37.571Z] 12:00:37     INFO - PID 5255 | JavaScript error: resource:///modules/AsyncTabSwitcher.jsm, line 250: TypeError: browser.frameLoader is null
[task 2018-07-22T12:00:37.889Z] 12:00:37     INFO - Browser exited with return code 0
[task 2018-07-22T12:00:37.890Z] 12:00:37  WARNING - u'runner_teardown': ()
[task 2018-07-22T12:00:37.898Z] 12:00:37     INFO - Setting up ssl
[task 2018-07-22T12:00:37.922Z] 12:00:37     INFO - certutil | 
[task 2018-07-22T12:00:37.950Z] 12:00:37     INFO - certutil | 
[task 2018-07-22T12:00:37.966Z] 12:00:37     INFO - certutil | 
[task 2018-07-22T12:00:37.967Z] 12:00:37     INFO - Certificate Nickname                                         Trust Attributes
[task 2018-07-22T12:00:37.967Z] 12:00:37     INFO -                                                              SSL,S/MIME,JAR/XPI
[task 2018-07-22T12:00:37.968Z] 12:00:37     INFO - 
[task 2018-07-22T12:00:37.968Z] 12:00:37     INFO - web-platform-tests                                           CT,, 
[task 2018-07-22T12:00:37.968Z] 12:00:37     INFO - 
[task 2018-07-22T12:00:37.984Z] 12:00:37     INFO - Application command: /builds/worker/workspace/build/application/firefox/firefox --marionette about:blank -profile /tmp/tmpI3RJGF.mozrunner
[task 2018-07-22T12:00:37.992Z] 12:00:37     INFO - Starting runner
[task 2018-07-22T12:00:39.684Z] 12:00:39     INFO - PID 5441 | 1532260839679	Marionette	INFO	Listening on port 2828
[task 2018-07-22T12:00:39.794Z] 12:00:39     INFO - PID 5441 | 1532260839787	Marionette	DEBUG	[2147483649] Frame script loaded
[task 2018-07-22T12:00:39.794Z] 12:00:39     INFO - PID 5441 | 1532260839788	Marionette	DEBUG	[2147483649] Frame script registered
[task 2018-07-22T12:00:39.828Z] 12:00:39     INFO - PID 5441 | 1532260839821	Marionette	DEBUG	[2147483649] Received DOM event beforeunload for about:blank
[task 2018-07-22T12:00:39.845Z] 12:00:39     INFO - PID 5441 | 1532260839835	Marionette	DEBUG	[2147483649] Received DOM event pagehide for about:blank
[task 2018-07-22T12:00:39.845Z] 12:00:39     INFO - PID 5441 | 1532260839835	Marionette	DEBUG	[2147483649] Received DOM event unload for about:blank
[task 2018-07-22T12:00:39.853Z] 12:00:39     INFO - PID 5441 | 1532260839851	Marionette	DEBUG	[2147483649] Received DOM event DOMContentLoaded for http://web-platform.test:8000/testharness_runner.html
[task 2018-07-22T12:00:39.889Z] 12:00:39     INFO - PID 5441 | 1532260839880	Marionette	DEBUG	[2147483649] Received DOM event pageshow for http://web-platform.test:8000/testharness_runner.html
Flags: needinfo?(emilio)
Sure, I'll push a fix here.
Flags: needinfo?(emilio)
Pushed by emilio@crisal.io:
https://hg.mozilla.org/integration/mozilla-inbound/rev/844d72890680
followup: Enable the pref for the whole subdirectory. r=me
I'm pretty sure animation-003 also needs getAnimations (bug 1477486).
You need to log in before you can comment on or make changes to this bug.