Closed Bug 1477149 Opened 2 years ago Closed 8 months ago

intermitent mochitest linux64 testing/mochitest/tests/python/test_build_profile.py::test_common_prefs_are_all_set ERROR

Categories

(Testing :: Mochitest, defect, P5)

Version 3
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1478050

People

(Reporter: dvarga, Unassigned)

References

Details

Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=189048260&repo=mozilla-central

Virtualenv location: /builds/worker/checkouts/gecko/obj-x86_64-pc-linux-gnu/_virtualenvs/gecko-QUm8IANb-2
[task 2018-07-19T22:32:08.859Z] running build_ext
[task 2018-07-19T22:32:08.859Z] copying build/lib.linux-x86_64-2.7/psutil/_psutil_linux.so -> psutil
[task 2018-07-19T22:32:08.859Z] copying build/lib.linux-x86_64-2.7/psutil/_psutil_posix.so -> psutil
[task 2018-07-19T22:32:08.859Z] 
[task 2018-07-19T22:32:08.859Z] Error processing command. Ignoring because optional. (optional:packages.txt:comm/build/virtualenv_packages.txt)
[task 2018-07-19T22:32:08.877Z] cat: backend.TestManifestBackend.in: No such file or directory
[task 2018-07-19T22:32:08.879Z] Build configuration changed. Regenerating backend.
[task 2018-07-19T22:32:09.366Z] No handlers could be found for logger "mozbuild.frontend.reader"
[task 2018-07-19T22:32:13.504Z] No build detected, test metadata may be incomplete.
[task 2018-07-19T22:32:15.207Z]  0:25.03 /builds/worker/checkouts/gecko/testing/mochitest/tests/python/test_build_profile.py
[task 2018-07-19T22:32:15.208Z]  0:25.03 ============================= test session starts ==============================
[task 2018-07-19T22:32:15.208Z]  0:25.03 platform linux2 -- Python 2.7.12, pytest-3.6.2, py-1.5.4, pluggy-0.6.0 -- /builds/worker/checkouts/gecko/obj-x86_64-pc-linux-gnu/_virtualenvs/gecko-QUm8IANb-2/bin/python
[task 2018-07-19T22:32:15.208Z]  0:25.03 rootdir: /builds/worker/checkouts/gecko, inifile: /builds/worker/checkouts/gecko/config/mozunit/mozunit/pytest.ini
[task 2018-07-19T22:32:15.208Z]  0:25.03 collecting ... collected 1 item
[task 2018-07-19T22:32:15.208Z]  0:25.03 
[task 2018-07-19T22:32:15.208Z]  0:25.03 testing/mochitest/tests/python/test_build_profile.py::test_common_prefs_are_all_set ERROR
[task 2018-07-19T22:32:15.208Z]  0:25.03 
[task 2018-07-19T22:32:15.208Z]  0:25.03 ==================================== ERRORS ====================================
[task 2018-07-19T22:32:15.208Z]  0:25.03 _______________ ERROR at setup of test_common_prefs_are_all_set ________________
[task 2018-07-19T22:32:15.208Z]  0:25.03 
[task 2018-07-19T22:32:15.208Z]  0:25.03 request = <SubRequest 'skip_using_mozinfo' for <Function 'test_common_prefs_are_all_set'>>
[task 2018-07-19T22:32:15.209Z]  0:25.03 setup_test_harness = <function inner at 0x7f3d5f943c80>
[task 2018-07-19T22:32:15.209Z]  0:25.03 
[task 2018-07-19T22:32:15.209Z]  0:25.03     @pytest.fixture(autouse=True)  # noqa: F811
[task 2018-07-19T22:32:15.209Z]  0:25.03     def skip_using_mozinfo(request, setup_test_harness):
[task 2018-07-19T22:32:15.209Z]  0:25.03         """Gives tests the ability to skip based on values from mozinfo.
[task 2018-07-19T22:32:15.209Z]  0:25.03 
[task 2018-07-19T22:32:15.210Z]  0:25.03         Example:
[task 2018-07-19T22:32:15.210Z]  0:25.03             @pytest.mark.skip_mozinfo("!e10s || os == 'linux'")
[task 2018-07-19T22:32:15.210Z]  0:25.03             def test_foo():
[task 2018-07-19T22:32:15.210Z]  0:25.03                 pass
[task 2018-07-19T22:32:15.210Z]  0:25.03         """
[task 2018-07-19T22:32:15.211Z]  0:25.03 
[task 2018-07-19T22:32:15.211Z]  0:25.03 >       setup_test_harness(*setup_args)
[task 2018-07-19T22:32:15.211Z]  0:25.03 
[task 2018-07-19T22:32:15.212Z]  0:25.03 testing/mochitest/tests/python/conftest.py:102:
[task 2018-07-19T22:32:15.213Z]  0:25.04 _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _
[task 2018-07-19T22:32:15.213Z]  0:25.04 
[task 2018-07-19T22:32:15.213Z]  0:25.04 files_dir = '/builds/worker/checkouts/gecko/testing/mochitest/tests/python/files'
[task 2018-07-19T22:32:15.214Z]  0:25.04 args = ('mochitest', 'testing/mochitest'), kwargs = {}
[task 2018-07-19T22:32:15.214Z]  0:25.04 harness_root = '/builds/worker/use-artifacts/build/tests/mochitest'
[task 2018-07-19T22:32:15.214Z]  0:25.04 test_root = '/builds/worker/use-artifacts/build/tests/mochitest/tests/selftests'
[task 2018-07-19T22:32:15.214Z]  0:25.04 
[task 2018-07-19T22:32:15.214Z]  0:25.04     def inner(files_dir, *args, **kwargs):
[task 2018-07-19T22:32:15.214Z]  0:25.04         harness_root = _get_test_harness(*args, **kwargs)
[task 2018-07-19T22:32:15.214Z]  0:25.04         if harness_root:
[task 2018-07-19T22:32:15.214Z]  0:25.04             sys.path.insert(0, harness_root)
[task 2018-07-19T22:32:15.214Z]  0:25.04 
[task 2018-07-19T22:32:15.214Z]  0:25.04             # Link the test files to the test package so updates are automatically
[task 2018-07-19T22:32:15.214Z]  0:25.04             # picked up. Fallback to copy on Windows.
[task 2018-07-19T22:32:15.214Z]  0:25.04             if files_dir:
[task 2018-07-19T22:32:15.214Z]  0:25.04                 test_root = os.path.join(harness_root, 'tests', 'selftests')
[task 2018-07-19T22:32:15.214Z]  0:25.04                 if not os.path.exists(test_root):
[task 2018-07-19T22:32:15.214Z]  0:25.04                     if hasattr(os, 'symlink'):
[task 2018-07-19T22:32:15.214Z]  0:25.04 >                       os.symlink(files_dir, test_root)
[task 2018-07-19T22:32:15.214Z]  0:25.04 E                       OSError: [Errno 17] File exists
[task 2018-07-19T22:32:15.215Z]  0:25.04 
[task 2018-07-19T22:32:15.215Z]  0:25.04 testing/mozbase/moztest/moztest/selftest/fixtures.py:63: OSError
[task 2018-07-19T22:32:15.215Z]  0:25.04 =========================== 1 error in 0.11 seconds ============================
[task 2018-07-19T22:32:15.215Z]  0:25.04 Setting retcode to 1 from /builds/worker/checkouts/gecko/testing/mochitest/tests/python/test_build_profile.py
[task 2018-07-19T22:32:15.415Z]  0:25.24 /builds/worker/checkouts/gecko/testing/mochitest/tests/python/test_get_active_tests.py
[task 2018-07-19T22:32:15.415Z]  0:25.24 ============================= test session starts ==============================
[task 2018-07-19T22:32:15.415Z]  0:25.24 platform linux2 -- Python 2.7.12, pytest-3.6.2, py-1.5.4, pluggy-0.6.0 -- /builds/worker/checkouts/gecko/obj-x86_64-pc-linux-gnu/_virtualenvs/gecko-QUm8IANb-2/bin/python
[task 2018-07-19T22:32:15.415Z]  0:25.24 rootdir: /builds/worker/checkouts/gecko, inifile: /builds/worker/checkouts/gecko/config/mozunit/mozunit/pytest.ini
[task 2018-07-19T22:32:15.415Z]  0:25.24 collecting ... collected 1 item
Duplicate of this bug: 1478181
Priority: -- → P5

Looking at the logs this seems very similar if not the same as Bug 1478050. Ahal, can we close this as a dupe?

Flags: needinfo?(ahal)

Yeah, good catch!

Status: NEW → RESOLVED
Closed: 8 months ago
Flags: needinfo?(ahal)
Resolution: --- → DUPLICATE
Duplicate of bug: 1478050
You need to log in before you can comment on or make changes to this bug.