Closed Bug 1477226 Opened 2 years ago Closed 2 years ago

Crash in SkCanvas::setMatrix

Categories

(Core :: Graphics: Layers, defect, critical)

62 Branch
Unspecified
Linux
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla63
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox61 --- unaffected
firefox62 --- unaffected
firefox63 --- fixed

People

(Reporter: calixte, Assigned: rhunt)

References

(Blocks 2 open bugs)

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is
report bp-8d7a0fc0-0fcc-4449-b2a0-eb9350180720.
=============================================================

Top 10 frames of crashing thread:

0 libxul.so SkCanvas::setMatrix 
1 libxul.so mozilla::gfx::DrawTargetSkia::SetTransform gfx/2d/DrawTargetSkia.cpp:2030
2 libxul.so mozilla::gfx::SetTransformCommand::ExecuteOnDT const gfx/2d/DrawCommands.h:1012
3 libxul.so mozilla::gfx::DrawTargetCaptureImpl::ReplayToDrawTarget gfx/2d/DrawTargetCapture.cpp:351
4 libxul.so mozilla::gfx::DrawTarget::DrawCapturedDT gfx/2d/DrawTarget.cpp:187
5 libxul.so mozilla::layers::CapturedTiledPaintState::Paint gfx/layers/PaintThread.cpp:126
6 libxul.so mozilla::layers::PaintThread::AsyncPaintTiledContents gfx/layers/PaintThread.cpp:457
7 libxul.so mozilla::detail::RunnableFunction<mozilla::layers::PaintThread::PaintTiledContents> >::Run gfx/layers/PaintThread.cpp:437
8 libxul.so nsThreadPool::Run 
9 libxul.so nsThread::ProcessNextEvent 

=============================================================

There is 1 crash in nightly 63 with buildid 20180719220047. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1471639.

[1] https://hg.mozilla.org/mozilla-central/rev?node=299faea63d79
Flags: needinfo?(rhunt)
There is a "spike" of crashes with signature matching regex Sk[A-Z]+.* in nightly with buildid 20180718220144 so just after the patch for bug 1471639 landed (see crash-stats at https://bit.ly/2uQAnqW).

buildid         # of crashes
-------         ------------

20180720101508 	5
20180719220047 	7
20180719100142 	4
20180718220144 	4
20180606220131 	1
20180606100133 	1
20180602100108 	1
20180601222241 	1
20180518222751 	1
20180517220057 	6
20180514100123 	1
Is it possible that bug 1471704 is at fault here? They landed very close to each other.

Bug 1471639 shouldn't affect linux as it changes behavior for a pref that's not enabled there (not that I'll say never when it comes to crashes). Bug 1471704 changed us to use a thread pool for painting which I feel is more likely to cause random crashes.

I'll still look through the crashes and see if I can figure anything out.
Assignee: nobody → rhunt
Flags: needinfo?(rhunt)
reverting affected status for 61 and 62 as per comment #1
I believe this to actually be caused by bug 1471704.
Blocks: 1471704
No longer blocks: 1471639
I'm going to close this assuming that the crashes are resolved since bug 1471704 has been backed out. Please reopen this if the crashes continue.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
You need to log in before you can comment on or make changes to this bug.