[Ubuntu] Unable to access some of the toolbar items after toggling the title bar

VERIFIED FIXED in Firefox -esr60

Status

()

defect
VERIFIED FIXED
9 months ago
7 months ago

People

(Reporter: Anca, Assigned: stransky)

Tracking

(Blocks 1 bug, {regression})

Trunk
mozilla63
All
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox-esr6063+ verified, firefox61 wontfix, firefox62 wontfix, firefox63 verified)

Details

Attachments

(1 attachment)

[Affected versions]: 
- 61.0.1 (20180704003137)
- 62.0b10 (20180719140244)
- 63.0a1 (2018-07-19)

[Affected platforms]:
- Ubuntu 16.04 x64
- Ubuntu 16.04 x32

[Steps to reproduce]:
1. Go to Menu - Customize
2. Deselect, than select the Title Bar checkbox
3. Click the Done button and enter the fullscreen
4. Click on any button on the right side of the toolbar  

[Expected result]:
- All buttons are functional, once are clicked.

[Actual result]:
- Nothing happens, the clicking action doesn’t trigger any response.

[Regression range]: 
- Mozregression points to bug 1417933 as the “culprit” of this behavior
Last good revision: 5a46db143897c53211818c722f15c510dd708c6c
First bad revision: 7d2121c8e0dd75cc48d8021ba55565889da8aac7
Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=5a46db143897c53211818c722f15c510dd708c6c&tochange=7d2121c8e0dd75cc48d8021ba55565889da8aac7

[Additional Notes]:
- When exit the fullscreen the buttons are funcional again
- Every item that is drag and drop inside the toolbar (only on the  toolbar’s right side) becomes unusable
- Page action/ Save to pocket/ Bookmark this page, inside the address bar are also affected
- I've reproduced this issue only on 16.04 on two test machines; Ubuntu 18.04 x64 and 14.04 x32 doesn’t seem to be affected.

Comment 1

9 months ago
Given the regressing bug was in gtk-land, I guess this should be too. Hopefully :stransky can take a look?
Component: Toolbars and Customization → Widget: Gtk
Flags: needinfo?(stransky)
Product: Firefox → Core
(Assignee)

Comment 2

9 months ago
Sure, I'll look at it.
Assignee: nobody → stransky
Flags: needinfo?(stransky)
(Assignee)

Comment 3

9 months ago
The "regression" is a bit inaccurate here IMHO as the referenced push just enabled titlebar rendering on Unity. Ubuntu 16.04 didn't have titlebar rendering before that patch.
(Assignee)

Updated

9 months ago
Blocks: gtktitlebar
(Assignee)

Comment 4

8 months ago
This bug does not depend on fullscreen mode. After toggling the titlebar the WM thinks that the Firefox window is smaller and click goes to underlying window. For instance when terminal is running on background on some places the cursor changes to text selection and after click the terminal is activated. Looks like a problem when new window is created in maximized mode but WM thinks it has a normal size.
Summary: [Ubuntu] Unable to access some of the toolbar items in fullscreen mode after toggling the title bar → [Ubuntu] Unable to access some of the toolbar items after toggling the title bar
(Assignee)

Comment 5

8 months ago
We need to use non-CSD mode for Unity desktop which works fine, tested on Ubuntu 16.04/Unity.
Comment on attachment 9005574 [details]
Bug 1477268 - Use window manager decorations instead of CSD mode on Unity, r=jhorak

Jan Horak [:jhorak] has approved the revision.
Attachment #9005574 - Flags: review+
(Assignee)

Updated

8 months ago
Keywords: checkin-needed

Comment 8

8 months ago
Pushed by ccoroiu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/da1a71bb37fd
Use window manager decorations instead of CSD mode on Unity, r=jhorak
Keywords: checkin-needed

Comment 9

8 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/da1a71bb37fd
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
Is this something likely to affect ESR60 users?
Flags: needinfo?(stransky)
(Assignee)

Comment 11

8 months ago
(In reply to Ryan VanderMeulen [:RyanVM] from comment #10)
> Is this something likely to affect ESR60 users?

Yes, it affects ESR60 users, we may uplift it there.
Flags: needinfo?(stransky)
(Assignee)

Comment 12

8 months ago
Comment on attachment 9005574 [details]
Bug 1477268 - Use window manager decorations instead of CSD mode on Unity, r=jhorak

[Approval Request Comment]
If this is not a sec:{high,crit} bug, please state case for ESR consideration: 
User impact if declined: broken parity-chrome feature
Fix Landed on Version: 63
Risk to taking this patch (and alternatives if risky): none
String or UUID changes made by this patch: none

See https://wiki.mozilla.org/Release_Management/ESR_Landing_Process for more info.
Attachment #9005574 - Flags: approval-mozilla-esr60?
Thanks, we'll revisit this request later into the cycle.
The issue is no longer reproducible on Firefox 63.0b4 (20180906162647) and Firefox 64.0 (20180907100116) on Ubuntu 16.04 platform.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Comment on attachment 9005574 [details]
Bug 1477268 - Use window manager decorations instead of CSD mode on Unity, r=jhorak

Fixes a Linux Chrome parity bug. Approved for ESR 60.3.
Attachment #9005574 - Flags: approval-mozilla-esr60? → approval-mozilla-esr60+
Flags: qe-verify+

Comment 17

7 months ago
The issue is no longer reproducible on Firefox 60.2.3esr (20181004210422).
Flags: qe-verify+
QA Contact: jmathies
QA Contact: jmathies
You need to log in before you can comment on or make changes to this bug.