Closed Bug 1477454 Opened 2 years ago Closed 2 years ago

WebExtensions experience is poor because Firefox allows what the user is interacting with to be starved of resources

Categories

(WebExtensions :: Untriaged, defect)

62 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1357487

People

(Reporter: from_bugzilla2, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:62.0) Gecko/20100101 Firefox/62.0
Build ID: 20180713213322

Steps to reproduce:

1. Install Tree Style Tab and Download Star
2. Load a bunch of other tabs and extensions to bog down the browser (If it helps, I typically run it on Kubuntu Linux 14.04 LTS on an Athlon II X2 270 (dual-core) with a copy of Firefox 52 ESR and a copy of Chromium running in the background.)
3. Middle-click a lot of links in rapid succession
4. Try clicking a tab in the Tree Style Tab sidebar to switch to it
5. Try middle-clicking a tab in the Tree Style Tab sidebar to close it
6. Try Clicking the Download Star browser action


Actual results:

If I've just middle-clicked a bunch of links, the Tree Style Tab sidebar's click handlers may take several second to fire, while interacting with the native tab bar continues to remain responsive, never taking more than a second to respond, even when bogged down.

Also, about half the time, opening Download Star on a page for the first time will get stuck in the screenshotted state for several seconds before the JavaScript-based templating engine runs.

In my browser, the Download Star issue occurs even when no pages are still loading.


Expected results:

Firefox's scheduler should give more priority to user-triggered event handlers set by WebExtensions and to content within an open browser/page action popup.
Summary: WebExtensions experience is poor because Firefox allows what the user is interacting with to be starved for resources → WebExtensions experience is poor because Firefox allows what the user is interacting with to be starved of resources
Product: Firefox → WebExtensions
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1357487
Would turning on OOP extensions guarantee that every extension gets its own process?

If not, that doesn't really prevent another WebExtension from starving the one the user is actively interacting with.
You need to log in before you can comment on or make changes to this bug.