Clearing all history does not reset zoom setting of sites since FF62

VERIFIED FIXED in Firefox 62

Status

()

defect
P1
major
VERIFIED FIXED
9 months ago
9 months ago

People

(Reporter: pevar, Assigned: baku)

Tracking

(Blocks 1 bug, {regression})

62 Branch
mozilla63
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox61 unaffected, firefox62 verified, firefox63 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 months ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20180721220720

Steps to reproduce:

Open any site including this page,

increase or decrease zoom size of the page.

clear all history -everything 


Actual results:

zoom setting is retained


Expected results:

Like before everything should have been reset to defaults
(Reporter)

Comment 1

9 months ago
Bug 1473275
 

might have caused this regression
Flags: needinfo?(paolo.mozmail)
Flags: needinfo?(jhofmann)
(Reporter)

Updated

9 months ago
Severity: normal → major
Has Regression Range: --- → yes
Has STR: --- → yes
OS: Unspecified → All
Hardware: Unspecified → All
Comment hidden (obsolete)

Updated

9 months ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

9 months ago
Flags: needinfo?(paolo.mozmail)

Comment 3

9 months ago
regression-window
(In reply to Gingerbread Man from comment #2)
> Yes, this peculiar regression range from mozregression-gui is correct.

Sorry about the noise. That range is actually incorrect. Bug 1477781 filed to investigate what went wrong there.

If I select the last good build in mozregression-gui, that push log link includes bug 1422365, which is bound to be it.

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=8c926373039374cd1a47d92215e9efb4d5557983&tochange=1f62ecdf59b6ecaa3c0fdda39bb296ec092a156b

> I double-checked by manually testing the "first release with" and "last
> release without" builds.

Those were nightly builds and therefore don't pinpoint a single bug.
Blocks: 1422365
No longer blocks: 1460617
Component: Security: PSM → Data Sanitization
Flags: needinfo?(dkeeler) → needinfo?(amarchesini)
Product: Core → Toolkit
(Assignee)

Comment 4

9 months ago
Posted patch pref.patchSplinter Review
Assignee: nobody → amarchesini
Flags: needinfo?(jhofmann)
Flags: needinfo?(amarchesini)
Attachment #8994764 - Flags: review?(jhofmann)

Updated

9 months ago
Status: NEW → ASSIGNED
(Reporter)

Updated

9 months ago
Priority: -- → P1

Comment 5

9 months ago
Comment on attachment 8994764 [details] [diff] [review]
pref.patch

Review of attachment 8994764 [details] [diff] [review]:
-----------------------------------------------------------------

Stealing, r=me
Attachment #8994764 - Flags: review?(jhofmann) → review+
Blocks: 1479513

Comment 6

9 months ago
Pushed by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/61f9854c9a74
Sanitizer.jsm must cleanup content preferences, r=Gijs

Comment 7

9 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/61f9854c9a74
Status: ASSIGNED → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla63

Comment 8

9 months ago
Comment on attachment 8994764 [details] [diff] [review]
pref.patch

Approval Request Comment
[Feature/Bug causing the regression]: bug 1422365
[User impact if declined]: clear recent history doesn't work as designed/expected
[Is this code covered by automated tests?]: there are some tests, but it looks like they're not sufficient to have caught this in automation...
[Has the fix been verified in Nightly?]: not yet
[Needs manual test from QE? If yes, steps to reproduce]: yes, see comment 0
[List of other uplifts needed for the feature/fix]: no
[Is the change risky?]: no
[Why is the change risky/not risky?]: 1-line change fixing a simple typo
[String changes made/needed]: no
Attachment #8994764 - Flags: approval-mozilla-beta?
Comment on attachment 8994764 [details] [diff] [review]
pref.patch

Recent regression, low-risk, Beta62+
Attachment #8994764 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Reproduced the issue on an affected build: 62.0b10/20180719140244 - Windows 8.1 x64.

Verified as fixed on:
62.0b14 2018-08-02
63.0a1 	2018-08-05

using environments:
Windows 8.1 x64
Windows 10 x64
Osx 10.13
Ubuntu 16.04

Based on the above, marking this issue as verified fixed.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.