Omitting last page of a set for printing

VERIFIED WORKSFORME

Status

()

Core
Printing: Output
VERIFIED WORKSFORME
16 years ago
15 years ago

People

(Reporter: Lincoln Ong, Assigned: rods (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Using the above URL as an example, which should print three pages, only the first
two pages are printed, when the output is directed to a HP LaserJet 4000N.  This
same URL is printed correctly with Netscape 4.79.

Comment 1

16 years ago
WFM. we tried on windows and linux and we got 4 pages
of output...we are using 5/29 builds..

you might be using an older build....please upgrade...
(Reporter)

Comment 2

16 years ago
Hello:
     The printing problem still exists with yesterday's build
(2002-05-29-08-trunk).  It appears that the generation of the postscript
with the font selections may be at fault.  Here is some additional
information.

Here are the font settings:
   Western
     Proportional: San Serif 13
     Serif:        adobe-times-iso8859-1
     Sans-Serif:   adobe-helvetica-iso8859-1
     Cursive:      adobe-arial-iso8859-1
     Fantasy:      adobe-arial-iso8859-1
     Monospace:    adobe-courier-iso8859-1 11
   Minimum font size: none
   Allow documents to use other fonts: unchecked
   Display resolution: 80dpi

From running this build of Mozilla from the command line,
the following error message was noted on stdout:

   NO FONT WAS FOUND

With Postscript error message printing enabled on the printer,
the following was displayed:

   ERROR: timeout
   OFFENDING COMMAND: timeout
   STACK:
   242

Comment 3

16 years ago
bz, what do you think ?
I think printing to a file and seeing what gv or another similarly full-
featured and lenient postscript viewer shows would be a start...  Also, if we 
really want to decide whether this is a problem in PS generation or layout, we 
should print with XPrint and see what happens.

Comment 5

16 years ago
bz:
> we should print with XPrint and see what happens.

CC:'ing me helps to speed things up... :)))))

Comment 6

16 years ago
Created attachment 85852 [details]
Testcase (http://melvin.hadasht.free.fr/home/sylpheed/actions/) printed with Xprint module (300 DPI, DIN-A4)

Reporter:
Does this PostScript job print OK for you ?
(Reporter)

Comment 7

16 years ago
As I do not currently have XPrint, I cannot tell you what the results are.
(Getting a copy of the source at this time is extremely slow via CVS.)
However, I have examined the Postscript generated via a "Print To: File",
using Ghostscript (GS).  GS displays the output correctly.  There is the
error messages: of:
   ERROR: timeout
   OFFENDING COMMAND: timeout

   STACK:

   (e )

as a Postscript error, but all three of the expected three pages are
printed correctly.

Comment 8

16 years ago
Lincoln Ong wrote:
> As I do not currently have XPrint, I cannot tell you what the results are.
> (Getting a copy of the source at this time is extremely slow via CVS.)

Uhm... the tree in the CVS is not fully initalised yet... but the page has links
to the Linux x86 binary tarball which comes with everything you need (except the
fonts... :) ...

Comment 9

16 years ago
Lincoln Ong wrote:
> As I do not currently have XPrint, I cannot tell you what the results are.

You could at least try the sample output job created with Xprint I attached here
(http://bugzilla.mozilla.org/attachment.cgi?id=85852&action=view) ... :)
(Reporter)

Comment 10

16 years ago
Hello Roland:
     Your attached sample output, all four pages, did print correctly.  However,
your font selections (which appear to be the Mozilla default) are different
from my test case, which should produce three pages.

Comment 11

16 years ago
Lincoln Ong wrote
> Your attached sample output, all four pages, did print correctly.  However,
> your font selections (which appear to be the Mozilla default) are different
> from my test case,

Can you little bit more specific ?
What do you mean with "your font selections are different from my test case" ?

> which should produce three pages.

Do you use any CSS stuff which says "create only three pages" ?
Otherwise Mozilla's layout subsystem decides itself when it adds a page break -
and since Xprint seems to use slightly larger fonts (which does not mean the
Xprint module is wrong - it tries to do _exactly_ what layout code wants from it
(therefore I guess the slighly smaller output from the PostScript module is a
bug in that module... =:-)) than the PostScript module in this case the text
needs more space and layout code decides to put some data on a new page.
(Reporter)

Comment 12

16 years ago
Hello Roland:
     Sorry I wasn't more specific.  For the font selection, I was referring to
the font selection that I have set (see comment #2).  I am not using any CSS
to force the number of pages; I came up with this total by both my attempts to
print the webpage and saving the Postscript.  With the Postscript output, 
Ghostscript displays the three pages and prints the three pages as expected
(however, Ghostscript still encounters and displays the 'timeout' message,
but the output does print correctly, so this message is due to something
else unknown).  As for printing from Mozilla, I am just using the default
built-in support, with no modifications.

As for the font size used by XPrint, yes, the font size is larger, actually
much larger (2.66 pages in my test vs 3.25 for XPrint), visually comparing
the printed pages.

I had always assumed that the printed text would pretty much match the displayed
text on the screen...perhaps this is a wrong assumption.

I will try to install a copy of XPrint and see what it prints out from the
generated Postscript file from Mozilla in my test case.

Thanks!
WFM with trunk 2002073022, linux. reporter (Lincoln Ong): can you reproduce this
bug with a recent build of mozilla (for example, 1.1beta)? if so, please comment
again with details. if not, please resolve this bug as WORKSFORME. thanks.
no answer.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 15

15 years ago
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.