Text clipping with WebRender on

RESOLVED FIXED in Firefox 64

Status

()

defect
P1
normal
RESOLVED FIXED
Last year
6 months ago

People

(Reporter: Fanolian+bugzilla, Assigned: lsalzman)

Tracking

(Blocks 2 bugs, {regression, reproducible})

Trunk
mozilla64
Unspecified
Windows 10
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox61 unaffected, firefox62 disabled, firefox63 disabled, firefox64 fixed)

Details

()

Attachments

(3 attachments)

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0
Build ID: 20180722220044

Steps to reproduce:
0. Set gfx.webrender.all to true. Restart browser.
1. Visit https://phabricator.services.mozilla.com/D2256.
2. Observe the text near the top of the page.


Actual result:
The last digit is clipped (Please see attachment).


Additional information:
There is no clippings with WebRender off.
The issue does not occur at every Nightly's zoom levels. It is most obvious at 67%, 100%, and 150%.

Font used in the screenshot (which is the default):
Segoe UI Bold, 13px, weight 700.


Mozregression points to bug 1463416.
Blocks: 1463416
Has Regression Range: --- → yes
Has STR: --- → yes
The issue also occurs at Google Calendar using Month View, but only with some tiles.
The last f in the tiles "Day off" is clipped.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(lsalzman)
OS: Unspecified → Windows 10
Version: 62 Branch → Trunk
Not sure. I found the same Win10 regression range as the reporter, but couldn't really reproduce bug 1464371 (Linux).
I thought that this could be a regression of bug 1458921 which landed together with bug 1463416.
Priority: -- → P1
lee has been able to reproduce this and is looking into it
Assignee: nobody → lsalzman
I'd love a fix for this (especially since Lee can repro), but we can let this ride to beta.
Priority: P1 → P2
It sounds like this is a pretty noticeable problem that can be annoying. I'm upgrading to P1. I don't want to block nightly on this but hopefully it will be ready today anyways.
Priority: P2 → P1
WR PR https://github.com/servo/webrender/pull/3048 will partially fix the clipping issue. A Gecko-side patch coming shortly will fix another part of this.
Flags: needinfo?(lsalzman)
When rendering in GDI mode, we're getting rounding of glyph positions that is screwing up all the positioning completely. With Skia, we were actually disabling subpixel positioning for GDI mode, so we need to do that with WR as well.
Attachment #9008474 - Flags: review?(jmuizelaar)
Attachment #9008474 - Flags: review?(jmuizelaar) → review+
Pushed by lsalzman@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/efe2d390bdc5
Don't use subpixel positioning for GDI fonts in WebRender. r=jrmuizel
https://hg.mozilla.org/mozilla-central/rev/efe2d390bdc5
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
Depends on: 1491130
See Also: → 1464371
Depends on: 1508203
You need to log in before you can comment on or make changes to this bug.