Closed Bug 1477679 Opened Last year Closed 7 months ago

Network - HAR and Throtthling menus prevent other dropdowns to be opened form 1st click

Categories

(DevTools :: Netmonitor, defect, P3, minor)

63 Branch
defect

Tracking

(firefox-esr60 unaffected, firefox61 wontfix, firefox62 wontfix, firefox63 wontfix, firefox64 wontfix, firefox65 wontfix, firefox66 wontfix, firefox67 verified)

VERIFIED FIXED
Firefox 67
Tracking Status
firefox-esr60 --- unaffected
firefox61 --- wontfix
firefox62 --- wontfix
firefox63 --- wontfix
firefox64 --- wontfix
firefox65 --- wontfix
firefox66 --- wontfix
firefox67 --- verified

People

(Reporter: cfogel, Assigned: harry7)

Details

(Keywords: regression)

Attachments

(3 files, 1 obsolete file)

[Affected versions]:
- Firefox 63.0a1 (2018-07-22), 62.0b9, 61.0.1

[Affected platforms]:
- win10x64, macOS 10.13.4, Ubuntu 16.04LTS

[Steps to reproduce]:
1. Launch Firefox;
2. Open DevTools/Netmonitor;
3. Click on the [Throttling] button;
4. Click on the [HAR] button;

[Expected result]:
- Dropdown menu for throttling is not displayed;
- dropdown menu for HAR is displayed.

[Actual result]:
- no dropdown is displayed.

[Regression range]:
- mozregression points out to:
https://bugzilla.mozilla.org/show_bug.cgi?id=1457066

[Additional notes]:
- attached screen recording with the combinations;
- same issue when swapping steps 3-4, or trying to open any other dropdown menu 
(ex: customize, bookmarks, menu )
Could you help us here?
Flags: needinfo?(pbrosset)
This is a case of the dropdown panel swallowing the first click.
Definitely something we should try to fix. Not the highest priority for now though.
Flags: needinfo?(pbrosset)
Priority: -- → P3
@Hemanth: this is related to your work on bug 1471284. Do you have a time to look into this?

Thanks,
Honza
Flags: needinfo?(hems.india1997)
(In reply to Jan Honza Odvarko [:Honza] PTO from 7/22 to 8/5 from comment #3)
> @Hemanth: this is related to your work on bug 1471284. Do you have a time to
> look into this?
> 
@Honza: Yes, I will look into it. I am assigning this bug to myself for now. If I am unable to fix it, I will remove the assignment.
Thanks,
Hemanth
Flags: needinfo?(hems.india1997)
@Honza: Seems like I am unable to assign it to me. Can you do that for me?
Thanks,
Hemanth
Done, thanks!

Honza
Assignee: nobody → hems.india1997
Status: NEW → ASSIGNED
(In reply to Jan Honza Odvarko [:Honza] from comment #6)
> Done, thanks!
> 
> Honza

So I started looking into this bug and I found that its not just between `har` and `throttling` buttons, but even if we click on `har` button and then click on any of the filters, the filter is not getting clicked. I also checked this in older versions of `firefox` and before our work got pushed. So I believe, this bug is because of some other thing and not related to our work on throttling selector. @Honza, can you please confirm? I am attaching a screen capture on my firefox 61.
Attached image harButtonOldFirefoxProblem.gif (obsolete) —
Attachment #8998610 - Attachment is obsolete: true
I uploaded wrong gif file before. Now I uploaded the correct one.
Thanks,
Hemanth
Can I get an update on this? I noticed this has been there even before as well. So any guidelines on how to look for it and fix it?
(In reply to Hemanth Kumar Veeranki [:harry7] from comment #10)
> Can I get an update on this? I noticed this has been there even before as
> well. So any guidelines on how to look for it and fix it?
I see, thanks for the testing!

The HAR drop down (as well as the one for Throttle) is built on top of "devtools/client/shared/components/menu/utils" and displayed using showMenu.

The menu is implemented in this module: "devtools/client/framework/menu"

The menu is built on top of <menupopup> element and opened using:
popup.openPopupAtScreen(screenX, screenY, true);

https://searchfox.org/mozilla-central/rev/80ac71c1c54af788b32e851192dfd2de2ec18e18/devtools/client/framework/menu.js#122

Perhaps you could check MDN for <menupopup> properties?
(hoping there is one that could be useful here)
https://developer.mozilla.org/en-US/docs/Mozilla/Tech/XUL/menupopup
https://developer.mozilla.org/en-US/docs/Mozilla/Tech/XUL/Tutorial/Popup_Menus

Honza
Flags: needinfo?(hems.india1997)
Harry, are you still working on this bug? Thanks
Network - HAR and Throtthling menus when they are opened are preventing other events to trigger by the first mouse click. After this
change, they will not consume the first click.
@Honza,
I investigated this and found out that we were setting an attribute called `consumeoutsideclicks` to true in our menu item and that is the reason why they are being consumed, I set this to false and first mouse click is not being consumed by the menu. I created a review. Can you verify the changes are working?
Flags: needinfo?(hems.india1997) → needinfo?(odvarko)

(In reply to Hemanth Kumar Veeranki [:harry7] from comment #14)

@Honza,
I investigated this and found out that we were setting an attribute called
consumeoutsideclicks to true in our menu item and that is the reason why
they are being consumed, I set this to false and first mouse click is not
being consumed by the menu. I created a review. Can you verify the changes
are working?
Thanks, this fixes the issue for me!

@Julian, that "consumeoutsideclicks" attribute has been introduced in Bug 1457066.
Is it still needed? Or should we introduce API that allows to customize the attribute (true/false) from outside?

Honza

Flags: needinfo?(odvarko) → needinfo?(jdescottes)

Thanks for the ping!
The meatball menu for which the bug was initially opened no longer uses framework/menu.js, so in that regard we could remove it.

I guess it would be good to verify on windows, after removing it, that the initial issue from Bug 1457066 is not back on the other menus triggered by a button that still rely on framework/menu.js (eg the network menus from this bug, the flexbox menu in the layout tab of the inspector etc...). The STRs for the initial bug were:

  • click on the button that opens the menu
  • (menu opens)
  • click on the button again
    ER: Menu should close
    AR: Menu flickers and remains open

Again, windows only :)

Flags: needinfo?(jdescottes)

I tested various menus based on devtools/client/framework/menu.js on Win10 and all seem to be working fine for me.

Here is yet Try push:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=ca36b6d45fbe31fe6caa750efeca2308f7a666e9

If the Try is green, we can land it.

Thanks for the patch!

Honza

Hey Honza. I see this bug is assigned, has a reviewed patch, and a green try build. But it hasn't been touched in 2 months. Can we still land it?

Flags: needinfo?(odvarko)
Pushed by jodvarko@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0db3a6976abd
Prevent the dropdown panel swallowing the first click r=Honza

Landed.

Honza

Flags: needinfo?(odvarko)
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67

Confirmed the issue with Firefox 63.0a1 (2018-07-23) on Windows 10.
Fix verified with Firefox 67.0a1 (20190227163104), Windows 10 x64, Ubuntu 18.04 x64 and macOS 10.13.6.

Status: RESOLVED → VERIFIED

Updating flags, as per previous comment.

You need to log in before you can comment on or make changes to this bug.