Closed Bug 1478058 Opened 2 years ago Closed 1 year ago

Crash in <T>::update caused by async blob image

Categories

(Core :: Graphics: WebRender, defect, P3, critical)

Unspecified
macOS
defect

Tracking

()

RESOLVED DUPLICATE of bug 1477571
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox61 --- unaffected
firefox62 --- unaffected
firefox63 --- fix-optional
firefox64 --- fix-optional

People

(Reporter: calixte, Assigned: Gankra)

References

(Blocks 1 open bug)

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is
report bp-f0f1d5d2-bc00-44bd-a0b7-742e70180724.
=============================================================

Top 10 frames of crashing thread:

0 libmozglue.dylib mozalloc_abort memory/mozalloc/mozalloc_abort.cpp:34
1 libmozglue.dylib abort memory/mozalloc/mozalloc_abort.cpp:81
2 XUL panic_abort::__rust_start_panic::abort src/libpanic_abort/lib.rs:61
3 XUL __rust_start_panic src/libpanic_abort/lib.rs:56
4 XUL std::panicking::rust_panic_with_hook src/libstd/panicking.rs:559
5 XUL std::panicking::begin_panic src/libstd/panicking.rs:445
6 XUL <webrender_bindings::moz2d_renderer::Moz2dBlobImageHandler as webrender_api::image::BlobImageHandler>::update gfx/webrender_bindings/src/moz2d_renderer.rs:416
7 XUL webrender::resource_cache::ResourceCache::pre_scene_building_update gfx/webrender/src/resource_cache.rs:750
8 XUL webrender::render_backend::RenderBackend::process_api_msg gfx/webrender/src/render_backend.rs:983
9 XUL webrender::render_backend::RenderBackend::run gfx/webrender/src/render_backend.rs:798

=============================================================

There is 1 crash in nightly 63 with buildid 20180723220051. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1476636.

[1] https://hg.mozilla.org/mozilla-central/rev?node=5fdc7f00aba1
Flags: needinfo?(jmuizelaar)
Yes that seems likely.
Flags: needinfo?(jmuizelaar)
Summary: Crash in <T>::update → Crash in <T>::update caused by async blob image
Assignee: nobody → a.beingessner
Priority: -- → P3
Last crash was 20180819221915 using a Linux build.
(In reply to Calixte Denizet (:calixte) from comment #0)
> This bug was filed from the Socorro interface and is
> report bp-f0f1d5d2-bc00-44bd-a0b7-742e70180724.

> MOZ_CRASH Reason 	missing image key
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1477571
You need to log in before you can comment on or make changes to this bug.