crash on this page (I think, it's caused by java applets)

RESOLVED INVALID

Status

--
critical
RESOLVED INVALID
17 years ago
8 years ago

People

(Reporter: bear, Assigned: joe.chou)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc3) Gecko/20020523
BuildID:    2002052309

crash on loading java applets

Reproducible: Always
Steps to Reproduce:
1.open URL
2.
3.

Actual Results:  crash

Expected Results:  show page

Comment 1

17 years ago
This is indeed a known Java crasher: site uses fphover.class applet.
Upgrading to JRE 1.4.0 will solve the problem.

Propose to mark dupe of bug 57372.
Assignee: Matti → joe.chou
Component: Browser-General → OJI
Keywords: crash
QA Contact: imajes-qa → pmac

Comment 2

17 years ago
WFM, current trunk CVS, Linux, Java 1.4

Comment 3

17 years ago
WFM 2002052809/trunk/W2K - J1.4

Comment 4

17 years ago
URL Works fine with Mozilla build 2002052808 on iMac under MAC OS X 10.1.4.
(Reporter)

Comment 5

17 years ago
Additional information:
Machine: SMP Pentium2

$ uname -mrv
2.4.18-6mdksmp #1 SMP Fri Mar 15 01:24:36 CET 2002 i686

Distribution: mandrake linux 8.2

Output from command line after crash:
-----------------------------------------
$ /usr/local/mozilla/mozilla

An unexpected exception has been detected in native code outside the VM.
Unexpected Signal : 11 occurred at PC=0x40a3ec74
Function name=(N/A)
Library=/lib/libc.so.6

NOTE: We are unable to locate the function name symbol for the error
      just occurred. Please refer to release documentation for possible
      reason and solutions.



Current Java thread:
        at sun.awt.motif.X11Graphics.disposeImpl(Native Method)
        at sun.awt.motif.X11Graphics.dispose(X11Graphics.java:251)
        at sun.awt.RepaintArea.paint(RepaintArea.java:300)
        at sun.awt.motif.MComponentPeer.handleEvent(MComponentPeer.java:349)
        at java.awt.Component.dispatchEventImpl(Component.java:2663)
        at java.awt.Container.dispatchEventImpl(Container.java:1213)
        at java.awt.Component.dispatchEvent(Component.java:2497)
        at java.awt.EventQueue.dispatchEvent(EventQueue.java:339)
        at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:131)
        at
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:98)
        at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
        at java.awt.EventDispatchThread.run(EventDispatchThread.java:85)

Dynamic libraries:
08048000-08050000 r-xp 00000000 03:41 93225     
/home/bear/mozilla/plugins/java2/bin/i386/native_threads/java_vm
08050000-08052000 rw-p 00007000 03:41 93225     
/home/bear/mozilla/plugins/java2/bin/i386/native_threads/java_vm
40000000-40014000 r-xp 00000000 03:03 168        /lib/ld-2.2.4.so
40014000-40015000 rw-p 00013000 03:03 168        /lib/ld-2.2.4.so
40016000-4001f000 r-xp 00000000 03:41 93136     
/home/bear/mozilla/plugins/java2/lib/i386/native_threads/libhpi.so
4001f000-40020000 rw-p 00008000 03:41 93136     
/home/bear/mozilla/plugins/java2/lib/i386/native_threads/libhpi.so
40020000-40021000 r--p 00000000 03:03 41306     
/usr/share/locale/en_US/LC_IDENTIFICATION
40021000-40022000 r--p 00000000 03:03 196765    
/usr/share/locale/en_US/LC_MEASUREMENT
40022000-40023000 r--p 00000000 03:03 41238     
/usr/share/locale/en_US/LC_TELEPHONE
40023000-40024000 r--p 00000000 03:03 41235      /usr/share/locale/en_US/LC_ADDRESS
40024000-40025000 r--p 00000000 03:03 196709     /usr/share/locale/en_US/LC_NAME
40025000-40026000 r--p 00000000 03:03 41301      /usr/share/locale/en_US/LC_PAPER
40026000-40027000 r--p 00000000 03:03 41304     
/usr/share/locale/en_US/LC_MESSAGES/SYS_LC_MESSAGES
40027000-40028000 r--p 00000000 03:03 41237      /usr/share/locale/en_US/LC_MONETARY
40028000-40029000 r--p 00000000 03:03 196708     /usr/share/locale/en_US/LC_TIME
40029000-4002a000 r--p 00000000 03:03 41302      /usr/share/locale/en_US/LC_NUMERIC
4002c000-4003a000 r-xp 00000000 03:03 112191     /lib/libpthread-0.9.so
4003a000-40042000 rw-p 0000d000 03:03 112191     /lib/libpthread-0.9.so
40042000-402a9000 r-xp 00000000 03:41 93259     
/home/bear/mozilla/plugins/java2/lib/i386/client/libjvm.so
402a9000-4040f000 rw-p 00266000 03:41 93259     
/home/bear/mozilla/plugins/java2/lib/i386/client/libjvm.so
40427000-40448000 r-xp 00000000 03:41 93182     
/home/bear/mozilla/plugins/java2/lib/i386/libjava.so
40448000-4044a000 rw-p 00020000 03:41 93182     
/home/bear/mozilla/plugins/java2/lib/i386/libjava.so
4044b000-40818000 r-xp 00000000 03:41 93252     
/home/bear/mozilla/plugins/java2/lib/i386/libawt.so
40818000-40828000 rw-p 003cc000 03:41 93252     
/home/bear/mozilla/plugins/java2/lib/i386/libawt.so
4083d000-4085e000 r-xp 00000000 03:03 179        /lib/libm-2.2.4.so
4085e000-4085f000 rw-p 00020000 03:03 179        /lib/libm-2.2.4.so
4085f000-40861000 r-xp 00000000 03:03 177        /lib/libdl-2.2.4.so
40861000-40862000 rw-p 00001000 03:03 177        /lib/libdl-2.2.4.so
40862000-408b0000 r-xp 00000000 03:03 2457       /usr/X11R6/lib/libXt.so.6.0
408b0000-408b4000 rw-p 0004d000 03:03 2457       /usr/X11R6/lib/libXt.so.6.0
408b4000-40978000 r-xp 00000000 03:03 2435       /usr/X11R6/lib/libX11.so.6.2
40978000-4097b000 rw-p 000c3000 03:03 2435       /usr/X11R6/lib/libX11.so.6.2
4097c000-409ad000 r-xp 00000000 03:41 93147     
/home/bear/mozilla/plugins/java2/lib/i386/libmlib_image.so
409ad000-409af000 rw-p 00030000 03:41 93147     
/home/bear/mozilla/plugins/java2/lib/i386/libmlib_image.so
409af000-409c0000 r-xp 00000000 03:41 93222     
/home/bear/mozilla/plugins/java2/lib/i386/libverify.so
409c0000-409c2000 rw-p 00010000 03:41 93222     
/home/bear/mozilla/plugins/java2/lib/i386/libverify.so
409c2000-40af4000 r-xp 00000000 03:03 112168     /lib/libc-2.2.4.so
40af4000-40afa000 rw-p 00131000 03:03 112168     /lib/libc-2.2.4.so
40afe000-40b10000 r-xp 00000000 03:03 112173     /lib/libnsl-2.2.4.so
40b10000-40b12000 rw-p 00011000 03:03 112173     /lib/libnsl-2.2.4.so
40b14000-40b4d000 r-xp 00000000 03:03 19410     
/usr/lib/libstdc++-3-libc6.2-2-2.10.0.so
40b4d000-40b5e000 rw-p 00038000 03:03 19410     
/usr/lib/libstdc++-3-libc6.2-2-2.10.0.so
40b61000-40b68000 r-xp 00000000 03:03 2453       /usr/X11R6/lib/libXp.so.6.2
40b68000-40b69000 rw-p 00006000 03:03 2453       /usr/X11R6/lib/libXp.so.6.2
40b6a000-40b78000 r-xp 00000000 03:03 2443       /usr/X11R6/lib/libXext.so.6.4
40b78000-40b79000 rw-p 0000d000 03:03 2443       /usr/X11R6/lib/libXext.so.6.4
40b79000-40b7e000 r-xp 00000000 03:03 2459       /usr/X11R6/lib/libXtst.so.6.1
40b7e000-40b7f000 rw-p 00004000 03:03 2459       /usr/X11R6/lib/libXtst.so.6.1
40b7f000-40b87000 r-xp 00000000 03:03 2433       /usr/X11R6/lib/libSM.so.6.0
40b87000-40b88000 rw-p 00007000 03:03 2433       /usr/X11R6/lib/libSM.so.6.0
40b88000-40b9c000 r-xp 00000000 03:03 2427       /usr/X11R6/lib/libICE.so.6.3
40b9c000-40b9d000 rw-p 00013000 03:03 2427       /usr/X11R6/lib/libICE.so.6.3
40ba0000-40bb4000 r-xp 00000000 03:41 93119     
/home/bear/mozilla/plugins/java2/lib/i386/libzip.so
40bb4000-40bb7000 rw-p 00013000 03:41 93119     
/home/bear/mozilla/plugins/java2/lib/i386/libzip.so
40bb7000-418d0000 r--s 00000000 03:41 93237     
/home/bear/mozilla/plugins/java2/lib/rt.jar
418fd000-41ba2000 r--s 00000000 03:41 93120     
/home/bear/mozilla/plugins/java2/lib/i18n.jar
41ba2000-41bb8000 r--s 00000000 03:41 93132     
/home/bear/mozilla/plugins/java2/lib/sunrsasign.jar
41bb8000-41c12000 r--s 00000000 03:41 93178     
/home/bear/mozilla/plugins/java2/lib/javaplugin.jar
41c12000-41c23000 r--s 00000000 03:41 93152     
/home/bear/mozilla/plugins/java2/lib/javaplugin_l10n.jar
43ccb000-43ccd000 r-xp 00000000 03:03 23633     
/usr/X11R6/lib/X11/locale/common/xlcDef.so.2
43ccd000-43cce000 rw-p 00001000 03:03 23633     
/usr/X11R6/lib/X11/locale/common/xlcDef.so.2
49d2f000-49d5a000 r--p 00000000 03:03 21842     
/usr/share/locale/ISO-8859-1/LC_CTYPE
49d5a000-49d60000 r--p 00000000 03:03 183091    
/usr/share/locale/ISO-8859-1/LC_COLLATE
49d60000-49d62000 r-xp 00000000 03:03 346        /usr/lib/gconv/ISO8859-1.so
49d62000-49d63000 rw-p 00001000 03:03 346        /usr/lib/gconv/ISO8859-1.so
49d63000-49d6c000 r-xp 00000000 03:41 93232     
/home/bear/mozilla/plugins/java2/lib/i386/libnet.so
49d6c000-49d6d000 rw-p 00008000 03:41 93232     
/home/bear/mozilla/plugins/java2/lib/i386/libnet.so
49d6d000-49d70000 r-xp 00000000 03:03 185        /lib/libnss_dns-2.2.4.so
49d70000-49d71000 rw-p 00002000 03:03 185        /lib/libnss_dns-2.2.4.so
49d71000-49d75000 r--s 00000000 03:03 46201      /tmp/jar_cache56911.tmp (deleted)
49d76000-49d7f000 r-xp 00000000 03:03 187        /lib/libnss_files-2.2.4.so
49d7f000-49d80000 rw-p 00008000 03:03 187        /lib/libnss_files-2.2.4.so
49dec000-49df5000 r-xp 00000000 03:03 193        /lib/libnss_nisplus-2.2.4.so
49df5000-49df7000 rw-p 00008000 03:03 193        /lib/libnss_nisplus-2.2.4.so
49df7000-49dfb000 r--s 00000000 03:03 231787     /tmp/jar_cache56912.tmp (deleted)
49f00000-49f17000 r-xp 00000000 03:41 93133     
/home/bear/mozilla/plugins/java2/lib/i386/libjavaplugin_jni.so
49f17000-49f19000 rw-p 00016000 03:41 93133     
/home/bear/mozilla/plugins/java2/lib/i386/libjavaplugin_jni.so
49f2d000-49fb7000 r-xp 00000000 03:41 93108     
/home/bear/mozilla/plugins/java2/lib/i386/libfontmanager.so
49fb7000-49fc7000 rw-p 00089000 03:41 93108     
/home/bear/mozilla/plugins/java2/lib/i386/libfontmanager.so
4a1d7000-4a1f1000 r-xp 00000000 03:03 23632     
/usr/X11R6/lib/X11/locale/common/ximcp.so.2
4a1f1000-4a1f4000 rw-p 00019000 03:03 23632     
/usr/X11R6/lib/X11/locale/common/ximcp.so.2
4a1f4000-4a1fd000 r-xp 00000000 03:03 191        /lib/libnss_nis-2.2.4.so
4a1fd000-4a1fe000 rw-p 00008000 03:03 191        /lib/libnss_nis-2.2.4.so
4a300000-4a30a000 r-xp 00000000 03:03 23637     
/usr/X11R6/lib/X11/locale/common/xomGeneric.so.2
4a30a000-4a30b000 rw-p 00009000 03:03 23637     
/usr/X11R6/lib/X11/locale/common/xomGeneric.so.2
4a316000-4a324000 r-xp 00000000 03:03 197        /lib/libresolv-2.2.4.so
4a324000-4a326000 rw-p 0000d000 03:03 197        /lib/libresolv-2.2.4.so
4a328000-4a357000 r-xp 00000000 03:41 93112     
/home/bear/mozilla/plugins/java2/lib/i386/libjpeg.so
4a357000-4a358000 rw-p 0002e000 03:41 93112     
/home/bear/mozilla/plugins/java2/lib/i386/libjpeg.so

Local Time = Wed May 29 14:37:01 2002
Elapsed Time = 12
#
# The exception above was detected in native code outside the VM
#
# Java VM: Java HotSpot(TM) Client VM (1.3.1-b24 mixed mode)
#
# An error report file has been saved as hs_err_pid26805.log.
# Please refer to the file for further information.
#
INTERNAL ERROR on Browser End: Pipe closed during read? State may be corrupt
System error?:: Success
Reporter: Can you upgrade to JRE1.4 ?

Comment 7

16 years ago
Michal, once again (one month later...): do you also get this crash with Java
1.4 installed?
And what do you think about this being a duplicate of bug 57372 as proposed in
comment #1?

Comment 8

16 years ago
No response from reporter
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Updated

16 years ago
QA Contact: pmac → petersen

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.