Closed Bug 1478172 Opened 4 years ago Closed 4 years ago

[wpt-sync] Sync PR 12170 - [wptrunner] Fix regression in Sauce Labs browser

Categories

(Testing :: web-platform-tests, enhancement, P4)

enhancement

Tracking

(firefox63 fixed)

RESOLVED FIXED
mozilla63
Tracking Status
firefox63 --- fixed

People

(Reporter: mozilla.org, Unassigned)

References

()

Details

(Whiteboard: [wptsync downstream])

Sync web-platform-tests PR 12170 into mozilla-central (this bug is closed when the sync is complete).

PR: https://github.com/web-platform-tests/wpt/pull/12170
Details from upstream follow.

Mike Pennisi <mike@mikepennisi.com> wrote:
>  [wptrunner] Fix regression in Sauce Labs browser
>  
>  A recent commit [1] updated the invocation of the `start` method for
>  "Browser" instances by introducing a new keyword argument. This
>  interfered with the use of the "Sauce Labs" browser because its
>  implementation of the `start` method did not accommodate any keyword
>  arguments.
>  
>  Update the `start` method to support (but ignore) all keyword arguments.
>  
>  [1] 91803e3a25afd8e0c201bc57cd05fffd5d543551
>  
>  ---
>  
>  @jgraham do you have any thoughts on how we could test for this?
The PR was not expected to affect any tests, but the try push wasn't a success. Check the try results for infrastructure issues
Pushed by wptsync@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/45604441c39d
[wpt PR 12170] - [wptrunner] Fix regression in Sauce Labs browser, a=testonly
https://hg.mozilla.org/mozilla-central/rev/45604441c39d
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
You need to log in before you can comment on or make changes to this bug.