Closed Bug 1478181 Opened 2 years ago Closed 1 year ago

Intermittent mch Unsuccessful Execution Steps | ERROR at setup of test_common_prefs_are_all_set

Categories

(Testing :: Mochitest, defect)

Version 3
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1477149

People

(Reporter: bogdan_tara, Unassigned)

Details

Failure log:
https://treeherder.mozilla.org/logviewer.html#?job_id=189872787&repo=autoland

https://taskcluster-artifacts.net/WJK6W28qReKKif8TDs0f0w/0/public/logs/live_backing.log

[task 2018-07-24T18:07:39.574Z]  0:23.33 /builds/worker/checkouts/gecko/testing/mochitest/tests/python/test_build_profile.py
[task 2018-07-24T18:07:39.574Z]  0:23.33 ============================= test session starts ==============================
[task 2018-07-24T18:07:39.575Z]  0:23.33 platform linux2 -- Python 2.7.12, pytest-3.6.2, py-1.5.4, pluggy-0.6.0 -- /builds/worker/checkouts/gecko/obj-x86_64-pc-linux-gnu/_virtualenvs/gecko-QUm8IANb-2/bin/python
[task 2018-07-24T18:07:39.575Z]  0:23.33 rootdir: /builds/worker/checkouts/gecko, inifile: /builds/worker/checkouts/gecko/config/mozunit/mozunit/pytest.ini
[task 2018-07-24T18:07:39.576Z]  0:23.33 collecting ... collected 1 item
[task 2018-07-24T18:07:39.576Z]  0:23.33 
[task 2018-07-24T18:07:39.576Z]  0:23.33 testing/mochitest/tests/python/test_build_profile.py::test_common_prefs_are_all_set ERROR
[task 2018-07-24T18:07:39.576Z]  0:23.33 
[task 2018-07-24T18:07:39.578Z]  0:23.33 ==================================== ERRORS ====================================
[task 2018-07-24T18:07:39.579Z]  0:23.33 _______________ ERROR at setup of test_common_prefs_are_all_set ________________
[task 2018-07-24T18:07:39.579Z]  0:23.33 
[task 2018-07-24T18:07:39.579Z]  0:23.33 request = <SubRequest 'skip_using_mozinfo' for <Function 'test_common_prefs_are_all_set'>>
[task 2018-07-24T18:07:39.579Z]  0:23.33 setup_test_harness = <function inner at 0x7ffa7a7a5230>
[task 2018-07-24T18:07:39.579Z]  0:23.33 
[task 2018-07-24T18:07:39.579Z]  0:23.33     @pytest.fixture(autouse=True)  # noqa: F811
[task 2018-07-24T18:07:39.579Z]  0:23.33     def skip_using_mozinfo(request, setup_test_harness):
[task 2018-07-24T18:07:39.579Z]  0:23.33         """Gives tests the ability to skip based on values from mozinfo.
[task 2018-07-24T18:07:39.579Z]  0:23.33 
[task 2018-07-24T18:07:39.579Z]  0:23.33         Example:
[task 2018-07-24T18:07:39.579Z]  0:23.33             @pytest.mark.skip_mozinfo("!e10s || os == 'linux'")
[task 2018-07-24T18:07:39.579Z]  0:23.33             def test_foo():
[task 2018-07-24T18:07:39.579Z]  0:23.33                 pass
[task 2018-07-24T18:07:39.579Z]  0:23.33         """
[task 2018-07-24T18:07:39.579Z]  0:23.33 
[task 2018-07-24T18:07:39.579Z]  0:23.33 >       setup_test_harness(*setup_args)
[task 2018-07-24T18:07:39.579Z]  0:23.33 
[task 2018-07-24T18:07:39.579Z]  0:23.33 testing/mochitest/tests/python/conftest.py:102:
[task 2018-07-24T18:07:39.579Z]  0:23.33 _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _ _
[task 2018-07-24T18:07:39.579Z]  0:23.33 
[task 2018-07-24T18:07:39.579Z]  0:23.33 files_dir = '/builds/worker/checkouts/gecko/testing/mochitest/tests/python/files'
[task 2018-07-24T18:07:39.579Z]  0:23.33 args = ('mochitest', 'testing/mochitest'), kwargs = {}
[task 2018-07-24T18:07:39.579Z]  0:23.33 harness_root = '/builds/worker/fetches/tests/mochitest'
[task 2018-07-24T18:07:39.579Z]  0:23.33 test_root = '/builds/worker/fetches/tests/mochitest/tests/selftests'
[task 2018-07-24T18:07:39.579Z]  0:23.33 
[task 2018-07-24T18:07:39.579Z]  0:23.33     def inner(files_dir, *args, **kwargs):
[task 2018-07-24T18:07:39.579Z]  0:23.33         harness_root = _get_test_harness(*args, **kwargs)
[task 2018-07-24T18:07:39.579Z]  0:23.34         if harness_root:
[task 2018-07-24T18:07:39.579Z]  0:23.34             sys.path.insert(0, harness_root)
[task 2018-07-24T18:07:39.581Z]  0:23.34 
[task 2018-07-24T18:07:39.582Z]  0:23.34             # Link the test files to the test package so updates are automatically
[task 2018-07-24T18:07:39.582Z]  0:23.34             # picked up. Fallback to copy on Windows.
[task 2018-07-24T18:07:39.582Z]  0:23.34             if files_dir:
[task 2018-07-24T18:07:39.582Z]  0:23.34                 test_root = os.path.join(harness_root, 'tests', 'selftests')
[task 2018-07-24T18:07:39.583Z]  0:23.34                 if not os.path.exists(test_root):
[task 2018-07-24T18:07:39.583Z]  0:23.34                     if hasattr(os, 'symlink'):
[task 2018-07-24T18:07:39.583Z]  0:23.34 >                       os.symlink(files_dir, test_root)
[task 2018-07-24T18:07:39.583Z]  0:23.34 E                       OSError: [Errno 17] File exists
[task 2018-07-24T18:07:39.583Z]  0:23.34 
[task 2018-07-24T18:07:39.583Z]  0:23.34 testing/mozbase/moztest/moztest/selftest/fixtures.py:63: OSError
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1477149
You need to log in before you can comment on or make changes to this bug.