can't send mail after switching mail accounts

RESOLVED WORKSFORME

Status

MailNews Core
Composition
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: Oleg Baranov, Assigned: varada)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc3)
Gecko/20020523
BuildID:    2002052306

sending of mail fails when switching profiles in Compose window from the one
that have "bcc" and "reply-to" to the one, which doesn't

Reproducible: Always
Steps to Reproduce:
1.ok, create two IMAP accounts.
let the first be simple (use defaults most)
let the second be a bit more complicated:
- BCC to some address
- use Reply-To field
- attach some Signature

2. now in main mail window choose Inbox in the "complicated" account and push
"Compose". you'd have "To:", "Reply-To:" and "BCC:" addresses in your address area.

3.put something in "To", "Subj", "Body" fields...

4. and then then use "From:" combobox to switch to "simple" profile.

5. Fill "To:" address

6. push "Send" button

Actual Results:  When "Send" button is pushed the fillowing messagebox appears:
"Sending of message failed. No receipients were specified..."

Expected Results:  there's an address in "To:" field.
the mail'd be send of course.

1. Filling "To:" field for the second time looks bad (step 5)
2. after profile switching (step 4) the signature remains
3. Wow! after these experiments I have a couple of the same lines in "From:"
combobox :-(

NB: NS6.2 has about the same bug...
-->varada
Assignee: ducarroz → varada

Comment 2

16 years ago
Not switching profiles, but switching mail accounts.
Summary: can't send mail after profile switching → can't send mail after switching mail accounts

Comment 3

14 years ago
This bug is quite old. Can you still reproduce it? If not, it could be resolved.

Comment 4

14 years ago
Obviously no response for a long time ;-)

WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.