Closed Bug 1478273 Opened 2 years ago Closed 1 year ago

When clicked on the side bar pane, it disappears

Categories

(DevTools :: Inspector, defect, P1)

All
Other
defect

Tracking

(firefox-esr52 unaffected, firefox-esr60 unaffected, firefox61 unaffected, firefox62 wontfix, firefox63 verified)

VERIFIED FIXED
Firefox 63
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox61 --- unaffected
firefox62 --- wontfix
firefox63 --- verified

People

(Reporter: azra.dhalayat, Assigned: miker)

References

Details

(Keywords: regression, Whiteboard: [specification][type:bug])

Attachments

(3 files)

What did you do?
================
1. Developed an Add-On to create side bar pane  
2. Utilized the Javascript API devtools.Panel
3. Launched in the Add-on

What happened?
==============
The side bar has been created and successfully able to call the user defined function to show the object, When i try to click the element to copy, the entire side bar disappears

What should have happened?
==========================
Ideally the Side bar should still remain to enable copying or selection

Is there anything else we should know?
======================================
Also, the execCommand("copy") is denied in-spite of having the permissions provided in the manifest.json
Attached is the error that i am facing, here is the snippet..

function onCreated(sidebarPane) {
	browser.devtools.panels.elements.onSelectionChanged.addListener(() => {
		sidebarPane.setExpression("(" + page_getProperties.toString() + ")()", "Xpath");
	});

	sidebarPane.onShown.addListener(() => {
		console.log("~~~~Side Bar Shown~~~~");
	});

	sidebarPane.onHidden.addListener(() => {
		console.log("~~~~~Hidden~~~~~~");
	});
}

browser.devtools.panels.elements.createSidebarPane("Object Capture").then(onCreated);
Facing problem in Firefox 61.0.1
Component: API → Untriaged
Product: developer.mozilla.org → Firefox
Version: unspecified → 61 Branch
Hi Azra!

It would help a lot if you could create a reduced test case for this issue.

Meanwhile, I am not that familiar with these kind of issues so I am setting the Devtools::Inspector Component, maybe someone from it can help.
Component: Untriaged → Inspector
Flags: needinfo?(azra.dhalayat)
Product: Firefox → DevTools
Hi David,

I am unable to understand what reduced test case means in this context. Can you please elaborate.

Thanks,
Azra
Flags: needinfo?(azra.dhalayat) → needinfo?(david.olah)
Of course. I meant that I would need an example of an Add-On version (not necessarily the full version, in case it is not ok to share it as it is)  that you developed. Without it, I will not be able to reproduce the issue.
Flags: needinfo?(david.olah) → needinfo?(azra.dhalayat)
Here is the sample code, I have only included the required part where i am still able to replicate the issue.
Flags: needinfo?(azra.dhalayat) → needinfo?(david.olah)
Thank you Azra for the reply!

I managed to reproduce the issue on Windows 10 on Firefox 62.0b12, Firefox 61.0.1 and Nightly 63.0a1 (2018-07-29) with the help of the Add-On.

I am marking the issue as New.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(david.olah)
Version: 61 Branch → Trunk
Thanks David! Do let me know if anything required in the analysis or if there is a work around.
Assignee: nobody → gl
Status: NEW → ASSIGNED
Priority: -- → P1
Assignee: gl → nobody
Status: ASSIGNED → NEW
Hey Mike, can you take a look at this? It is caused by your event telemetry in https://searchfox.org/mozilla-central/source/devtools/client/inspector/toolsidebar.js#338, and will break any addon that is added to the inspector sidebar when selected. 

Error: "The property "newpanel" was added to a telemetry event with the signature devtools.main,sidepanel_changed,inspector,null but it's value "devtools-inspector-sidebar-c082d2be68df4d64a8e70d6ad6659ed0197a435e_temporary-addon-392-0" is longer than the maximum allowed length of 80 characters
CALLER: resource://devtools/client/inspector/toolsidebar.js:338:7"
Flags: needinfo?(mratcliffe)
Assignee: nobody → mratcliffe
Status: NEW → ASSIGNED
Flags: needinfo?(mratcliffe)
Comment on attachment 9001590 [details]
Bug 1478273 - When clicked on the side bar pane, it disappears r?gl

Gabriel [:gl] (ΦωΦ) has approved the revision.
Attachment #9001590 - Flags: review+
Attachment #9001590 - Flags: review?(gl)
Pushed by mratcliffe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ee51ad97d401
When clicked on the side bar pane, it disappears r=gl
https://hg.mozilla.org/mozilla-central/rev/ee51ad97d401
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
How was this caused by bug 1463083 if 61 is also affected?
Flags: needinfo?(mratcliffe)
(In reply to Ryan VanderMeulen [:RyanVM] from comment #18)
> How was this caused by bug 1463083 if 61 is also affected?

No, the bug originates in 62.

Event telemetry limit certain fields to a specified list of strings and also has limits on the number of characters allowed inside property names and values.

Sadly, when a custom panel is registered with devtools the panel id can break these rules and throw an error.
Flags: needinfo?(mratcliffe)
Is this something we should consider backporting or can it ride the 63 train?
I don't think we need to backport.
Flags: needinfo?(mratcliffe)
Flags: qe-verify+
Reproduced this bug using the add-on from comment 6, on an affected Nightly build (2018-07-25).

I can no longer see this issue with latest Beta 63.0b11 (20181001131022) under Windows 10 x64, macOS 10.13 and Ubuntu 16.04 x64.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.