Intermittent browser/base/content/test/general/browser_bug519216.js | didn't call progressListener4 for the first location change -

RESOLVED DUPLICATE of bug 1478159

Status

()

defect
P5
normal
RESOLVED DUPLICATE of bug 1478159
10 months ago
9 months ago

People

(Reporter: intermittent-bug-filer, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

10 months ago
treeherder
Filed by: apavel [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=189877245&repo=mozilla-inbound

https://queue.taskcluster.net/v1/task/LzQwvtgXRVy5hmOr_NB59g/runs/0/artifacts/public/logs/live_backing.log

11:34:14     INFO - TEST-START | browser/base/content/test/general/browser_bug519216.js
11:34:14     INFO - GECKO(756) | ++DOMWINDOW == 35 (0x12a4be400) [pid = 760] [serial = 108] [outer = 0x12769f000]
11:34:14     INFO - TEST-INFO | started process screencapture
11:34:15     INFO - TEST-INFO | screencapture: exit 0
11:34:15     INFO - Buffered messages logged at 11:33:17
11:34:15     INFO - TEST-PASS | browser/base/content/test/general/browser_bug519216.js | called progressListener1 before progressListener2 - 
11:34:15     INFO - TEST-PASS | browser/base/content/test/general/browser_bug519216.js | called progressListener2 before progressListener3 - 
11:34:15     INFO - Buffered messages finished
11:34:15     INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/general/browser_bug519216.js | didn't call progressListener4 for the first location change - 
11:34:15     INFO - Stack trace:
11:34:15     INFO - chrome://mochitests/content/browser/browser/base/content/test/general/browser_bug519216.js:onLocationChange:41
11:34:15     INFO - chrome://browser/content/tabbrowser.js:callListeners:721
11:34:15     INFO - chrome://browser/content/tabbrowser.js:_callProgressListeners:734
11:34:15     INFO - chrome://browser/content/tabbrowser.js:_callProgressListeners:4446
11:34:15     INFO - chrome://browser/content/tabbrowser.js:onLocationChange:4809
11:34:15     INFO - resource://gre/modules/RemoteWebProgress.jsm:_callProgressListeners:144
11:34:15     INFO - resource://gre/modules/RemoteWebProgress.jsm:receiveMessage:237
11:34:15     INFO - MessageListener.receiveMessage*resource://gre/modules/RemoteWebProgress.jsm:swapBrowser:89
11:34:15     INFO - resource://gre/modules/RemoteWebProgress.jsm:RemoteWebProgressManager:72
11:34:15     INFO - chrome://global/content/bindings/remote-browser.xml:remote-browser_XBL_Constructor:413
11:34:15     INFO - chrome://browser/content/tabbrowser.js:_insertBrowser:2016
11:34:15     INFO - chrome://browser/content/tabbrowser.js:addTab:2387
11:34:15     INFO - chrome://mochikit/content/browser-test.js:Tester_waitForWindowsState:578
11:34:15     INFO - chrome://mochikit/content/browser-test.js:nextTest:902
11:34:15     INFO - chrome://mochikit/content/browser-test.js:testScope/test_finish/<:1397
11:34:15     INFO - chrome://mochikit/content/browser-test.js:run:1334
11:34:15     INFO - GECKO(756) | ++DOMWINDOW == 36 (0x12a4bac00) [pid = 760] [serial = 109] [outer = 0x12769f000]
11:34:15     INFO - Console message: [JavaScript Error: "The character encoding of the plain text document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the file needs to be declared in the transfer protocol or file needs to use a byte order mark as an encoding signature." {file: "data:text/plain,bug519216" line: 0}]
11:34:15     INFO - GECKO(756) | MEMORY STAT | vsize 4728MB | residentFast 692MB | heapAllocated 210MB
11:34:15     INFO - TEST-OK | browser/base/content/test/general/browser_bug519216.js | took 369ms
Comment hidden (Intermittent Failures Robot)
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1478159
You need to log in before you can comment on or make changes to this bug.