mouse problems with left+right click

RESOLVED WORKSFORME

Status

()

Core
Drag and Drop
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: Emanuele, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; it-IT; rv:1.0rc3) Gecko/20020523
BuildID:    20020523

I choose the middle-click to open a link in a new tab but i emulate the third
button so i have to do a right+left click; when my click is not very accurate a
menu appears and the mouse icon becomes the same as when i'm  copying and i have
to kill mozilla.
i'll send a screenshot

Reproducible: Always
Steps to Reproduce:
1.go over a link
2.do a left click and maintain down the button
3.do a right click (menu will appear)
4. leave the left button and move the mouse

Actual Results:  i can move the mouse but i can't use it until mozilla is closed
or i switch to text mode ant the return to the graphic one

Expected Results:  all but that
WFM with trunk 2002073022, linux. reporter (Emanuele): can you reproduce this
bug with a recent build of mozilla (for example, 1.1beta)? if so, please comment
again with details. if not, please resolve this bug as WORKSFORME. thanks.
(Reporter)

Comment 2

16 years ago
I confirm with build id 2002062504, now i cant download a newer build.
Add. information:
I can release the mouse with ctrl+d o ctrl+d without killing mozilla
(Reporter)

Comment 3

16 years ago
Created attachment 93997 [details]
screeshot with mouse appereance
hm.. there was a similar bug around RC1/RC2 with bookmarks.. maybe it's the same
(and so fixed now..)

Comment 5

15 years ago
I can reproduce this with no trouble. I'm using linux nightly 2002110804 on
mandrake 9.0 with KDE.

1) Move the mouse over a link.
2) Click and hold the left mouse button. Link should change to highlight color.
3) Click and hold the right mouse button. Right-click menu should appear.
4) Release one or both of the buttons if you like, but don't click either of
them again. (Releasing them doesn't destroy the effect, but clicking one of them
again does).
5) Move the mouse some direction other than into the menu (e.g., up and left, or
directly to the right).

Observed behavior: The link text highlights and the mouse cursor changes to the
drag mouse. The menu does not disappear. Mozilla seems to get stuck in this
mode; clicking the mouse buttons won't dismiss the menu or cancel the drag.

If the link text doesn't highlight, you moved the mouse incorrectly. What is
happening is that you're triggereing a link-drag while the menu is open. Moving
the mouse directly into the menu doesn't always trigger a link-drag.
Confirming this, I see it too.
I can close te menu just by pressing 'esc'.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 7

15 years ago
*** Bug 169357 has been marked as a duplicate of this bug. ***

Comment 8

12 years ago
WFM, SeaMonkey 2005-08-31-02 trunk Linux.
(the menu does not appear on right click after the drag has started)

Can anyone still reproduce this bug?
Assignee: bross2 → nobody
QA Contact: tpreston

Comment 9

10 years ago
I checked:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008043007 Minefield/3.0pre
and didn't see this problem
WFM, Firefox 2008042704 on Linux.

-> WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.