News account can not handle '+' in an email address.

VERIFIED DUPLICATE of bug 98664

Status

VERIFIED DUPLICATE of bug 98664
17 years ago
14 years ago

People

(Reporter: jack+bugzilla, Assigned: racham)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc3)
Gecko/20020523
BuildID:    2002052306

The Account manager adds a new account each time you subscribe to a news group
if you have a '+' in your email address for the account. For example, I use
jack+nntp@cybermail.net as my email address for my news.charter.net news
account. If I subscribe to a news group, 
the account manager creates an account called jack%2Bnntp on news.charter.net.
If I subscribe to a group, a new account is created called jack%252Bnntp on
news.charter.net. If I subcribe again, I see jack%25252Bnntp on news.charter.net
created. this goes on and on. I can  only use news groups with an email address
of jack@cybermail.net. 

Reproducible: Always
Steps to Reproduce:
1.Create news account ( like news.charter.net ) 
2.Use email address like jack+nntp@cybermail.net
3.Subscribe to a news group. 

Actual Results:  News accounts are created named:
news.charter.net
jack%2Bnntp on news.charter.net
jack%252Bnntp on news.charter.net 
jack%25252Bnntp on news.charter.net

Expected Results:  
news.charter.net

Note: a '+' is a valid email address character.

Comment 1

17 years ago
That's freaky.

Confirming, WinXP, 1.0.0 branch 2002060106.  
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: News account can not handle '+' in an email address. → News account can not handle '+' in an email address.

Comment 2

17 years ago

*** This bug has been marked as a duplicate of 98664 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.