Closed Bug 1478425 Opened Last year Closed Last year

Button does not update appearance when class changed

Categories

(Core :: Layout, defect)

61 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1472465

People

(Reporter: ken, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0
Build ID: 20180704003137

Steps to reproduce:

Visit https://apps.geocortex.com/workflow/designer/
(For this particular site, you need to create an ArcGIS login, which is free.)
Click File > New > Blank Workflow.



Actual results:

The "Create" button remains faded (less opaque), appearing disabled.


Expected results:

The button should appear 100% opaque. If you inspect the element, the class updates but the appearance of the button does not.
Component: Untriaged → Layout
Product: Firefox → Core
Can repro on 61, but can't repro it on Nighly, FWIW. Trying to see what fixed it now. If someone could turn that into a reduced test-case it'd be really helpful so we can use it as a regression test.
Mozregression says that bug 1472465 fixed this, which landed with tests, so not much left to do here.

Thanks a lot for the report! Let me know if you are the owner of the site and need a workaround or what not, I can ask Miko to provide one.
Status: UNCONFIRMED → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1472465
Yes, I am one of the developers responsible for this site. A workaround would be useful.

Do you know when the fix will be released?
(In reply to Ken Lyon from comment #3)
> Yes, I am one of the developers responsible for this site. A workaround
> would be useful.

Miko, any chance you could try to find a workaround for this?

> Do you know when the fix will be released?

Looks like Firefox 62 will contain the fix, so you should be able to try it on beta and confirm it works.
Flags: needinfo?(mikokm)
(In reply to Emilio Cobos Álvarez (:emilio) from comment #4)

> Looks like Firefox 62 will contain the fix, so you should be able to try it
> on beta and confirm it works.

Yes, the beta version works. I tested using 62.0b13 and the problem is no longer present.
The original bug was a problem with repainting the element after opacity value had changed, right after the element location had changed.

I think the easiest workaround here would be to change some other CSS property of the button (affecting the whole area of the button) along with the opacity.

Adding a white border for disabled button worked for me in devtools:

.disabled.button {
  cursor: default;
  opacity: 0.3;
  border: 1px solid #FFFFFF !important;
}
Flags: needinfo?(mikokm)
(In reply to Miko Mynttinen [:miko] from comment #6)

> Adding a white border for disabled button worked for me in devtools:
> 
> .disabled.button {
>   cursor: default;
>   opacity: 0.3;
>   border: 1px solid #FFFFFF !important;
> }

Thanks for the workaround. That works really well, and the border isn't noticeable either which is a bonus.
You need to log in before you can comment on or make changes to this bug.