Rename `URI_CAN_LOAD_IN_PRIVILEGED_CHILD` to `URI_MUST_USE_PRIVILEGED_CHILD_IF_AVAILABLE` in nsIAboutModule

NEW
Assigned to

Status

()

enhancement
P1
normal
9 months ago
6 months ago

People

(Reporter: imjching, Assigned: imjching)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

9 months ago
At the moment, we should not take the `URI_CAN_LOAD_IN_PRIVILEGED_CHILD` flag in nsIAboutModule literally. We will *always* use the privileged content process if the flag is enabled and the `browser.tabs.remote.separatePrivilegedContentProcess` pref is turned on.

We should rename the flag to something less confusing like `URI_MUST_USE_PRIVILEGED_CHILD_IF_AVAILABLE`.
(Assignee)

Updated

9 months ago
Depends on: 1472212
Severity: normal → enhancement
Iteration: --- → 63.3 - Aug 6
Priority: -- → P1
Iteration: 63.3 - Aug 6 → ---
You need to log in before you can comment on or make changes to this bug.