non-existant years cause unusable calendar

RESOLVED WONTFIX

Status

Calendar
General
RESOLVED WONTFIX
16 years ago
12 years ago

People

(Reporter: Brant Gurganus, Unassigned)

Tracking

Details

(Reporter)

Description

16 years ago
Call me crazy, but the best way to find bugs is to do something unexpected so I
clicked the back a year button and made it to the year 0.  The problem is that
there is no year 0.  The calendar goes from 1BC to 1AD.  Further clicking of the
back a year button goes to undefinder (NaN) years which are not correct.  At
this point JavaScript errors occur:

Error: newMonthItem has no properties
Source File: chrome://calendar/content/datepicker/datepicker.js
Line: 313

Error: uncaught exception: [Exception... "Component returned failure code:
0x80004005 (NS_ERROR_FAILURE) [nsIStringBundle.GetStringFromName]"  nsresult:
"0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame ::
chrome://calendar/content/dateUtils.js :: anonymous :: line 131"  data: no]

Also, from here, I can neither go forward nor back any years, months, or days.
When I click a day, I get the error:

Error: ThisBox has no properties
Source File: chrome://calendar/content/calendarMonthView.js
Line: 538

If I switch to week view (I was in month view) and go backwards in weeks past
the beginning of the year and go back to month view, I am back to 2001.  At this
point, I did not want to go back a year 2002 times to see what other errors I
could produce, but I am sure there are others.

Comment 1

16 years ago
That's some good QA. :)
Status: NEW → ASSIGNED
(Reporter)

Comment 2

16 years ago
This belongs in a new bug, but when I was doing this, I would find it nice to be
able to type in the year number instead of pressing the prev/next year buttons.

By the way, what happens in year 10000?  I'm not pressing next year 8000 times
though.

Comment 3

16 years ago
Someone else can take this on. It shouldn't be too hard...
Assignee: mikep → nobody
Status: ASSIGNED → NEW

Comment 4

16 years ago
Brant: For pretty much any computer working right now, any date in 10000CE or
beyond is b0rken. Not like any of these computers will be working then anyways,
considering that for most of them, the time/date counters are supposed to
overflow some time in 2038 anyways.
(Reporter)

Comment 5

16 years ago
Regarding Comment #2, it works fine past Y10K.

Comment 6

16 years ago
I'm going to mark this bug as won't fix, because, realistically, no one is ever
going to take this on.  If you want to use the calendar to schedule events in
the year 0, then you'll have to use some other system.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
The bugspam monkeys have been set free and are feeding on Calendar :: General. Be afraid for your sanity!
QA Contact: colint → general
You need to log in before you can comment on or make changes to this bug.