Closed Bug 1478558 Opened Last year Closed Last year

Remove usage of http://mozqa.com/ in services/sync/tests/tps/test_tabs.js

Categories

(Testing Graveyard :: TPS, enhancement, major)

Version 3
enhancement
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED
mozilla63

People

(Reporter: whimboo, Assigned: markh)

References

Details

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1336257 +++

In bug 1336257 we moved to HTTPS but now with the SCL3 datacenter shutdown coming closer we want to completely get rid of that host. As such all firefox-ui tests already moved away from mozqa.com via bug 1414776. The only remaining instances for that host are the ones from TPS now:

var tabs1 = [
  { uri: "https://mozqa.com/data/firefox/layout/mozilla.html",
    title: "Mozilla",
    profile: "profile1"
...
var tabs2 = [
  { uri: "https://mozqa.com/data/firefox/layout/mozilla_community.html",
    title: "Mozilla Community",
    profile: "profile2"

A question which raises for me is why do we need those external URLs? Would it be also fine to load them locally, or even via data URLs? If both wouldn't work what about eg. https://sha256.badssl.com/?

We would need this patch being uplifted to 62 and esr60 to meet the shutdown criteria of SCL3.
Flags: needinfo?(tchiovoloni)
Flags: needinfo?(markh)
> A question which raises for me is why do we need those external URLs? Would it be also fine to load them locally, or even via data URLs? If both wouldn't work what about eg. https://sha256.badssl.com/?

We have test coverage for syncing tabs from non-external urls already, and have had times when one breaks but not the other, so it would be better to keep them pointed at external URLs. https://sha256.badssl.com would probably work, although I think this test needs two separate URLs.

(I have to grumble though, when we switched this in bug 1336257 last year we were told to "replace 'http://mozqa.com' with 'https://mozqa.com'. This is available immediately and will remain working and supported."...)
Flags: needinfo?(tchiovoloni)
As Thom said, I think any URL would be fine, but should be a real https:// url. One on sumo or mozilla.org seems fine to me and I don't think the traffic we'd generate will ever be a problem. The only necessary change should be those URLs (ie, no additional code changes should be necessary)

IIUC, we only currently use TPS on Nightly, so it's probably not necessary to uplift.
Flags: needinfo?(markh)
(In reply to Thom Chiovoloni [:tcsc] from comment #1)
> We have test coverage for syncing tabs from non-external urls already, and
> have had times when one breaks but not the other, so it would be better to
> keep them pointed at external URLs. https://sha256.badssl.com would probably
> work, although I think this test needs two separate URLs.

Do you mean different URLs in terms of different domains, or are different hosts also fine? There are a couple more valid HTTPs hosts on badssl.com which you might be able to use. Or go the way as Mark suggested.

> (I have to grumble though, when we switched this in bug 1336257 last year we
> were told to "replace 'http://mozqa.com' with 'https://mozqa.com'. This is
> available immediately and will remain working and supported."...)

At that time it probably wasn't that clear what should/will happen with that host. It's not really maintained all the last years and as such causes some problems in IT. Given that it was mainly setup for my/our purposes, and we don't need it anymore we simply want to get rid of it. 

Changing those two URLs is in-fact simple, and I could even provide a patch if you don't have the time to fix it yourself.
To add some more context here : 

1) badssl.com is the way to go for testing (it's a joint effort between Google and Mozilla, it's what Chrome uses for SSL related tests as well). 

2) The SCL3 datacenter is powering down by August 31st. That's where mozqa.com is hosted. We're also taking that opportunity to clean up applications and systems that aren't being actively maintained, hence the push from Henrik to move to something that is actively maintained. 

I'm happy to jump on a call if needed to explain further :) Sorry for the inconvenience caused by having to switch URLs again.
(In reply to Shyam Mani [:fox2mike] from comment #4)
> 1) badssl.com is the way to go for testing (it's a joint effort between
> Google and Mozilla, it's what Chrome uses for SSL related tests as well). 

Note that these tests have nothing to do with ssl and regular http sites would be just as valid, so badssl.com seems the wrong choice here. Are you suggesting it is correct regardless, or were you under the impression that these tests were somehow related to ssl?
Flags: needinfo?(smani)
(In reply to Mark Hammond [:markh] from comment #5)
 
> Note that these tests have nothing to do with ssl and regular http sites
> would be just as valid, so badssl.com seems the wrong choice here. Are you
> suggesting it is correct regardless, or were you under the impression that
> these tests were somehow related to ssl?

Oh, my suggestion was based on these were somehow related to SSL. Thanks for clarifying.
Flags: needinfo?(smani)
(In reply to Thom Chiovoloni [:tcsc] from comment #1)
> (I have to grumble though, when we switched this in bug 1336257 last year we
> were told to "replace 'http://mozqa.com' with 'https://mozqa.com'. This is
> available immediately and will remain working and supported."...)

I apologize, for whatever it's worth, for any confusion from this. It's been a very difficult couple years for the various of us involved in solving the MOZQA.COM problem — for example, our load balancers stopped permitting one of the intentionally-invalid SSL configurations unexpectedly last year — and we've encountered a wide variety of delays along the way as well. Our intentions were to have these changes gradually ride the trains, but so many complications have cropped up that we're running into datacenter timelines and have had to request out-of-order uplifts. Thank you for your patience with all of this.
Comment on attachment 8996187 [details]
Bug 1478558 - Remove usage of http://mozqa.com/ in services/sync/tests/tps/test_tabs.js

Henrik Skupin (:whimboo) has approved the revision.

https://phabricator.services.mozilla.com/D2547
Attachment #8996187 - Flags: review+
Product: Testing → Testing Graveyard
Assignee: nobody → markh
Status: NEW → ASSIGNED
Comment on attachment 8996187 [details]
Bug 1478558 - Remove usage of http://mozqa.com/ in services/sync/tests/tps/test_tabs.js

Thom Chiovoloni [:tcsc] has approved the revision.
Attachment #8996187 - Flags: review+
Pushed by mhammond@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e7eb8b37d85e
Remove usage of http://mozqa.com/ in services/sync/tests/tps/test_tabs.js r=whimboo,tcsc
https://hg.mozilla.org/mozilla-central/rev/e7eb8b37d85e
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
Mark, I don't know how your are testing TPS. But do we have to get this uplifted to beta, and esr60? If you don't test on those branches we might be fine without. Thanks.
Flags: needinfo?(markh)
Thanks Henrik, but we only use Nightly so I think we are good.
Flags: needinfo?(markh)
You need to log in before you can comment on or make changes to this bug.