Last Comment Bug 147856 - with application/xhtml+xml, body does not cover the whole screen
: with application/xhtml+xml, body does not cover the whole screen
Status: RESOLVED INVALID
:
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Marc Attinasi
: Chris Petersen
:
Mentors:
http://www.ego4u.de/test/pog2/body.xhtml
: 195622 297576 344025 379376 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-29 07:20 PDT by Mario Mueller
Modified: 2007-05-01 21:56 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Mario Mueller 2002-05-29 07:20:59 PDT
I have two sites with the same content.

  http://www.ego4u.de/test/pog1/body.xhtml

  http://www.ego4u.de/test/pog2/body.xhtml

Both are XHTML1.1 documents and they have a colored body element. pog1 has
Content-type text/html and the complete background is colored. pog2 is delivered
with application/xhtml+xml and only the part with content is colored.

I think this is a bug in the xhtml renderer. It's possible, that the bug is
connected with Bug#:111514
Comment 1 Boris 'pi' Piwinger 2002-05-29 07:44:40 PDT
Not sure if this is bug 111514, but I see the problem with Linux.

pi
Comment 2 Boris Zbarsky [:bz] (still a bit busy) 2002-05-29 12:42:03 PDT
<body> never covers the whole screen -- put a border on it to see that.  In 
HTML (_not_ XHTML) it is recommended by CSS2 that the body background be 
propagated to the root element (which is <html>) so that it will cover the 
whole canvas as it does in legacy browsers.

If you want your background to cover the whole canvas, set it on your root 
element, not on some random child.
Comment 3 Mario Mueller 2002-05-29 16:40:49 PDT
Please, can you descibe me why the css2 specs recommend that authors specify the
background for the BODY element rather than the HTML element?

http://www.w3.org/TR/REC-CSS2/colors.html#q2
Comment 4 Boris Zbarsky [:bz] (still a bit busy) 2002-05-29 20:44:24 PDT
For backwards compatibility with user-agents which do not implement that part 
of the specification correctly (NS4, IE5/Windows, IE5.5/Windows, etc).  Also, 
that is for HTML, not XHTML.  If you try serving your XHTML as text/html (so 
it's treated as an HTML document) you will see that the background is 
propagated as expected.

In practice, setting the background on both <html> and <body> is a good idea.
Comment 5 Josh Birnbaum 2003-03-02 07:51:19 PST
*** Bug 195622 has been marked as a duplicate of this bug. ***
Comment 6 Josh Birnbaum 2005-06-13 13:19:38 PDT
*** Bug 297576 has been marked as a duplicate of this bug. ***
Comment 7 Eli Friedman 2006-07-09 13:10:37 PDT
*** Bug 344025 has been marked as a duplicate of this bug. ***
Comment 8 Arie Paap [:wildmyron] 2007-05-01 21:56:02 PDT
*** Bug 379376 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.