Resolving address bar search terms disables search until retyped

VERIFIED DUPLICATE of bug 147667

Status

VERIFIED DUPLICATE of bug 147667
17 years ago
14 years ago

People

(Reporter: nick, Assigned: Matti)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
To reproduce:

1. Type the search terms 'foo bar' into the address bar
2. Press [Enter] to attempt to resolve the terms
3. Wait for the error dialog and OK it
4. Click on the address bar
5. Press cursor down twice to highlight the search option
6. Press [Enter] to perform the search

Expected Behaviour:
  A search is performed with the entered terms

Actual Behaviour:
  The browser attempts to resolve the terms again

Workaround:
  Edit or retype the search terms

Comment 1

17 years ago
I see this behaviour on:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0) Gecko/20020528
Build: 2002052806

When you try to resolve 'foo bar' the first time it 
tries to lookup 'www.foo bar.com'. This fails.
Pressing down to highlight the search option should
cause a search for 'foo bar' but instead it tries
to resolve 'www.foo bar.com' again.

Another work arround is to press down to open the 
drop down with the 'Search foo' at the bottom then
click on the 'Search foo' using the mouse.

Comment 2

17 years ago
Can confirm this bug with RC3 (2002052306) on WinMe

Comment 3

17 years ago

*** This bug has been marked as a duplicate of 147667 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.