Closed Bug 1478580 Opened 3 years ago Closed 3 years ago

Attendee dialog control look like disabled in ESR60 on Windows

Categories

(Calendar :: Dialogs, defect)

Lightning 6.2
Unspecified
Windows
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: MakeMyDay, Assigned: Paenglab)

References

Details

(Keywords: regression)

Attachments

(2 files)

In the ESR version Lightning 6.2, the listboxes for the attendees list and the freebusy grid have a grey background for Windows - suggesting those wehere disabled. This should be white instead.

For post ESR60, this will be fixed with bug 1477478, so the issue needs an ESR60 only fix.

Richard, can you take a look at it?
Which panel is that? "Invite Attendees" looks OK to me.
This is what is see - ESR60b10 is in the foreground, ESR52 for reference in the background. I haven't checked with a new profile though - you don't see the issue?
Yes, grey background, I didn't notice it.
Toolkit removed the background color of listboxes because it's not needed when -moz-appearance: listbox; is set. Here the listboxes are -moz-appearance: none;.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8995289 - Flags: review?(makemyday)
Comment on attachment 8995289 [details] [diff] [review]
attendeeBGColor.patch

Review of attachment 8995289 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for the quick fix. Have you verified this isn't an issue on other platforms?

This should only land on ESR but not on CC/beta since bug 1477478 is about to remove the listboxes entirely.
Attachment #8995289 - Flags: review?(makemyday)
Attachment #8995289 - Flags: review+
Attachment #8995289 - Flags: approval-calendar-esr?(philipp)
I checked all platforms and it's only a Windows issue.
Comment on attachment 8995289 [details] [diff] [review]
attendeeBGColor.patch

So far beta has the listboxes, so if we do a beta, we will me need this.
Attachment #8995289 - Flags: approval-calendar-beta?(philipp)
Up to you, but if you land this on beta, you should backout it again with landing bug 1477478 on beta (which should be the plan), so probably it's not worth the effort to land it there.
Frankly, I don't know what the plans for beta are in general given all the test failures due to the M-C overlay loader still being active. That said, why would uplifting the listbox removal be necessary? What am I missing?
If there will be no beta for 62, then there is also no point to uplift it to beta in the first place, since uplifting only should happen for release purpose. Calendar is traditionally quite conservative with uplifting (and this is for a reason). But we should keep the discussion about 62 being ready for a beta release out of this bug.
Sadly you still haven't explained why bug 1477478 is a beta 62 uplift candidate, see "which should be the plan" (comment #8). As far as I can see, it's a pure bustage fix for an M-C feature that got withdrawn at mozilla63, so no uplift required.

This bug here *is* an uplift candidate, since if we build TB 62 beta, we shouldn't regress something that got fixed in TB 60 ESR.
I don't know for sure, but its at least likely that freebusy lookup will not work, but I haven't tested. Bug 1101381 was just a bandaid patch to at least make adding attendees possible, for anything left not working for 62, bug 1477478 would be the answer.
Thanks for the try push - but if I read it correctly, this is based on mozilla-esr60, which was expected to work. More interestingly would be a try push for 62 once the overlay loader thing is in shape there. If it worked there, too, I would agree with you that there is no need for uplifting bug 1477478.
I did the try push together with bug 1477641. The state of TB 62 with Calendar 6.4 is for others to assess. As far as I can tell, independent of this small CSS change here, it's mostly not working:
https://treeherder.mozilla.org/#/jobs?repo=comm-beta&revision=11ccbb8139d06af407655115817e50c07f8121ab&selectedJob=190005414
Hard to tell whether the attendee dialogue works. But other things surely fail.
Just download a build via that link and try it.
Comment on attachment 8995289 [details] [diff] [review]
attendeeBGColor.patch

I didn't know -moz-field was case insensitive. Anyway, a+ for whatever you need, I'm certain you will find out where these few lines should best land.
Attachment #8995289 - Flags: approval-calendar-esr?(philipp)
Attachment #8995289 - Flags: approval-calendar-esr+
Attachment #8995289 - Flags: approval-calendar-beta?(philipp)
Attachment #8995289 - Flags: approval-calendar-beta+
checkin-needed for ESR60.
Keywords: checkin-needed
TB 60 ESR, Cal 6.2:
https://hg.mozilla.org/releases/comm-esr60/rev/e412da29421f
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 6.2
Attachment #8995289 - Flags: approval-calendar-beta+
You need to log in before you can comment on or make changes to this bug.