Open Bug 1478626 Opened Last year Updated Last year

Remove unused Browser:NextTab and Browser:PrevTab commands

Categories

(Firefox :: Keyboard Navigation, defect, P3)

defect

Tracking

()

REOPENED
Firefox 63
Tracking Status
firefox63 --- disabled
firefox64 --- disabled

People

(Reporter: dao, Unassigned)

References

(Depends on 1 open bug)

Details

(Keywords: regression)

Attachments

(2 files)

Attached patch patch_v1.diffSplinter Review
Attachment #8997100 - Flags: review?(dao+bmo)
Comment on attachment 8997100 [details] [diff] [review]
patch_v1.diff

Thanks!
Attachment #8997100 - Flags: review?(dao+bmo) → review+
Assignee: nobody → so61pi.re
Keywords: checkin-needed
Pushed by ncsoregi@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/69bd5eb50a32
Remove unused Browser:NextTab and Browser:PrevTab commands. r=dao
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/69bd5eb50a32
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
I was using these commands, via the "browser.gesture.twist.left" and "browser.gesture.twist.right" preferences.  My nightly just got updated to one with this changeset, and now twist to switch tabs is broken.  What is the  replacement I should be using?
Flags: needinfo?(dao+bmo)
(In reply to Boris Zbarsky [:bzbarsky, bz on IRC] from comment #5)
> I was using these commands, via the "browser.gesture.twist.left" and
> "browser.gesture.twist.right" preferences.  My nightly just got updated to
> one with this changeset, and now twist to switch tabs is broken.  What is
> the  replacement I should be using?

I guess there is none. This can happen with hidden prefs that are essentially unsupported. If we consider gesture customization important enough, we should probably provide a web extension API for this.
Flags: needinfo?(dao+bmo)
We can do that (and should, and I filed bug 1486613 on that yesterday), but given that all the infrastructure for the prefs and mapping them to commands is still in place, and that this is a widely documented Firefox feature, what is the benefit of removing the two commands that outweighs the usability loss to people who were using the feature?
Flags: needinfo?(dao+bmo)
Used it alongside browser.gesture.pinch.in = cmd_newNavigatorTab, browser.gesture.pinch.out = cmd_close, browser.gesture.tap = History:UndoCloseTab. Thanks to those features I could use Firefox with one hand, without ever taking it off touchpad. Unless I needed to type something. I would imagine it's not hard to maintain, since only the handle for those features was removed. Instead of removing "unused" feature, why not create a beautiful wiki page for it and make it more popular? The only reason people don't use it is cause they just don't know about it. Firefox is the only one-hand capable browser thanks to this.
I was using this too via browser.gesture.swipe.left/right. As soon as a feature makes it to web search it's no longer "hidden" or "unsupported" generally, and it's certainly useful, so unless there are good reasons for removing it this just seems like busy work that just breaks people's workflows. And will now make me downgrade and turn off auto updates for the nightly, which will also make my browser more insecure.
Seems like we removed it because we thought it wasn't used, which turned out to not be the case. I'd be in favor of reverting this patch until we have a suitable web extension API in place. </2cents>
Yes, please revert!  I have worked around this using BetterTouchTool on the mac but a native solution would be better.
(In reply to Mike Taylor [:miketaylr] (62 Regression Engineering Owner) from comment #10)
> Seems like we removed it because we thought it wasn't used, which turned out
> to not be the case.

Kinda. I don't think some people setting a hidden pref necessarily qualifies as "used" in the grand scheme of things, but I didn't know this was documented widely.

We can revert this for now.
Flags: needinfo?(dao+bmo)
https://hg.mozilla.org/integration/mozilla-inbound/rev/be87e01f5f235c9919485606fd65cd58417d3ebc
Assignee: so61pi.re → nobody
Mentor: dao+bmo
Status: RESOLVED → REOPENED
Depends on: 1486613
Keywords: good-first-bug
Resolution: FIXED → ---
Whiteboard: [lang=xul]
Attachment #9006519 - Flags: approval-mozilla-beta?
Attachment #9006519 - Attachment is patch: true
Attachment #9006519 - Attachment mime type: application/octet-stream → text/plain
Comment on attachment 9006519 [details] [diff] [review]
revert change on beta

Review of attachment 9006519 [details] [diff] [review]:
-----------------------------------------------------------------

Approved for the next 63 beta as the users' workflow regressions were not intended
Attachment #9006519 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Keywords: checkin-needed
Whiteboard: checkin-needed: revert change on beta
Attachment #8997100 - Flags: review+
Whiteboard: checkin-needed: revert change on beta
Change on beta reverted by landing the above commit.
You need to log in before you can comment on or make changes to this bug.