Closed Bug 14787 Opened 21 years ago Closed 21 years ago

[BLOCKER] crash in making profile in apprunner

Categories

(SeaMonkey :: General, defect, P3)

x86
Windows NT
defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 13780

People

(Reporter: karnaze, Assigned: neeti)

Details

I pulled today around noon, removed mozregistry.dat and user50. I get a crash
when creating the profile in apprunner.


nsPresContext::PreferenceChanged(const char * 0x024fee30) line 252 + 19 bytes
PrefChangedCallback(const char * 0x024fee30, void * 0x019cf1d0) line 55
pref_DoCallback(const char * 0x024fee30) line 2294 + 17 bytes
pref_HashPref(const char * 0x024fee30, PrefValue {...}, int 32, int 0) line 1865
+ 9 bytes
PREF_SetDefaultCharPref(const char * 0x024fee30, const char * 0x024fedb0) line
799 + 17 bytes
nsPref::SetDefaultCharPref(nsPref * const 0x00ecadd0, const char * 0x024fee30,
const char * 0x024fedb0) line 691 + 13 bytes
XPTC_InvokeByIndex(nsISupports * 0x00ecadd0, unsigned int 38, unsigned int 2,
nsXPTCVariant * 0x0012e52c) line 135
nsXPCWrappedNativeClass::CallWrappedMethod(JSContext * 0x02094eb0,
nsXPCWrappedNative * 0x024fd0f0, const XPCNativeMemberDescriptor * 0x01b9f3e0,
nsXPCWrappedNativeClass::CallMode CALL_METHOD, unsigned int 2, long *
0x00cfb028, long * 0x0012e6cc) line 751 + 44 bytes
WrappedNative_CallMethod(JSContext * 0x02094eb0, JSObject * 0x00d19e60, unsigned
int 2, long * 0x00cfb028, long * 0x0012e6cc) line 170 + 34 bytes
js_Invoke(JSContext * 0x02094eb0, unsigned int 2, unsigned int 0) line 655 + 26
bytes
js_Interpret(JSContext * 0x02094eb0, long * 0x0012ef44) line 2232 + 15 bytes
js_Invoke(JSContext * 0x02094eb0, unsigned int 0, unsigned int 0) line 671 + 13
bytes
js_Interpret(JSContext * 0x02094eb0, long * 0x0012f778) line 2232 + 15 bytes
js_Invoke(JSContext * 0x02094eb0, unsigned int 1, unsigned int 2) line 671 + 13
bytes
js_InternalCall(JSContext * 0x02094eb0, JSObject * 0x00b9bf50, long 14271224,
unsigned int 1, long * 0x0012f8f8, long * 0x0012f8b0) line 748 + 15 bytes
JS_CallFunction(JSContext * 0x02094eb0, JSObject * 0x00b9bf50, JSFunction *
0x021584a0, unsigned int 1, long * 0x0012f8f8, long * 0x0012f8b0) line 2634 + 32
bytes
nsJSContext::CallFunction(nsJSContext * const 0x020934e0, void * 0x00b9bf50,
void * 0x021584a0, unsigned int 1, void * 0x0012f8f8, int * 0x0012f8f4) line 231
+ 39 bytes
nsJSEventListener::HandleEvent(nsIDOMEvent * 0x024965d0) line 103 + 48 bytes
nsEventListenerManager::HandleEvent(nsIPresContext & {...}, nsEvent *
0x0012fc60, nsIDOMEvent * * 0x0012fafc, unsigned int 7, nsEventStatus &
nsEventStatus_eIgnore) line 1012 + 21 bytes
GlobalWindowImpl::HandleDOMEvent(GlobalWindowImpl * const 0x02093534,
nsIPresContext & {...}, nsEvent * 0x0012fc60, nsIDOMEvent * * 0x0012fafc,
unsigned int 1, nsEventStatus & nsEventStatus_eIgnore) line 2838
nsWebShell::OnEndDocumentLoad(nsWebShell * const 0x020b59b4, nsIDocumentLoader *
0x020b5930, nsIChannel * 0x02154190, unsigned int 0, nsIDocumentLoaderObserver *
0x020b59b4) line 3361 + 34 bytes
nsDocLoaderImpl::FireOnEndDocumentLoad(nsDocLoaderImpl * 0x020b5930, nsIChannel
* 0x02154190, unsigned int 0) line 885
nsDocLoaderImpl::OnStopRequest(nsDocLoaderImpl * const 0x020b5934, nsIChannel *
0x024ad690, nsISupports * 0x00000000, unsigned int 0, const unsigned short *
0x00000000) line 768
nsLoadGroup::RemoveChannel(nsLoadGroup * const 0x020b58c0, nsIChannel *
0x024ad690, nsISupports * 0x00000000, unsigned int 0, const unsigned short *
0x00000000) line 597 + 39 bytes
nsFileChannel::OnStopRequest(nsFileChannel * const 0x024ad694, nsIChannel *
0x024ad060, nsISupports * 0x00000000, unsigned int 0, const unsigned short *
0x00000000) line 475
nsOnStopRequestEvent::HandleEvent(nsOnStopRequestEvent * const 0x024ae230) line
283
nsStreamListenerEvent::HandlePLEvent(PLEvent * 0x024aff30) line 152 + 12 bytes
PL_HandleEvent(PLEvent * 0x024aff30) line 541 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x00ec9540) line 500 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x00260522, unsigned int 49367, unsigned int 0,
long 15504704) line 970 + 9 bytes
USER32! DispatchMessageWorker@8 + 135 bytes
USER32! DispatchMessageA@4 + 11 bytes
nsAppShell::Run() line 74
nsAppShellService::Run(nsAppShellService * const 0x00ec9b30) line 462
main1(int 1, char * * 0x00ba4ac0) line 591 + 12 bytes
main(int 1, char * * 0x00ba4ac0) line 702 + 13 bytes
mainCRTStartup() line 338 + 17 bytes
KER
Assignee: rickg → neeti
Component: Viewer App → Browser-General
Changing module to browser-general; but it's really a preference bug.
Reassigning to module owner.
I think this is a dup of bug 13780
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 13780 ***
Status: RESOLVED → VERIFIED
Verified dupe of bug 13780.  sspitzer@netscape.com set up the prefs state upon
new profile creation.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.