Closed Bug 1478735 Opened Last year Closed Last year

Download with target=_blank switches to other tab target=_blank

Categories

(Firefox for Android :: Download Manager, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 64
Tracking Status
firefox62 --- wontfix
firefox63 --- wontfix
firefox64 --- fixed

People

(Reporter: agashlin, Assigned: andrei.a.lazar)

References

Details

(Keywords: regression, Whiteboard: --do_not_change--[priority:high])

Attachments

(2 files)

Attached file tabs_example.zip
Using the attached example in fennec:

1. Open index.html
2. Tap the first link ("index.html"), which opens in a new tab
3. Switch back to the first tab
4. Tap the second link ("blah.wav"). A new tab briefly opens and disappears, then we switch to the second tab. Meanwhile the prompt for what to do with the download is in the first tab.

This doesn't seem to happen if I simply have another tab open, the second tab has to be _blank.

I tried to do a mozregression bisection on this but I wasn't able to find a build where we don't switch to the second tab. I did find that earlier in 2017 the "what to do with this download" prompt at least shows up, instead of showing up on the wrong tab, the range for this was:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=ef813898b5d34ef03428b1cee37a329f425db6e7&tochange=9e45f48ecf55f1d184834bb287411c17bb635a95

But that probably doesn't need to be fixed, if we properly switched back to the first tab the prompt would be visible.
Jim seems to be a regression from work about a year ago. Any thoughts if this is a simple thing to address?
Blocks: 1393128
Flags: needinfo?(nchen)
I think someone from Susheel's team should take a look. Since it's reproducible I don't think it'll take too long
Flags: needinfo?(nchen)
Comment 1 and 2
Flags: needinfo?(sdaswani)
Put it on the work queue.
Flags: needinfo?(sdaswani)
Whiteboard: --do_not_change--[priority:high]
Assignee: nobody → vlad.baicu
Assignee: vlad.baicu → andrei.a.lazar
Fwiw, while testing I noticed that Fennec is not shown as an option when opening .html files from the device, but Chrome is, you have to put the path to the file to access it e.g. file:///sdcard/Download/index.html.

Based on the findings of our QA team, it seems to be the issue reported here https://bugzilla.mozilla.org/show_bug.cgi?id=1375035
Depends on: 1375035
Download with target=_blank now switches to the parent tab.
Keywords: checkin-needed
Pushed by apavel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a42437c2e1fe
Download with target=_blank switches to other tab target=_blank r=JanH,jchen
Keywords: checkin-needed
Keywords: checkin-needed
As per this comment https://phabricator.services.mozilla.com/D6928#185569 this needs some modifications before landing. Removing the chechin-needed.
Keywords: checkin-needed
Flags: needinfo?(andrei.a.lazar)
Keywords: checkin-needed
Pushed by ebalazs@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e9dfaf584e37
Download with target=_blank switches to other tab target=_blank r=JanH,jchen
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/e9dfaf584e37
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 64
You need to log in before you can comment on or make changes to this bug.