Closed Bug 1478755 Opened Last year Closed Last year

Flash of recommended story in third tile while loading spoc

Categories

(Firefox :: New Tab Page, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 63
Iteration:
63.5 - Sep 3
Tracking Status
firefox63 --- verified

People

(Reporter: thecount, Assigned: thecount)

References

Details

Attachments

(3 files)

Found in https://bugzilla.mozilla.org/show_bug.cgi?id=1472292

See attachment to get an idea of the issue in action.

What happens is when the stories get fetched, the recs are inserted, then an event is fired to notify of an update https://github.com/mozilla/activity-stream/blob/master/lib/TopStoriesFeed.jsm#L101

When that's done a NEW_TAB_REHYDRATED even is fired which causes us to add the spoc: https://github.com/mozilla/activity-stream/blob/master/lib/TopStoriesFeed.jsm#L468

This is most likely causing the delay. It also looks like this is here to ensure that
1. spocs never delay a rec being shown because there is no guarantee a spoc is going to be added.
2. Waiting for recs to be done before inserting a spoc ensure a rec never loads on top of a spoc.

If we are to fire off adding spocs at the same time to start adding recs, we'll reduce the delay, but need to ensure if we are adding a rec in the third spot, we check to make sure a spoc isn't already there.
Assignee: nobody → sdowne
Iteration: --- → 63.3 - Aug 6
Priority: -- → P1
Blocks: 1486631
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
https://hg.mozilla.org/mozilla-central/rev/332b73bd0c42
Iteration: 63.3 - Aug 6 → 63.5 - Sep 3
Target Milestone: --- → Firefox 63
I have verified that this issue is no longer reproducible on Windows 10 x64, Arch Linux and Mac 10.13.3 with the latest "Firefox Nightly" (63.0a1 - Build ID 20180902220539) installed. Now the sponsored content is no longer displayed after a normal one.
Status: RESOLVED → VERIFIED
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.