The default bug view has changed. See this FAQ.

Searching in newsgroups fails (XPAT not supported by some news servers)

RESOLVED DUPLICATE of bug 98836

Status

MailNews Core
Search
RESOLVED DUPLICATE of bug 98836
15 years ago
8 years ago

People

(Reporter: ISHIKAWA, Chiaki, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
In contrast to older netscape, Mozilla uses
XPAT
command to search for articles, say, a string in a subject line.

Unfortunately, some news servers (such as nntpcache) doesn't support
XPAT yet.
Hence, I can't use the mozilla's search function for, say,
searching news articles for a given string.

I wonder if Mozilla can be modified to
use older netscape-like search function without
using "XPAT" command on user preference request.
(A la the switch between HTTP/1.1 and HTTP/1.0).

I won't mind the reduced functionality when XPAT is not used.

(I know that the use of XPAT probably saves some bandwidth since
the selection of resulting articles is done on the server-side as 
opposed to the client side as in the netscape 4.x  presumably.)

Comment 1

15 years ago
There are a couple existing bugs about this, I'm sure.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

14 years ago
> There are a couple existing bugs about this, I'm sure.

Which ones?
(Reporter)

Comment 3

14 years ago
>> There are a couple existing bugs about this, I'm sure.
>
>Which ones?

I assume that this question is for laurel@netscape.com, and not to me,
ishikawa@yk.rim.or.jp: I received the inquiry via e-mail from
bugzilla. I wonder if the e-mail was automatically sent to 
laurel@netscape.com as well.
mass re-assign.
Assignee: naving → sspitzer

Comment 5

13 years ago
Is this a Dup of Bug 210784
(Reporter)

Comment 6

13 years ago
Created attachment 149452 [details]
This is an image of search subject line of a newsgroup.

Use of XPAT causes an error message from the newsserver.
(Reporter)

Comment 7

13 years ago
e comment #5 above, I created attachment mentioned in #6.

Please note the error dialog shown after
I hit SEARCH button.

Right, I can't even use the search with mozilla while
netscape 4.xx works. The news server is nntpcache.
(Maybe I should upgrade the severity.)

I read the mentioned the bug 210784 .

But given that XPAT command doesn't even work against
some newsserver(s), I don't think this is the same
issue.

Obviously, there were attempts by others to implement
"XPAT" command, but it never materialized as far as I can tell.

(In reply to comment #5)
> Is this a Dup of Bug 210784

Comment 8

13 years ago
(In reply to comment #7)
> e comment #5 above, I created attachment mentioned in #6.
> 
> Please note the error dialog shown after
> I hit SEARCH button.

Is the error dialog authored on the server side?
I use Giganews <www.giganews.com>, which I know does not support XPAT. The error
message I get is:
"A News (NNTP) error occurred: xpat not supported"

Comment 9

13 years ago
*** Bug 210784 has been marked as a duplicate of this bug. ***

Comment 10

13 years ago
Setting this bug as the core problem bug for failing searches on some news servers.
See RFE bug 83968 for the ability of where to search.
Summary: Use of XPAT for searching articles don't work with some news servers. → Searching in newsgroups fails (XPAT not supported by some news servers)
Product: Browser → Seamonkey

Updated

12 years ago
Assignee: sspitzer → mail

Comment 11

11 years ago
It is possible to search locally downloaded headers by switching to "offline" mode.

Comment 12

11 years ago
Moving to Core. 
Assignee: mail → nobody
Component: MailNews: Search → MailNews: Search
OS: Linux → All
Product: Mozilla Application Suite → Core
QA Contact: laurel → search
Hardware: PC → All

Comment 13

11 years ago
*** Bug 349510 has been marked as a duplicate of this bug. ***

Updated

10 years ago
Duplicate of this bug: 377859

Updated

9 years ago
Duplicate of this bug: 292290
(Assignee)

Updated

9 years ago
Product: Core → MailNews Core
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 98836
You need to log in before you can comment on or make changes to this bug.