Closed Bug 147885 Opened 19 years ago Closed 19 years ago

JavaScript Status bar text from one tab is seen in all tabs.

Categories

(SeaMonkey :: Tabbed Browser, defect)

x86
Windows 98
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 104532

People

(Reporter: ictatha, Assigned: jag+mozilla)

Details

Overview Description:

When viewing multiple pages using the tabbed browsing feature, if a web page
uses JavaScript to continually display text in the status bar (i.e. scrolling
text and other effects), this text is displayed no matter which tab you are viewing.

This gets more interesting when you open pages using these kind of effects in
more than one tab.  Both scripts will work.  The status bar will just flash back
and forth between them (depending, of course, on how often the script is
updating the status bar).

Steps to Reproduce:

1.) Open a few tabs displaying pages with no JavaScript effects.
2.) In one of the tabs, open a page that uses JavaScript status bar text effects
examples:
http://javascriptkit.com/script/cut75.shtml
http://javascriptkit.com/script/cut11.shtml
http://www.web-source.net/javascript_status_clock.htm
http://happysmart.net/JavaScript/StatusBar/StatusBarTime.htm
3.) Go back to the other tabs.  Notice the effect from the other page is still
there.

Expected Results:

I think that only the active tab should have access to the status bar.

Build Dates & Platforms:

I have reproduced this on Win98 using build 2002052306, and on MacOS 9.1 using
build 2002031106.

*** This bug has been marked as a duplicate of 104532 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.