Closed Bug 1478948 Opened 2 years ago Closed 8 months ago

at-spi state for comboboxes keep having the focused state for Linux

Categories

(Thunderbird :: Disability Access, defect)

52 Branch
Unspecified
Linux
defect
Not set
normal

Tracking

(thunderbird_esr60 wontfix, thunderbird_esr68 wontfix, thunderbird72 wontfix, thunderbird73 fixed)

RESOLVED FIXED
Thunderbird 73.0
Tracking Status
thunderbird_esr60 --- wontfix
thunderbird_esr68 --- wontfix
thunderbird72 --- wontfix
thunderbird73 --- fixed

People

(Reporter: samuel.thibault, Unassigned)

References

Details

(Keywords: access, Whiteboard: [fixed by bug 440377])

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0
Build ID: 20180718215440

Steps to reproduce:

- Start writing a new message
- in accerciser, look for the widget corresponding to the "To:" combobox
- look in the accerciser interface navigator, it has the focusable state but not the focused state.
- use tab to get the focus on the "To:" combobox
- in the interface navigator, the focused state has shown up
- use tab to get the focus out from the "To:" combobox


Actual results:

on the last step, the focused state keeps showing up in the interface navigator.


Expected results:

the focused state should have disappeared from the interface navigator.
The same happens with the items of the text style combobox:

- Start writing a new message
- in accerciser, look for the widget corresponding to the "Paragraph" item of the text style combobox
- look in the accerciser interface navigator, it has the focusable state but not the focused state.
- click in the message to get the cursor there
- use the mouse to open the text style combobox
- in the interface navigator, the focused state has shown up
- click in the message again to close the text style combobox

on the last step, the focused state keeps showing up in the interface navigator, while it should have disappeared.
Sorry, this bug as had no attention so far. I'm just looking through a backlog of five months and saw it. This is an accessibility problem, right? What is "accerciser"?
Yes, this poses accessibility issue.

Accerciser is a tool which provides you with an insight of what information a screen reader gets. Here it will show you the "focusable" state.
Richard, who could look into this?
Maybe Marco can look into this and help us check what is wrong.
Flags: needinfo?(mzehe)
I cannot reproduce this on Windows. If I tab away from the combobox again, it correctly loses its focused state. S this is something in the Linux layer specifically, which somehow doesn't pick up that the focus has moved away from the combobox.
Flags: needinfo?(mzehe)
Thank you Marco. We have CSS rule which react on :focus. If this would not go away then the menulist would always show the focused state. I checked this again and it really goes away.

(In reply to Marco Zehe (:MarcoZ) from comment #6)

I cannot reproduce this on Windows. If I tab away from the combobox again,
it correctly loses its focused state. So this is something in the Linux layer
specifically, which somehow doesn't pick up that the focus has moved away
from the combobox.

Does this still exist in 68 or newer?
If so, what is the way forward here?

Keywords: access
OS: Unspecified → Linux
Summary: at-spi state for comboboxes keep having the focused state → at-spi state for comboboxes keep having the focused state for Linux

Do you also see this issue when using versoin 68?

Whiteboard: [closeme 2020-01-04

(In reply to Wayne Mery (:wsmwk) from comment #8)

(In reply to Marco Zehe (:MarcoZ) from comment #6)

I cannot reproduce this on Windows. If I tab away from the combobox again,
it correctly loses its focused state. So this is something in the Linux layer
specifically, which somehow doesn't pick up that the focus has moved away
from the combobox.

Does this still exist in 68 or newer?
If so, what is the way forward here?

With latest redesign made on Thunderbird Daily with bug 440377 this issue is no longer relevant.

Thanks for the update

Status: UNCONFIRMED → RESOLVED
Closed: 8 months ago
Depends on: 440377
Resolution: --- → FIXED
Whiteboard: [closeme 2020-01-04
Component: Untriaged → Disability Access

hmm, this still leaves thunderbird_esr68 affected.

Unless there is an easy fix for esr (paenglab?), I'm guessing we won't be expending energy to do so (Magnus?). I have proactively marked it so.

Flags: needinfo?(richard.marti)
Flags: needinfo?(mkmelin+mozilla)

I don't see the issue, so I can't easily fix it.

Flags: needinfo?(richard.marti)

Agreed.

Flags: needinfo?(mkmelin+mozilla)
Whiteboard: [fixed by bug 440377]
Target Milestone: --- → Thunderbird 73.0
You need to log in before you can comment on or make changes to this bug.