IMAP INBOX doesn't show messages if you delete INBOX.msf and startup

RESOLVED FIXED

Status

RESOLVED FIXED
17 years ago
14 years ago

People

(Reporter: Bienvenu, Assigned: Bienvenu)

Tracking

({regression})

Trunk
x86
Windows 2000
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

17 years ago
If you startup IMAP after deleting INBOX.msf for your default INBOX, the
contents of the inbox don't show until you click on another folder and back on
the inbox. This works on the branch, so it got broken on the trunk somehow.
(Assignee)

Comment 1

17 years ago
what's happening is that we're trying to update the inbox twice, once by
selecting it, and once from MsgGetMessagesForAllServers, and this causes us to
send two folder loaded notifications; the first notification breaks batching and
updating of the view, and causes this problem. I'm trying to figure out what
broke to cause this.
Keywords: regression
(Assignee)

Comment 2

17 years ago
OK, this is caused by ere@atbi.fi's fix for bug 18266, which also causes bug
147903, I'm pretty sure. In particular, changing the call to
MsgGetMessagesForAllServers not to get the defaultServer causes us to get two
updates going on the inbox at startup, which we've gone to a fair amount of
trouble to avoid. Ere did this on purpose, basically, to get ::GetNewMessages
called on startup, so his code could be invoked at startup. I'm not sure how to
fix this - we could try to be more tolerant of having two updates going on, or
we could rework Ere's code to get called when ::UpdateFolder is called on the
Inbox (though that would mean it would get called whenever the user selecte the
INBOX, which may or may not be desirable...)

Updated

17 years ago
QA Contact: olgam → huang
(Assignee)

Comment 3

17 years ago
Created attachment 85474 [details] [diff] [review]
proposed fix

this makes it so we don't send a folder loaded notification if the reason we
didn't run a url is that we were already running a url on this folder. The
theory is that the other url is also a folder load and will cause a folder
loaded notification to get sent. This is not guaranteed to be true, though I'm
hard-pressed to come up with a scenario where it's not true.
Comment on attachment 85474 [details] [diff] [review]
proposed fix

r/sr=sspitzer, which ever you need.
Attachment #85474 - Flags: superreview+

Comment 5

17 years ago
I'm sorry for breaking this. Anyway, I think this is a good patch as it makes
the system more tolerant against me and anyone else who fail to notice such effects.
(Assignee)

Comment 6

17 years ago
can I put r=ere@atp.fi, then, for this patch?

What do you think about having the user selecting the imap inbox do a download
like get new mail? I think a lot of users just know that selecting the inbox
does a get new mail, so they don't bother hitting get new mail.

Comment 7

17 years ago
Comment on attachment 85474 [details] [diff] [review]
proposed fix

r=ere@atp.fi

I have seen people push Get Msgs a few times after selecting inbox (I guess
they do it just in case it didn't update). It might be because the status bar
doesn't show "No new messages" when the operation is completed quickly. It
might also be just a habit, because often the inbox is already selected and
then clicking it doesn't do anything. 

In any case I think getting new messages when selecting a folder is a good
thing. It helps keep the message list current.
Attachment #85474 - Flags: review+
(Assignee)

Comment 8

17 years ago
fix checked in.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.