[perf] not batching unread count updates on my IMAP inbox.

RESOLVED FIXED in mozilla1.1alpha

Status

RESOLVED FIXED
17 years ago
14 years ago

People

(Reporter: sspitzer, Assigned: Bienvenu)

Tracking

({perf, regression})

Trunk
mozilla1.1alpha
x86
Windows 2000
perf, regression

Firefox Tracking Flags

(Not tracked)

Details

not batching unread count updates on my IMAP inbox.

here's what I did:

exit mozilla, remove INBOX.msf and foobar.msf (foobar is a large folder, with 
lots of unread messages).

start up mail.  I have it set to get new messages, and it automatically selects 
my inbox at startup.  We seem to be updating the unread count one at a time.

note, when I select my foobar folder, we seem to do the proper batching.

I'll check to see if it only happens when I start up and I have new mail.
> I'll check to see if it only happens when I start up and I have new mail.

it turns out, I didn't have new mail.

I was just getting mscott's windows only alert: 

"New Messages
 sspitzer has n new messages"

where n was the number of messages in my Inbox.
(Assignee)

Comment 2

17 years ago
most likely same cause as bug 147896
Keywords: perf, regression
yes, this was fixed by #147896
Assignee: sspitzer → bienvenu
Target Milestone: --- → mozilla1.1alpha
fixed.

even though it was fixed by the other bug, not really a dup.

let's give bienvenu some bug fixing credit, and allow QA to verify that this is 
fixed as well.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Updated

16 years ago
QA Contact: olgam → laurel

Updated

16 years ago
QA Contact: laurel → gchan
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.