Intermittent valgrind-test | Conditional jump or move depends on uninitialised value(s) at style::properties::longhands::clip_path::cascade_property / style::properties::cascade_rules / ?!? / ?!?

RESOLVED FIXED in Firefox 63

Status

()

defect
P5
normal
RESOLVED FIXED
Last year
6 months ago

People

(Reporter: intermittent-bug-filer, Assigned: jseward)

Tracking

({intermittent-failure})

unspecified
mozilla63
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox63 fixed)

Details

(Whiteboard: [stockwell disable-recommended])

Attachments

(2 attachments)

Filed by: csabou [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=190546786&repo=autoland

https://queue.taskcluster.net/v1/task/QbVy3KcrT9KyXIA4EsnWeg/runs/0/artifacts/public/logs/live_backing.log

[task 2018-07-27T15:23:37.985Z] 15:23:37     INFO -   2:48.88 TEST-UNEXPECTED-FAIL | valgrind-test | Conditional jump or move depends on uninitialised value(s) at style::properties::longhands::clip_path::cascade_property / style::properties::cascade_rules / ?!? / ?!?
[task 2018-07-27T15:23:37.985Z] 15:23:37     INFO -   2:48.88 ==2114== Conditional jump or move depends on uninitialised value(s)
[task 2018-07-27T15:23:37.985Z] 15:23:37     INFO -   2:48.88 ==2114==    at 0x11EE6411: style::properties::longhands::clip_path::cascade_property (gecko_properties.rs:17149)
[task 2018-07-27T15:23:37.985Z] 15:23:37     INFO -   2:48.88 ==2114==    by 0x11DE79EF: style::properties::cascade_rules (properties.rs:85402)
[task 2018-07-27T15:23:37.985Z] 15:23:37     INFO -   2:48.88 ==2114==    by 0x11DE5702: <style::style_resolver::StyleResolverForElement<'a, 'ctx, 'le, E>>::cascade_style_and_visited (properties.rs:84889)
[task 2018-07-27T15:23:37.989Z] 15:23:37     INFO -   2:48.88 ==2114==    by 0x11DE4330: <style::style_resolver::StyleResolverForElement<'a, 'ctx, 'le, E>>::cascade_primary_style (style_resolver.rs:216)
[task 2018-07-27T15:23:37.989Z] 15:23:37     INFO -   2:48.88 ==2114==    by 0x11DE26A1: <style::style_resolver::StyleResolverForElement<'a, 'ctx, 'le, E>>::resolve_style (style_resolver.rs:175)
[task 2018-07-27T15:23:37.989Z] 15:23:37     INFO -   2:48.88 ==2114==    by 0x11DD0592: style::traversal::compute_style (style_resolver.rs:270)
[task 2018-07-27T15:23:37.989Z] 15:23:37     INFO -   2:48.88 ==2114==    by 0x11DCCA1B: geckoservo::glue::traverse_subtree (traversal.rs:434)
[task 2018-07-27T15:23:37.990Z] 15:23:37     INFO -   2:48.88 ==2114==    by 0x11DCC212: Servo_TraverseSubtree (glue.rs:351)
[task 2018-07-27T15:23:37.990Z] 15:23:37     INFO -   2:48.88 ==2114==    by 0x103E1087: mozilla::ServoStyleSet::StyleDocument(mozilla::ServoTraversalFlags) (ServoStyleSet.cpp:993)
[task 2018-07-27T15:23:37.990Z] 15:23:37     INFO -   2:48.88 ==2114==    by 0x1044CB54: mozilla::RestyleManager::DoProcessPendingRestyles(mozilla::ServoTraversalFlags) (RestyleManager.cpp:2966)
[task 2018-07-27T15:23:37.990Z] 15:23:37     INFO -   2:48.88 ==2114==    by 0x10456128: ProcessPendingRestyles (RestyleManager.cpp:3075)
[task 2018-07-27T15:23:37.990Z] 15:23:37     INFO -   2:48.88 ==2114==    by 0x10456128: mozilla::PresShell::DoFlushPendingNotifications(mozilla::ChangesToFlush) (PresShell.cpp:4292)
[task 2018-07-27T15:23:37.990Z] 15:23:37     INFO -   2:48.88 ==2114==    by 0xF03BBFB: FlushPendingNotifications (nsIPresShell.h:577)
[task 2018-07-27T15:23:37.990Z] 15:23:37     INFO -   2:48.88 ==2114==    by 0xF03BBFB: nsIDocument::FlushPendingNotifications(mozilla::ChangesToFlush) (nsDocument.cpp:7436)
[task 2018-07-27T15:23:37.991Z] 15:23:37     INFO -   2:48.88 ==2114==    by 0xF03BC88: nsIDocument::FlushPendingNotifications(mozilla::FlushType) (nsDocument.cpp:7375)
[task 2018-07-27T15:23:37.991Z] 15:23:37     INFO -   2:48.88 ==2114==    by 0xEAB54F8: nsDocLoader::DocLoaderIsEmpty(bool) [clone .part.74] (nsDocLoader.cpp:694)
[task 2018-07-27T15:23:37.991Z] 15:23:37     INFO -   2:48.88 ==2114==    by 0xEAB6075: DocLoaderIsEmpty (nsDocLoader.cpp:627)
[task 2018-07-27T15:23:37.991Z] 15:23:37     INFO -   2:48.88 ==2114==    by 0xEAB6075: nsDocLoader::OnStopRequest(nsIRequest*, nsISupports*, nsresult) (nsDocLoader.cpp:627)
[task 2018-07-27T15:23:37.991Z] 15:23:37     INFO -   2:48.88 ==2114==    by 0xE22E433: mozilla::net::nsLoadGroup::RemoveRequest(nsIRequest*, nsISupports*, nsresult) (nsLoadGroup.cpp:629)
[task 2018-07-27T15:23:37.991Z] 15:23:37     INFO -   2:48.88 ==2114==    by 0xEEC4ABE: imgRequestProxy::RemoveFromLoadGroup() [clone .part.59] (imgRequestProxy.cpp:445)
[task 2018-07-27T15:23:37.991Z] 15:23:37     INFO -   2:48.88 ==2114==    by 0xEEC5502: RemoveFromLoadGroup (imgRequestProxy.cpp:412)
[task 2018-07-27T15:23:37.991Z] 15:23:37     INFO -   2:48.88 ==2114==    by 0xEEC5502: imgRequestProxy::OnLoadComplete(bool) (imgRequestProxy.cpp:1114)
[task 2018-07-27T15:23:37.991Z] 15:23:37     INFO -   2:48.88 ==2114==    by 0xEEA4F71: operator() (ProgressTracker.cpp:358)
[task 2018-07-27T15:23:37.992Z] 15:23:37     INFO -   2:48.88 ==2114==    by 0xEEA4F71: operator()<mozilla::image::SyncNotifyInternal(const T&, bool, mozilla::image::Progress, const nsIntRect&) [with T = const mozilla::image::ObserverTable*]::<lambda(mozilla::image::IProgressObserver*)> > (ProgressTracker.cpp:283)
[task 2018-07-27T15:23:37.992Z] 15:23:37     INFO -   2:48.88 ==2114==    by 0xEEA4F71: void mozilla::image::SyncNotifyInternal<mozilla::image::ObserverTable const*>(mozilla::image::ObserverTable const* const&, bool, unsigned int, mozilla::gfx::IntRectTyped<mozilla::gfx::UnknownUnits> const&) (ProgressTracker.cpp:357)
[task 2018-07-27T15:23:37.992Z] 15:23:37     INFO -   2:48.88 ==2114==    by 0xEEA52A3: operator() (ProgressTracker.cpp:378)
[task 2018-07-27T15:23:37.992Z] 15:23:37     INFO -   2:48.88 ==2114==    by 0xEEA52A3: Read<mozilla::image::ProgressTracker::SyncNotifyProgress(mozilla::image::Progress, const nsIntRect&)::<lambda(const mozilla::image::ObserverTable*)> > (CopyOnWrite.h:179)
[task 2018-07-27T15:23:37.992Z] 15:23:37     INFO -   2:48.88 ==2114==    by 0xEEA52A3: mozilla::image::ProgressTracker::SyncNotifyProgress(unsigned int, mozilla::gfx::IntRectTyped<mozilla::gfx::UnknownUnits> const&) (ProgressTracker.cpp:379)
[task 2018-07-27T15:23:37.992Z] 15:23:37     INFO -   2:48.88 ==2114==    by 0xEEB691D: mozilla::image::VectorImage::OnSVGDocumentLoaded() (VectorImage.cpp:1469)
[task 2018-07-27T15:23:37.992Z] 15:23:37     INFO -   2:48.88 ==2114==    by 0xEEB6AB4: mozilla::image::SVGLoadEventListener::HandleEvent(mozilla::dom::Event*) (VectorImage.cpp:229)
[task 2018-07-27T15:23:37.992Z] 15:23:37     INFO -   2:48.88 ==2114==    by 0xFA5D2B0: mozilla::EventListenerManager::HandleEventSubType(mozilla::EventListenerManager::Listener*, mozilla::dom::Event*, mozilla::dom::EventTarget*) (EventListenerManager.cpp:1101)
[task 2018-07-27T15:23:37.992Z] 15:23:37     INFO -   2:48.88 ==2114==    by 0xFA5FA95: mozilla::EventListenerManager::HandleEventInternal(nsPresContext*, mozilla::WidgetEvent*, mozilla::dom::Event**, mozilla::dom::EventTarget*, nsEventStatus*, bool) (EventListenerManager.cpp:1333)
[task 2018-07-27T15:23:37.992Z] 15:23:37     INFO -   2:48.88 ==2114==    by 0xFA6068C: HandleEvent (EventListenerManager.h:391)
[task 2018-07-27T15:23:37.992Z] 15:23:37     INFO -   2:48.88 ==2114==    by 0xFA6068C: mozilla::EventTargetChainItem::HandleEvent(mozilla::EventChainPostVisitor&, mozilla::ELMCreationDetector&) (EventDispatcher.cpp:422)
[task 2018-07-27T15:23:37.993Z] 15:23:37     INFO -   2:48.88 ==2114==    by 0xFA60DA0: mozilla::EventTargetChainItem::HandleEventTargetChain(nsTArray<mozilla::EventTargetChainItem>&, mozilla::EventChainPostVisitor&, mozilla::EventDispatchingCallback*, mozilla::ELMCreationDetector&) (EventDispatcher.cpp:635)
[task 2018-07-27T15:23:37.993Z] 15:23:37     INFO -   2:48.88 ==2114==    by 0xFA6276C: mozilla::EventDispatcher::Dispatch(nsISupports*, nsPresContext*, mozilla::WidgetEvent*, mozilla::dom::Event*, nsEventStatus*, mozilla::EventDispatchingCallback*, nsTArray<mozilla::dom::EventTarget*>*) (EventDispatcher.cpp:1111)
[task 2018-07-27T15:23:37.993Z] 15:23:37     INFO -   2:48.88 ==2114==    by 0xFA62E47: mozilla::EventDispatcher::DispatchDOMEvent(nsISupports*, mozilla::WidgetEvent*, mozilla::dom::Event*, nsPresContext*, nsEventStatus*) (EventDispatcher.cpp:1191)
[task 2018-07-27T15:23:37.993Z] 15:23:37     INFO -   2:48.88 ==2114==    by 0xF081AC8: nsINode::DispatchEvent(mozilla::dom::Event&, mozilla::dom::CallerType, mozilla::ErrorResult&) (nsINode.cpp:1088)
[task 2018-07-27T15:23:37.993Z] 15:23:37     INFO -   2:48.88 ==2114==    by 0xFA51F54: mozilla::dom::EventTarget::DispatchEvent(mozilla::dom::Event&) (EventTarget.cpp:197)
[task 2018-07-27T15:23:37.993Z] 15:23:37     INFO -   2:48.88 ==2114==    by 0xFA3F465: mozilla::AsyncEventDispatcher::Run() (AsyncEventDispatcher.cpp:72)
[task 2018-07-27T15:23:37.993Z] 15:23:37     INFO -   2:48.88 ==2114==    by 0xE1A5B1C: nsThread::ProcessNextEvent(bool, bool*) [clone .part.267] (nsThread.cpp:1235)
[task 2018-07-27T15:23:37.993Z] 15:23:37     INFO -   2:48.88 ==2114==    by 0xE19DAEA: NS_ProcessNextEvent(nsIThread*, bool) (nsThreadUtils.cpp:519)
[task 2018-07-27T15:23:37.993Z] 15:23:37     INFO -   2:48.88 ==2114==    by 0xE600DD1: mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate*) (MessagePump.cpp:97)
[task 2018-07-27T15:23:37.993Z] 15:23:37     INFO -   2:48.88 ==2114==    by 0xE5D5851: RunInternal (message_loop.cc:325)
[task 2018-07-27T15:23:37.994Z] 15:23:37     INFO -   2:48.88 ==2114==    by 0xE5D5851: RunHandler (message_loop.cc:318)
[task 2018-07-27T15:23:37.994Z] 15:23:37     INFO -   2:48.88 ==2114==    by 0xE5D5851: MessageLoop::Run() (message_loop.cc:298)
[task 2018-07-27T15:23:37.994Z] 15:23:37     INFO -   2:48.88 ==2114==    by 0x10296688: nsBaseAppShell::Run() (nsBaseAppShell.cpp:158)
[task 2018-07-27T15:23:37.994Z] 15:23:37     INFO -   2:48.88 ==2114==  Uninitialised value was created by a stack allocation
[task 2018-07-27T15:23:37.994Z] 15:23:37     INFO -   2:48.88 ==2114==    at 0x11F14710: <style::values::generics::basic_shape::BasicShape<H, V, LengthOrPercentage> as style::values::computed::ToComputedValue>::to_computed_value (basic_shape.rs:62)
[task 2018-07-27T15:23:37.994Z] 15:23:37     INFO -   2:48.88 ==2114==
[task 2018-07-27T15:23:37.994Z] 15:23:37     INFO -   2:48.88 {
Emilio, could you take a look at these kind of failures? Thank you.
Flags: needinfo?(emilio)
Looks like a likely false-positive... A lot of build-system patches from glandium landed near the revision from comment 0.

Mike, has there been a rust build change or something recently?
Flags: needinfo?(emilio) → needinfo?(mh+mozilla)
Bug 1478917 only affects mac builds.
Bug 1478919 only affects the spidermonkey tsan builds.

Neither can be related.
Flags: needinfo?(mh+mozilla)
Neither of the changes in the commit log from comment 6 is related to the code in question.  How sure are we of that regression range?
Flags: needinfo?(bzbarsky) → needinfo?(apavel)
I just did more retriggers there, and the same failure shows up on the push before mine too.
Flags: needinfo?(apavel)
(In reply to Boris Zbarsky [:bz] (no decent commit message means r-) from comment #11)
> I just did more retriggers there, and the same failure shows up on the push
> before mine too.

:( i will keep investigating this. Thank you for looking into it.
Flags: needinfo?(apavel)
This does indeed look like it was introduced by bug 1474414, which moved activity stream from a system add-on to a plain browser component. Reverting it does make the failure go away, but only because add-ons don't get loaded when running this test:

addons.xpi-utils	WARN	addMetadata: Add-on activity-stream@mozilla.org is invalid: [Exception... "Component returned failure code: 0x80520006 (NS_ERROR_FILE_TARGET_DOES_NOT_EXIST) [nsIFile.isFile]"

So assuming the test does want to load about:home (??) and its related styles, the error does point at one particular rule:

Conditional jump or move depends on uninitialised value(s) at style::properties::longhands::clip_path::cascade_property / style::properties::cascade_rules

https://searchfox.org/mozilla-central/rev/d0a0ae30d534dc55e712bd3eedc1b4553ba56323/browser/components/newtab/css/activity-stream-linux.css#1487
clip-path: inset(-1px -1px 4px);

That was added in bug 1465623 https://github.com/mozilla/activity-stream/pull/4186

Removing that one clip-path declaration does make the failure go away:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=5ba48800dcfbd96e9d5f2b9216efeede5b882e5b

emilio, is this something to fix in servo?
Component: General → CSS Parsing and Computation
Depends on: 1465623, 1474414
Flags: needinfo?(edilee) → needinfo?(emilio)
Given clip-path parsing is written in rust I'm moderately sure this is another false positive from valgrind like the ones we already have:

  https://searchfox.org/mozilla-central/rev/d0a0ae30d534dc55e712bd3eedc1b4553ba56323/build/valgrind/x86_64-pc-linux-gnu.sup#888

I can land the annotation, but maybe Julian wants to take a deeper look at this? It's really weird that's intermittent.
Flags: needinfo?(emilio) → needinfo?(jseward)
Julian, there are 110 total failures in the last 7 days, all on linux64, can you take a look?
Considering current valgrind git trunk has fixed many of those false positives, how about we upgrade to the current git trunk and see if that makes this one go away?

Julian, what do you think?
Attachment #8999133 - Flags: review?(core-build-config-reviews)
Attachment #8999133 - Flags: feedback?(jseward)
I think upgrading to the V trunk is worth trying, since there have been
false-positive fixes pushed in there in the past few months, especially
for x86_64-linux.

I'm not entirely sure what you're asking me w.r.t. the patch.  It looks
huge and, I'd guess, is a delta between the current trunk and .. what
currently we're using, or something like that?
Flags: needinfo?(jseward)
(In reply to Julian Seward [:jseward] from comment #24)
> I think upgrading to the V trunk is worth trying, since there have been
> false-positive fixes pushed in there in the past few months, especially
> for x86_64-linux.
> 
> I'm not entirely sure what you're asking me w.r.t. the patch.  It looks
> huge and, I'd guess, is a delta between the current trunk and .. what
> currently we're using, or something like that?

I'm not asking anything wrt the patch itself. FWIW, it's large because it *removes* a large patch for https://bugs.kde.org/show_bug.cgi?id=79362.
Comment on attachment 8999133 [details] [diff] [review]
Upgrade valgrind to current git trunk

Review of attachment 8999133 [details] [diff] [review]:
-----------------------------------------------------------------

::: taskcluster/ci/packages/kind.yml
@@ +155,5 @@
> +        git -C ../valgrind-git archive --format=tar --prefix=valgrind-$VERSION/ $COMMIT | bzip2 > ../valgrind_$VERSION.orig.tar.bz2 &&
> +        tar -C .. -jxf ../valgrind_$VERSION.orig.tar.bz2 &&
> +        cp -r debian ../valgrind-$VERSION &&
> +        cd ../valgrind-$VERSION &&
> +        debchange -v 1:$VERSION-1.deb7moz1 --distribution wheezy "Mozilla backport of git master as of 2018-08-06." < /dev/null

I feel like including a giant chunk of shell in .yml files goes against the grain of what these were intended for. =/
Attachment #8999133 - Flags: review?(core-build-config-reviews) → review+
It's a one-off until valgrind 3.14 is released.
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d6db6699e050
Upgrade valgrind to current git trunk. r=froydnj
https://hg.mozilla.org/mozilla-central/rev/d6db6699e050
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
Even after the merge the failure is still occurring.
Failure log:
https://treeherder.mozilla.org/logviewer.html#?job_id=193825736&repo=autoland&lineNumber=42181

[task 2018-08-14T10:23:46.360Z] 10:23:46     INFO -   1:49.31 --3746-- REDIR: 0x5cf9120 (libc.so.6:mempcpy) redirected to 0x4a227e0 (_vgnU_ifunc_wrapper)
[task 2018-08-14T10:23:46.360Z] 10:23:46     INFO -   1:49.31 --3746-- REDIR: 0x5d9bca0 (libc.so.6:__mempcpy_ssse3) redirected to 0x4c30120 (mempcpy)
[task 2018-08-14T10:23:46.376Z] 10:23:46     INFO -   1:49.32 --3746-- REDIR: 0x5cf7fe0 (libc.so.6:__GI_memcmp) redirected to 0x4c2eb30 (__GI_memcmp)
[task 2018-08-14T10:23:53.245Z] 10:23:53     INFO -   1:56.19 --3746-- memcheck GC: 75301 nodes, 39608 survivors (52.6%)
[task 2018-08-14T10:23:53.245Z] 10:23:53     INFO -   1:56.19 --3746-- memcheck GC: 106491 new table size (stepup)
[task 2018-08-14T10:24:10.112Z] 10:24:10     INFO -   2:13.05 --3746-- memcheck GC: 106491 nodes, 30103 survivors (28.3%)
[task 2018-08-14T10:24:23.779Z] 10:24:23     INFO -   2:26.72 --3746-- memcheck GC: 106491 nodes, 37501 survivors (35.2%)
[task 2018-08-14T10:24:24.497Z] 10:24:24     INFO -   2:27.44 1534242264481	addons.xpi	WARN	Can't get modified time of /builds/worker/workspace/build/src/obj-firefox/dist/bin/browser/features/aushelper@mozilla.org.xpi
[task 2018-08-14T10:24:24.505Z] 10:24:24     INFO -   2:27.45 1534242264497	addons.xpi	WARN	Can't get modified time of /builds/worker/workspace/build/src/obj-firefox/dist/bin/browser/features/firefox@getpocket.com.xpi
[task 2018-08-14T10:24:24.512Z] 10:24:24     INFO -   2:27.46 1534242264505	addons.xpi	WARN	Can't get modified time of /builds/worker/workspace/build/src/obj-firefox/dist/bin/browser/features/formautofill@mozilla.org.xpi
[task 2018-08-14T10:24:24.527Z] 10:24:24     INFO -   2:27.47 1534242264513	addons.xpi	WARN	Can't get modified time of /builds/worker/workspace/build/src/obj-firefox/dist/bin/browser/features/fxmonitor@mozilla.org.xpi
[task 2018-08-14T10:24:24.528Z] 10:24:24     INFO -   2:27.47 1534242264521	addons.xpi	WARN	Can't get modified time of /builds/worker/workspace/build/src/obj-firefox/dist/bin/browser/features/onboarding@mozilla.org.xpi
[task 2018-08-14T10:24:24.568Z] 10:24:24     INFO -   2:27.51 1534242264530	addons.xpi	WARN	Can't get modified time of /builds/worker/workspace/build/src/obj-firefox/dist/bin/browser/features/screenshots@mozilla.org.xpi
[task 2018-08-14T10:24:24.583Z] 10:24:24     INFO -   2:27.53 1534242264572	addons.xpi	WARN	Can't get modified time of /builds/worker/workspace/build/src/obj-firefox/dist/bin/browser/features/webcompat-reporter@mozilla.org.xpi
[task 2018-08-14T10:24:24.584Z] 10:24:24     INFO -   2:27.53 1534242264580	addons.xpi	WARN	Can't get modified time of /builds/worker/workspace/build/src/obj-firefox/dist/bin/browser/features/webcompat@mozilla.org.xpi
[task 2018-08-14T10:24:34.199Z] 10:24:34     INFO -   2:37.14 --3746-- memcheck GC: 106491 nodes, 40606 survivors (38.1%)
[task 2018-08-14T10:24:43.631Z] 10:24:43     INFO -   2:46.57 --3746-- memcheck GC: 106491 nodes, 34418 survivors (32.3%)
[task 2018-08-14T10:24:51.923Z] 10:24:51     INFO -   2:54.87 TEST-UNEXPECTED-FAIL | valgrind-test | Conditional jump or move depends on uninitialised value(s) at style::properties::longhands::clip_path::cascade_property / style::properties::cascade_rules / ?!? / ?!?
[task 2018-08-14T10:24:51.923Z] 10:24:51     INFO -   2:54.87 ==3746== Conditional jump or move depends on uninitialised value(s)
[task 2018-08-14T10:24:51.923Z] 10:24:51     INFO -   2:54.87 ==3746==    at 0x11E6D7B1: style::properties::longhands::clip_path::cascade_property (gecko_properties.rs:17152)
[task 2018-08-14T10:24:51.923Z] 10:24:51     INFO -   2:54.87 ==3746==    by 0x11D6320D: style::properties::cascade_rules (properties.rs:83642)
[task 2018-08-14T10:24:51.923Z] 10:24:51     INFO -   2:54.87 ==3746==    by 0x11D612C2: <style::style_resolver::StyleResolverForElement<'a, 'ctx, 'le, E>>::cascade_style_and_visited (properties.rs:83129)
[task 2018-08-14T10:24:51.923Z] 10:24:51     INFO -   2:54.87 ==3746==    by 0x11D60020: <style::style_resolver::StyleResolverForElement<'a, 'ctx, 'le, E>>::cascade_primary_style (style_resolver.rs:216)
[task 2018-08-14T10:24:51.923Z] 10:24:51     INFO -   2:54.87 ==3746==    by 0x11D5E721: <style::style_resolver::StyleResolverForElement<'a, 'ctx, 'le, E>>::resolve_style (style_resolver.rs:175)
[task 2018-08-14T10:24:51.923Z] 10:24:51     INFO -   2:54.87 ==3746==    by 0x11D4CC12: style::traversal::compute_style (style_resolver.rs:270)
[task 2018-08-14T10:24:51.924Z] 10:24:51     INFO -   2:54.87 ==3746==    by 0x11D490AB: geckoservo::glue::traverse_subtree (traversal.rs:434)
[task 2018-08-14T10:24:51.924Z] 10:24:51     INFO -   2:54.87 ==3746==    by 0x11D488A2: Servo_TraverseSubtree (glue.rs:351)
[task 2018-08-14T10:24:51.924Z] 10:24:51     INFO -   2:54.87 ==3746==    by 0x103607C7: mozilla::ServoStyleSet::StyleDocument(mozilla::ServoTraversalFlags) (ServoStyleSet.cpp:993)
[task 2018-08-14T10:24:51.924Z] 10:24:51     INFO -   2:54.87 ==3746==    by 0x103CC944: mozilla::RestyleManager::DoProcessPendingRestyles(mozilla::ServoTraversalFlags) (RestyleManager.cpp:3025)
[task 2018-08-14T10:24:51.924Z] 10:24:51     INFO -   2:54.87 ==3746==    by 0x103D6188: ProcessPendingRestyles (RestyleManager.cpp:3134)
[task 2018-08-14T10:24:51.924Z] 10:24:51     INFO -   2:54.87 ==3746==    by 0x103D6188: mozilla::PresShell::DoFlushPendingNotifications(mozilla::ChangesToFlush) (PresShell.cpp:4297)
[task 2018-08-14T10:24:51.924Z] 10:24:51     INFO -   2:54.87 ==3746==    by 0xEFB746B: FlushPendingNotifications (nsIPresShell.h:577)
[task 2018-08-14T10:24:51.924Z] 10:24:51     INFO -   2:54.87 ==3746==    by 0xEFB746B: nsIDocument::FlushPendingNotifications(mozilla::ChangesToFlush) (nsDocument.cpp:7443)
[task 2018-08-14T10:24:51.925Z] 10:24:51     INFO -   2:54.87 ==3746==    by 0xEFB74F8: nsIDocument::FlushPendingNotifications(mozilla::FlushType) (nsDocument.cpp:7382)
[task 2018-08-14T10:24:51.925Z] 10:24:51     INFO -   2:54.87 ==3746==    by 0xEA3D388: nsDocLoader::DocLoaderIsEmpty(bool) [clone .part.74] (nsDocLoader.cpp:694)
[task 2018-08-14T10:24:51.925Z] 10:24:51     INFO -   2:54.87 ==3746==    by 0xEA3DF05: DocLoaderIsEmpty (nsDocLoader.cpp:627)
[task 2018-08-14T10:24:51.925Z] 10:24:51     INFO -   2:54.87 ==3746==    by 0xEA3DF05: nsDocLoader::OnStopRequest(nsIRequest*, nsISupports*, nsresult) (nsDocLoader.cpp:627)
[task 2018-08-14T10:24:51.925Z] 10:24:51     INFO -   2:54.87 ==3746==    by 0xE1A3503: mozilla::net::nsLoadGroup::RemoveRequest(nsIRequest*, nsISupports*, nsresult) (nsLoadGroup.cpp:629)
[task 2018-08-14T10:24:51.925Z] 10:24:51     INFO -   2:54.87 ==3746==    by 0xEE3FF6E: imgRequestProxy::RemoveFromLoadGroup() [clone .part.59] (imgRequestProxy.cpp:441)
[task 2018-08-14T10:24:51.925Z] 10:24:51     INFO -   2:54.87 ==3746==    by 0xEE409B2: RemoveFromLoadGroup (imgRequestProxy.cpp:408)
[task 2018-08-14T10:24:51.925Z] 10:24:51     INFO -   2:54.87 ==3746==    by 0xEE409B2: imgRequestProxy::OnLoadComplete(bool) (imgRequestProxy.cpp:1110)
[task 2018-08-14T10:24:51.925Z] 10:24:51     INFO -   2:54.87 ==3746==    by 0xEE20461: operator() (ProgressTracker.cpp:358)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to Tiberius Oros[:tiberius_oros] from comment #33)
> Even after the merge the failure is still occurring.

Right.  So we're going to have to land a suppression, as suggested
by Emilio in comment 16.  I can prepare a patch, but it'll be a bit
tricky to test, given that the failure is intermittent.  I suppose
I can retrigger the V run on automation, say, 50 times.
Julian:  The failure, though intermittent, has a high occurrence rate, most likely in the first 5 retriggers you have a result.
(In reply to Julian Seward [:jseward] from comment #36)
> Created attachment 9000059 [details] [diff] [review]
> Suppress the false positive in
> style::properties::longhands::clip_path::cascade_property

Before: https://treeherder.mozilla.org/#/jobs?repo=try&revision=a85b23a47c849fb5c605366e52d0c6c160eb7e1c
25 fails in 30 runs

After: https://treeherder.mozilla.org/#/jobs?repo=try&revision=d0e5e4a7c9e01650d1b3a440d7170b5730bab515
No fails in 30 runs
Attachment #9000059 - Flags: review?(emilio)
Comment on attachment 9000059 [details] [diff] [review]
Suppress the false positive in style::properties::longhands::clip_path::cascade_property

Review of attachment 9000059 [details] [diff] [review]:
-----------------------------------------------------------------

::: build/valgrind/x86_64-pc-linux-gnu.sup
@@ +352,5 @@
> +# Conditional jump or move depends on uninitialised value(s)
> +#    at style::[..]::clip_path::cascade_property (gecko_properties.rs:17152)
> +#    by style::properties::cascade_rules (properties.rs:83642)
> +#    by [..]::cascade_style_and_visited (properties.rs:83129)
> +#    by [..]::cascade_primary_style (style/style_resolver.rs:216)

Maybe this comment should point to the bug?
Attachment #9000059 - Flags: review?(emilio) → review+
Pushed by jseward@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/c7d7fe608132
Suppress Valgrind false positive in style::properties::longhands::clip_path::cascade_property.  r=emilio.
https://hg.mozilla.org/mozilla-central/rev/c7d7fe608132
Status: REOPENED → RESOLVED
Closed: Last yearLast year
Resolution: --- → FIXED
Assignee: nobody → jseward
(In reply to Intermittent Failures Robot from comment #42)
> For more details, see:
> https://treeherder.mozilla.org/intermittent-failures.html#/
> bugdetails?bug=1479055&startday=2018-08-13&endday=2018-08-19&tree=all

Per the above link, the orange count per push went to zero on Aug 16,
which is pretty much at the point where the comment 36 patch hit m-c.
So I think we're good here.
Attachment #8999133 - Flags: feedback?(jseward)
You need to log in before you can comment on or make changes to this bug.