Scrollbar sometimes misplaced going back

VERIFIED FIXED in Chimera0.4

Status

Camino Graveyard
Page Layout
--
major
VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: Chris Petersen, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

unspecified
Chimera0.4
PowerPC
Mac OS X

Details

(URL)

(Reporter)

Description

16 years ago
It seems that when you scroll down a page for a link to render another page from
and then select back to go to the original page that was still at the same
scroll position you scrolled to, after you mouse click the vertical scroll bar
to navigate once again it makes the original page go back to the top instead of
staying where you had it scrolled to.
(Reporter)

Comment 1

16 years ago
------- Additional Comments From Mike Potter 2002-05-07 18:11 -------

Holy cow, I don't know what that sentence means... Here's what I see:
1.  Go to slashdot.org
2.  Scroll down.
3.  Follow a link.
4.  Click back.
5.  Notice that the scroll bar is at the top of the page, not where it was when
you left the slashdot.org site.

(Reporter)

Comment 2

16 years ago
Still occurs in 0.2.8

Comment 3

16 years ago
I believe scrolled position is part of history, although I'm not sure if the
responsibility is on Gecko to scroll to it (I would assume so) or on the
embedding client app. CC'ing Radha for enlightenment

Comment 4

16 years ago
->pinkerton
Assignee: saari → pinkerton
(Assignee)

Comment 5

16 years ago
yeah, this is the same as mozdev bug 1048.
Status: NEW → ASSIGNED
The responsibility to scroll to the previous position belongs to  Gecko, however
session history gives the layout engine the things it needs to scroll to the
previous position. I have seen this bug before. This is probably a dupe of
something I have. I think the issue with slashdot.org is, it either generates 
dynamic pages or changes too frequently that gecko can't find the previous
location in the page while going back.

Comment 7

16 years ago
*** Bug 148743 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

16 years ago
Target Milestone: --- → Chimera0.4

Comment 8

16 years ago
*** Bug 150522 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 9

16 years ago
*** Bug 151035 has been marked as a duplicate of this bug. ***

Comment 10

16 years ago
http://mozdev.org/bugs/show_bug.cgi?id=1048 is a dupe of this bug.
(Assignee)

Comment 11

16 years ago
fwiw, this doesn't always happen. just sometimes.
Summary: Scroll Bar bug → Scrollbar sometimes misplaced going back

Comment 12

16 years ago
*** Bug 151618 has been marked as a duplicate of this bug. ***

Comment 13

16 years ago
*** Bug 152680 has been marked as a duplicate of this bug. ***

Comment 14

16 years ago
*** Bug 152828 has been marked as a duplicate of this bug. ***

Comment 15

16 years ago
*** Bug 153097 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 16

16 years ago
fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 17

16 years ago
Awesome... Verified in the 2002-06-21-05 NB.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.