Favorites toolbar draws on top of web page when window is made small

VERIFIED FIXED

Status

Camino Graveyard
Page Layout
VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: Chris Petersen, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
When you have many bookmarks in the favorites toolbar and you make
the window small the bookmarks shift down and cover the web page.
This happens on virtually all small windows.  The severity of the coverage
varies with each time the window is made small.  Making the window
large again does not fix the problem.  You must close the window and
open a new one.
(Reporter)

Comment 1

16 years ago
Very reproducable in 0.2.8

Comment 2

16 years ago
->pinkerton
Assignee: saari → pinkerton
(Assignee)

Comment 3

16 years ago
i see nothing wrong here. the toolbar wraps. should it not wrap? the content
doesn't get covered at all.
(Reporter)

Comment 4

16 years ago
After resizing the window multiple times,I see the problem shown in the attachment.
(Reporter)

Comment 5

16 years ago
After resizing multiple times, the toolbar bookmarks will start to "float" over
top of page. See second attachment.
(Reporter)

Comment 6

16 years ago
Created attachment 85473 [details]
Screen shot of floating toolbar bookmarks
(Assignee)

Comment 7

16 years ago
petersen, is this webpage-dependent? i can't dupe it with www.mozilla.org.
(Reporter)

Comment 8

16 years ago
No, doesn't seem to be web page specific.
(Reporter)

Comment 9

16 years ago
Additional steps to reproduce:

1) Launch Chimera
2) Drag numerous bookmarks to personal toolbar so that it wraps down to the next
line.
3) Resize the browser window to the smallest possible size. This causes the 
toolbar bookmarks to wrap in window.
4) Now, resize window back to original size.
5) Bookmarks float off the toolbar and are placed over page.

Occurs on two different G4's (Dual 800 and Single 933), OS X 10.1.4

Comment 10

16 years ago
The bug is only reproducable when you make the window small quickly.  If 
you make the window small slowly the bug does not appear.  Grab the 
resize box and make the window small as fast as you can.
(Assignee)

Comment 11

16 years ago
ah-ha! yes, i see this now. the trick is going _FAST_. smells like a cocoa bug
to me, i'm not sure if we even have any code that does this ourselves. i'll
check the  autosizing, but...
Status: NEW → ASSIGNED
(Assignee)

Comment 12

16 years ago
got it. much better now. fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 13

16 years ago
Marking verified in 2002-06-04-05 nightly trunk build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.