on imap INBOX discovery, I get a "New Messages" alert with the wrong number of messages

RESOLVED EXPIRED

Status

RESOLVED EXPIRED
17 years ago
9 years ago

People

(Reporter: sspitzer, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

on imap INBOX discovery, I get an alert "New Messages, sspitzer has <n> new 
messages" where <n> is the total number of messages in my inbox, instead of the 
new number.

to reproduce:

exit mozilla
remove INBOX.msf
mozilla -mail

I have it set to check for new messages at the start, and this is on my default 
inbox.

Updated

17 years ago
QA Contact: olgam → stephend
Seth, after deleting your INBOX.msf, and then launching mail, do you also get a
blank inbox?  I have to switch folders before I can see any messages.  I also
see your problem too.
Nevermind; my problem is covered by bug 147896.  Sorry for the noise.

Comment 4

14 years ago
I'm using Mozilla 1.7.3 and in between sessions are deleting my profile. This 
is intention. When I reconnect to the server and get my mail on startup, 
the 'Jane Doe has XX new messages' appears. It calculates the entire number of 
messages in the folder, not just those that are new.

Comment 5

14 years ago
It counts the number of unread messages that it hasn't seen before. If you've
deleted your profile, that will be the total unread messages...the \RECENT flag
from the imap server is not reliable.

Comment 6

14 years ago
I've read the RFC and it says that if an email can't be considered "Recent"
because the server doesn't support it, then it should be considered recent by
the mail client.

I shall contact the manufacturers of the mail server I'm using now, which is a
massive company with a very expensive mail server product (so I'm surprised if
it's the server which is faulty but are willing to look down that avenue).

I'll get back to you guys.
Product: Browser → Seamonkey
Assignee: mscott → mail
QA Contact: stephend → search

Comment 7

10 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED
Assignee: mail → nobody
QA Contact: search → message-display

Comment 8

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → EXPIRED
You need to log in before you can comment on or make changes to this bug.