bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Search sidebar should have 'find in page' controls

RESOLVED DUPLICATE of bug 64984

Status

SeaMonkey
Search
--
enhancement
RESOLVED DUPLICATE of bug 64984
16 years ago
10 years ago

People

(Reporter: Seb Wills, Assigned: Samir Gehani)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Often people do a search-engine search for specific terms, then want to locate
where in the resulting documents those terms actually appear.

A nice way to do this would be if, in the search sidebar, there was an easy way
to do the action "find this search term in the currently displayed document".

The 'cleanest' (but not the most noticable) way to do this would be that if you
right-click on a word 'word' in the search terms textbox in the search sidebar,
one of the menu options could be "find 'word' in current page".

The Google toolbar for Internet Explorer does a similar thing but implemented
differently: for every word currently in their search terms textbox, there is a
button on the toolbar containing that word, which does a "find in page" when
pressed. (For a screenshot, see http://toolbar.google.com/ - on the very right
of the image of the toolbar you can see the "stanford" button corresponding to
the fact that "stanford" is entered into the search box in the screenshot.)
But it's difficult to see how that implementation (with a button for each search
word) would fit neatly on a sidebar with a vertical aspect ratio.
(Reporter)

Comment 1

16 years ago
Another neat way to implement this feature would be to use a menubutton control,
with the icon being a "find in page" icon and the menu items being the words of
the search query.

Comment 2

16 years ago

*** This bug has been marked as a duplicate of 64984 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.