Closed Bug 1479463 Opened 3 years ago Closed 3 years ago

For RSS account type, Remove "Check for new articles at startup"

Categories

(Thunderbird :: Preferences, defect)

x86_64
All
defect
Not set
normal

Tracking

(thunderbird_esr6062+ fixed, thunderbird63 fixed)

RESOLVED FIXED
Thunderbird 63.0
Tracking Status
thunderbird_esr60 62+ fixed
thunderbird63 --- fixed

People

(Reporter: wsmwk, Assigned: alta88)

Details

Attachments

(1 file)

From Bug #1479434 "Check for new articles at startup is a legacy thing which I should have removed. About a minute after startup, all feeds are now checked to see if their update frequency has expired and pause state.  So check at startup is pretty useless."
Assignee: nobody → alta88
Attachment #8996140 - Flags: review?(mkmelin+mozilla)
Comment on attachment 8996140 [details] [diff] [review]
nofeedLoginAtStartup.patch

Review of attachment 8996140 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM, thanks! r=mkmelin
Attachment #8996140 - Flags: review?(mkmelin+mozilla) → review+
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/d4d13b229f99
For RSS account type, remove 'Check for new articles at startup'. r=mkmelin
Status: NEW → RESOLVED
Closed: 3 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 63.0
Comment on attachment 8996140 [details] [diff] [review]
nofeedLoginAtStartup.patch

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: crash in Subscribe dialog UI in certain cases.
Testing completed (on c-c, etc.):  manual.
Risk to taking this patch (and alternatives if risky): very low.

I think the tracking flag was the wrong thing to set as it's not being noticed. Anyway, the major thing here is getting rid of useless UI, but the more important thing is the lines in feed-subscriptions.js which fixes making the UI unusable sometimes.
Attachment #8996140 - Flags: approval-comm-esr60?
Comment on attachment 8996140 [details] [diff] [review]
nofeedLoginAtStartup.patch

Indeed, I didn't notice the flag. I'll ship it in TB 60.2.1 RSN(TM) ;-)
Attachment #8996140 - Flags: approval-comm-esr60? → approval-comm-esr60+
TB 60.2 ESR:
https://hg.mozilla.org/releases/comm-esr60/rev/d10016aa761f650b158d7a088e1d7518069ff968

I hope no one gets upset about the string *removals*.

Oh, the flag would have been tracking-thunderbird_esr60.
thanks.
You need to log in before you can comment on or make changes to this bug.